Update to 0.8.3

Pass maintainerhsip to submitter

PR:		ports/151753
Submitted by:	Chris Petrik <c.petrik.sosa at gmail.com>
This commit is contained in:
Max Brazhnikov 2010-11-30 08:02:25 +00:00
parent 30fa6d4cf8
commit 6ea9c1a025
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=265436
4 changed files with 51 additions and 71 deletions

View File

@ -6,18 +6,17 @@
#
PORTNAME= peekabot
PORTVERSION= 0.7.2
PORTREVISION= 4
PORTVERSION= 0.8.3
CATEGORIES= science
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.7.x/ \
http://distfiles.officialunix.com/
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}.x/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= c.petrik.sosa@gmail.com
COMMENT= Distributed real-time 3D visualization tool for robotics researchers
LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost-libs \
xerces-c.27:${PORTSDIR}/textproc/xerces-c2\
fltk.1:${PORTSDIR}/x11-toolkits/fltk
xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
fltk.1:${PORTSDIR}/x11-toolkits/fltk \
gtkglextmm-x11-1.2:${PORTSDIR}/x11-toolkits/gtkglextmm
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="`fltk-config --ldflags`" \
@ -25,19 +24,14 @@ CONFIGURE_ENV= LDFLAGS="`fltk-config --ldflags`" \
USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack
#Internal compiler error with < 4.4
USE_GCC= 4.4+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700042
USE_GCC= 4.2+
.endif
.if ${ARCH} == "sparc64"
BROKEN= does not compile with boost on sparc64
.endif
post-patch:
${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
${WRKSRC}/src/3rdparty/png++/io_base.hpp
.include <bsd.port.post.mk>

View File

@ -1,3 +1,2 @@
MD5 (peekabot-0.7.2.tar.bz2) = 091f588e3b1931de2454539c797f7526
SHA256 (peekabot-0.7.2.tar.bz2) = aa27e4082bb42cdc770d0090aae96b74b8a7014d8a36325e69b8d1553a4ff7b4
SIZE (peekabot-0.7.2.tar.bz2) = 2546064
SHA256 (peekabot-0.8.3.tar.bz2) = 156760cc0255bcec697b0fc3a4df89fadf4a0e042d925606fe787b8df27c966a
SIZE (peekabot-0.8.3.tar.bz2) = 2713734

View File

@ -1,14 +0,0 @@
--- src/3rdparty/png++/config.hpp.orig 2009-06-15 02:57:01.000000000 +0400
+++ src/3rdparty/png++/config.hpp 2009-06-22 02:47:55.000000000 +0400
@@ -47,6 +47,11 @@
#include <machine/endian.h>
#include <sys/_endian.h>
+#elif defined(__FreeBSD__)
+
+#include <machine/endian.h>
+#include <sys/endian.h>
+
#else
#error Byte-order could not be detected.

View File

@ -2,11 +2,10 @@ bin/obj2pbmf
bin/peekabot
include/peekabot.hh
include/peekabot/Action.hh
include/peekabot/Any.hh
include/peekabot/Deprecated.hh
include/peekabot/Matrix.hh
include/peekabot/PathIdentifier.hh
include/peekabot/Types.hh
include/peekabot/Vector.hh
include/peekabot/Visibility.hh
include/peekabot/Version.hh
include/peekabot/client/DelayedDispatch.hh
@ -17,7 +16,6 @@ include/peekabot/client/PeekabotClient.hh
include/peekabot/client/Recording.hh
include/peekabot/client/Result.hh
include/peekabot/client/Status.hh
include/peekabot/client/any_dl.hpp
include/peekabot/client/proxies/CameraProxy.hh
include/peekabot/client/proxies/CircleProxy.hh
include/peekabot/client/proxies/CubeProxy.hh
@ -39,48 +37,46 @@ include/peekabot/client/proxies/ScalableProxy.hh
include/peekabot/client/proxies/SliderProxy.hh
include/peekabot/client/proxies/SphereProxy.hh
include/peekabot/client/proxies/VertexBasedProxy.hh
include/peekabot/client/proxies/OccupancyGrid3DProxy.hh
include/peekabot/client/proxies/TriMeshProxy.hh
include/peekabot/client/proxies/PolylineProxy.hh
lib/libpeekabot.a
lib/libpeekabot.la
lib/libpeekabot.so
lib/libpeekabot.so.5
lib/libpeekabot.so.6
libdata/pkgconfig/peekabot.pc
%%DATADIR%%/data/default_scene.xml
%%DATADIR%%/fonts/COPYING
%%DATADIR%%/fonts/FreeSerif.ttf
%%DATADIR%%/images/add_camera.png
%%DATADIR%%/images/camera_object.png
%%DATADIR%%/images/camera_object2.png
%%DATADIR%%/images/camera_object3.png
%%DATADIR%%/images/circle_object.png
%%DATADIR%%/images/cont_snapshot.png
%%DATADIR%%/images/cube_object.png
%%DATADIR%%/images/cube_object_aa.png
%%DATADIR%%/images/cylinder_object.png
%%DATADIR%%/images/cylinder_object_aa.png
%%DATADIR%%/images/dof.png
%%DATADIR%%/images/grid.png
%%DATADIR%%/images/groundplane.png
%%DATADIR%%/images/group_object.png
%%DATADIR%%/images/label.png
%%DATADIR%%/images/light_object.png
%%DATADIR%%/images/line_cloud.png
%%DATADIR%%/images/locked.png
%%DATADIR%%/images/move.png
%%DATADIR%%/images/occupancy_grid_2d.png
%%DATADIR%%/images/ortho_mode.png
%%DATADIR%%/images/ortho_mode_aa.png
%%DATADIR%%/images/perspective_mode.png
%%DATADIR%%/images/perspective_mode_aa.png
%%DATADIR%%/images/point_cloud.png
%%DATADIR%%/images/polygon_object.png
%%DATADIR%%/images/polyline_object.png
%%DATADIR%%/images/polyline_object_aa.png
%%DATADIR%%/images/rotate.png
%%DATADIR%%/images/snapshot.png
%%DATADIR%%/images/snapshot_disabled.png
%%DATADIR%%/images/sphere_object.png
%%DATADIR%%/images/teapot.png
%%DATADIR%%/images/topdown.png
%%DATADIR%%/images/topdown_aa.png
%%DATADIR%%/icons/objects/camera-16.png
%%DATADIR%%/icons/objects/circle-16.png
%%DATADIR%%/icons/objects/cube-16.png
%%DATADIR%%/icons/objects/cylinder-16.png
%%DATADIR%%/icons/objects/dof-16.png
%%DATADIR%%/icons/objects/grid-16.png
%%DATADIR%%/icons/objects/label-16.png
%%DATADIR%%/icons/objects/line-cloud-16.png
%%DATADIR%%/icons/objects/model-16.png
%%DATADIR%%/icons/objects/og2d-16.png
%%DATADIR%%/icons/objects/og3d-16.png
%%DATADIR%%/icons/objects/point-cloud-16.png
%%DATADIR%%/icons/objects/polygon-16.png
%%DATADIR%%/icons/objects/polyline-16.png
%%DATADIR%%/icons/objects/sphere-16.png
%%DATADIR%%/icons/objects/tri-mesh-16.png
%%DATADIR%%/icons/log-22.png
%%DATADIR%%/icons/log-error-22.png
%%DATADIR%%/icons/move-tool-16.png
%%DATADIR%%/icons/move-tool-22.png
%%DATADIR%%/icons/navigate-tool-22.png
%%DATADIR%%/icons/ortho-16.png
%%DATADIR%%/icons/ortho-22.png
%%DATADIR%%/icons/rotate-tool-16.png
%%DATADIR%%/icons/rotate-tool-22.png
%%DATADIR%%/icons/screenshot-16.png
%%DATADIR%%/icons/screenshot-22.png
%%DATADIR%%/icons/top-down-16.png
%%DATADIR%%/icons/top-down-22.png
%%DATADIR%%/schemas/basic_types.xsd
%%DATADIR%%/schemas/camera.xsd
%%DATADIR%%/schemas/circle.xsd
@ -100,10 +96,15 @@ lib/libpeekabot.so.5
%%DATADIR%%/schemas/scene_object.xsd
%%DATADIR%%/schemas/slider.xsd
%%DATADIR%%/schemas/sphere.xsd
%%DATADIR%%/schemas/tri_mesh.xsd
%%DATADIR%%/schemas/polyline.xsd
%%DATADIR%%/peekabot.ui
@dirrm %%DATADIR%%/schemas
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%/fonts
@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%/icons/objects
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%
@dirrm include/peekabot/client/proxies
@dirrm include/peekabot/client