devel/fbthrift: Update 2021.04.12.00 -> 2021.04.19.00
This commit is contained in:
parent
834584e558
commit
6e80ffbbf3
@ -1,6 +1,6 @@
|
||||
PORTNAME= fbthrift
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 2021.04.12.00
|
||||
DISTVERSION= 2021.04.19.00
|
||||
CATEGORIES= devel
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1618268098
|
||||
SHA256 (facebook-fbthrift-v2021.04.12.00_GH0.tar.gz) = 64230e83b9ac00a18833ece0e70b8618ea44ee4725d2492ba62f9f2d7efffb29
|
||||
SIZE (facebook-fbthrift-v2021.04.12.00_GH0.tar.gz) = 5298222
|
||||
TIMESTAMP = 1618823176
|
||||
SHA256 (facebook-fbthrift-v2021.04.19.00_GH0.tar.gz) = ad2fef18e82d69583bcdf107e0c7600c48cd8bc125086932548e7115a656a4bc
|
||||
SIZE (facebook-fbthrift-v2021.04.19.00_GH0.tar.gz) = 5453537
|
||||
|
@ -1,27 +0,0 @@
|
||||
From 70a25a6f6d24fa8e9d8e7d4421a9e5cacf05a904 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Forney <mforney@mforney.org>
|
||||
Date: Fri, 9 Apr 2021 18:19:10 -0700
|
||||
Subject: [PATCH] Add missing dependency on RocketUpgrade headers to thriftcpp2
|
||||
target
|
||||
|
||||
One source file in this target, async/HeaderClientChannel.cpp,
|
||||
depends on the generated header RocketUpgradeAsyncClient.h, so it
|
||||
needs to depend on the target that generates this header.
|
||||
|
||||
This causes a build error with samurai due to an incorrect build
|
||||
order, and can be reproduced with ninja as well by building
|
||||
thrift/lib/cpp2/CMakeFiles/thriftcpp2.dir/async/HeaderClientChannel.cpp.o
|
||||
directly with an empty .ninja_deps.
|
||||
|
||||
https://github.com/facebook/fbthrift/pull/422
|
||||
|
||||
--- thrift/lib/cpp2/CMakeLists.txt.orig 2021-04-04 11:22:06 UTC
|
||||
+++ thrift/lib/cpp2/CMakeLists.txt
|
||||
@@ -208,6 +208,7 @@ add_dependencies(
|
||||
thriftcpp2
|
||||
rpcmetadata
|
||||
thriftmetadata
|
||||
+ RocketUpgrade-cpp2-target
|
||||
)
|
||||
target_link_libraries(
|
||||
thriftcpp2
|
@ -280,6 +280,7 @@ include/thrift/lib/cpp2/server/LoggingEvent.h
|
||||
include/thrift/lib/cpp2/server/LoggingEventHelper.h
|
||||
include/thrift/lib/cpp2/server/MonitoringMethodNames.h
|
||||
include/thrift/lib/cpp2/server/MonitoringServerInterface.h
|
||||
include/thrift/lib/cpp2/server/PreprocessParams.h
|
||||
include/thrift/lib/cpp2/server/QIAdmissionController.h
|
||||
include/thrift/lib/cpp2/server/RequestDebugLog.h
|
||||
include/thrift/lib/cpp2/server/RequestsRegistry.h
|
||||
@ -377,6 +378,7 @@ include/thrift/lib/cpp2/util/Ewma.h
|
||||
include/thrift/lib/cpp2/util/EwmaRate.h
|
||||
include/thrift/lib/cpp2/util/Frozen2ViewHelpers.h
|
||||
include/thrift/lib/cpp2/util/ManagedStringView.h
|
||||
include/thrift/lib/cpp2/util/MethodMetadata.h
|
||||
include/thrift/lib/cpp2/util/ScopedServerInterfaceThread-inl.h
|
||||
include/thrift/lib/cpp2/util/ScopedServerInterfaceThread.h
|
||||
include/thrift/lib/cpp2/util/ScopedServerThread.h
|
||||
@ -397,6 +399,7 @@ include/thrift/lib/py3/stream.h
|
||||
include/thrift/lib/py3/test/BinaryTypes.h
|
||||
include/thrift/lib/py3/test/client_event_handlers/handler.h
|
||||
include/thrift/lib/py3/test/cpp_handler.h
|
||||
include/thrift/lib/py3/test/interactions/interaction_test.h
|
||||
include/thrift/lib/py3/test/is_overload/func.h
|
||||
include/thrift/lib/py3/test/stream/server.h
|
||||
include/thrift/lib/py3/types.h
|
||||
|
Loading…
Reference in New Issue
Block a user