- Update to version 1.0.0
- Add LICENSE information, don't install license files, let them be handled by our licensing framework - ADD RUN_DEPENDS on gnomesu which is needed for gaining superuser privileges required by the program at start Changelog: Version 1.0.0 Ported to GTK+ 3. Version 0.9.0, released on 2017-05-11 Implemented (untested) support for Linux-based Areca controllers with enclosures. Implemented (untested) support for Windows-based Areca controllers (thanks to Richard Kagerer). Implemented (untested) support for Linux-based HP controllers with cciss and hpsa/hpahcisr drivers (thanks to Fabrice Bacchella). Changes in Preferences no longer fail silently until rescan/restart. Better drive detection under Windows after removable drives are detached. Windows version is no longer marked as "dpi aware" since it's not supported that well. Drive attribute descriptions have been updated (including clarifications for SSDs). Added support for SSD-only and HDD-only vendor attributes. Devices having only basic info can be displayed now in the info window. Fixed BDRW drive detection (it was detected as a HDD). Other minor improvements. A number of issues have been fixed (including a crash).
This commit is contained in:
parent
cc8dbd7128
commit
6e6ed024fb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=443825
@ -2,20 +2,30 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gsmartcontrol
|
||||
PORTVERSION= 0.8.7
|
||||
PORTREVISION= 5
|
||||
PORTVERSION= 1.0.0
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://artificialtime.com/${PORTNAME}/
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
|
||||
|
||||
MAINTAINER= pawel@FreeBSD.org
|
||||
COMMENT= Graphical user interface for smartmontools
|
||||
|
||||
LIB_DEPENDS= libgtkmm-2.4.so:x11-toolkits/gtkmm24
|
||||
LICENSE= BSD3CLAUSE BSL GPLv2 GPLv3 PD ZLIB
|
||||
LICENSE_COMB= multi
|
||||
LICENSE_FILE_BSD3CLAUSE=${WRKSRC}/LICENSE_bsd-ac.txt
|
||||
LICENSE_FILE_BSL= ${WRKSRC}/LICENSE_boost_1_0.txt
|
||||
LICENSE_FILE_GPLv2= ${WRKSRC}/LICENSE_gpl2.txt
|
||||
LICENSE_FILE_GPLv3= ${WRKSRC}/LICENSE_gpl3.txt
|
||||
LICENSE_FILE_PD= ${WRKSRC}/LICENSE_unlicense.txt
|
||||
LICENSE_FILE_ZLIB= ${WRKSRC}/LICENSE_zlib.txt
|
||||
|
||||
LIB_DEPENDS= libpcre.so:devel/pcre
|
||||
RUN_DEPENDS= bash:shells/bash \
|
||||
gnomesu:security/libgnomesu \
|
||||
smartctl:sysutils/smartmontools
|
||||
|
||||
USES= compiler:c++11-lang pkgconfig tar:bzip2 libtool
|
||||
USES= compiler:c++11-lang libtool pkgconfig tar:bzip2
|
||||
USE_CXXSTD= c++11
|
||||
USE_GNOME= atkmm cairo glibmm gtk30 gtkmm30 libsigc++20 pangomm
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (gsmartcontrol-0.8.7.tar.bz2) = 708fa803243abb852ed52050fc82cd3592a798c02743342441996e77f19ffec6
|
||||
SIZE (gsmartcontrol-0.8.7.tar.bz2) = 684394
|
||||
TIMESTAMP = 1497639656
|
||||
SHA256 (gsmartcontrol-1.0.0.tar.bz2) = 7ce35c52260084fa0ac4c7c9011bf231b459af157247f52d0c56aa0e90df947b
|
||||
SIZE (gsmartcontrol-1.0.0.tar.bz2) = 691419
|
||||
|
30
sysutils/gsmartcontrol/files/patch-Makefile.in
Normal file
30
sysutils/gsmartcontrol/files/patch-Makefile.in
Normal file
@ -0,0 +1,30 @@
|
||||
--- Makefile.in.orig 2017-06-15 21:00:10 UTC
|
||||
+++ Makefile.in
|
||||
@@ -84,7 +84,7 @@ DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile
|
||||
$(top_srcdir)/configure $(am__configure_deps) \
|
||||
$(srcdir)/config.h.in $(srcdir)/gsmartcontrol.spec.in \
|
||||
$(srcdir)/version.in $(srcdir)/compilation_flags.in \
|
||||
- $(dist_doc_DATA) $(nobase_dist_doc_DATA) COPYING ChangeLog \
|
||||
+ $(dist_doc_DATA) $(nobase_dist_doc_DATA) ChangeLog \
|
||||
INSTALL NEWS TODO ar-lib config.guess config.sub depcomp \
|
||||
install-sh missing
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||
@@ -375,17 +375,7 @@ noinst_DATA = AUTHORS.txt LICENSE_gsmartcontrol.txt RE
|
||||
# These will be installed into docdir.
|
||||
# Some of these files are actually needed for compilation (see src/res/Makefile.am).
|
||||
dist_doc_DATA = AUTHORS.txt ChangeLog NEWS README.txt \
|
||||
- LICENSE_boost_1_0.txt \
|
||||
- LICENSE_bsd-ac.txt \
|
||||
- LICENSE_bsd-ucb.txt \
|
||||
- LICENSE_gpl2.txt \
|
||||
- LICENSE_gpl3.txt \
|
||||
- LICENSE_gsmartcontrol.txt \
|
||||
- LICENSE_hz.txt \
|
||||
- LICENSE_pcrecpp.txt \
|
||||
- LICENSE_unlicense.txt \
|
||||
- LICENSE_zlib.txt
|
||||
-
|
||||
+ LICENSE_gsmartcontrol.txt
|
||||
|
||||
# nobase_ preserves their directory names.
|
||||
nobase_dist_doc_DATA = contrib/cron-based_noadmin/README \
|
@ -1,20 +1,11 @@
|
||||
bin/gsmartcontrol
|
||||
bin/gsmartcontrol-root
|
||||
man/man1/gsmartcontrol.1.gz
|
||||
man/man1/gsmartcontrol-root.1.gz
|
||||
man/man1/gsmartcontrol.1.gz
|
||||
share/applications/gsmartcontrol.desktop
|
||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_boost_1_0.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_bsd-ac.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_bsd-ucb.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_gpl2.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_gpl3.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_gsmartcontrol.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_hz.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_pcrecpp.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_unlicense.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_zlib.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/contrib/cron-based_noadmin/README
|
||||
@ -31,5 +22,6 @@ share/icons/hicolor/256x256/apps/gsmartcontrol.png
|
||||
share/icons/hicolor/32x32/apps/gsmartcontrol.png
|
||||
share/icons/hicolor/48x48/apps/gsmartcontrol.png
|
||||
share/icons/hicolor/64x64/apps/gsmartcontrol.png
|
||||
share/metainfo/gsmartcontrol.appdata.xml
|
||||
share/pixmaps/gsmartcontrol.png
|
||||
share/pixmaps/gsmartcontrol.xpm
|
||||
|
Loading…
Reference in New Issue
Block a user