print/ft2demos: Update to 2.11.1 and unbreak

Convert to meson build system (from GNU Make)
Use gitlab source which has meson.build

PR:		260922
This commit is contained in:
Eric Gullufsen 2022-01-16 14:50:01 +01:00 committed by Daniel Engberg
parent 110c4877c8
commit 6e009d0456
4 changed files with 25 additions and 26 deletions

View File

@ -1,10 +1,10 @@
# Created by: KANOU Hiroki <kanou@khdd.net>
PORTNAME= ft2demos
PORTVERSION= 2.10.4
PORTVERSION= 2.11.1
CATEGORIES= print
MASTER_SITES= SAVANNAH/freetype/ \
SF/freetype/freetype-demos/${PORTVERSION}
MASTER_SITES= https://gitlab.freedesktop.org
MAINTAINER= ports@FreeBSD.org
COMMENT= Demo programs for FreeType2
@ -12,16 +12,17 @@ COMMENT= Demo programs for FreeType2
LICENSE= BSD3CLAUSE GPLv2
LICENSE_COMB= dual
BROKEN= Doesn't build with FreeType 2.11.0
BUILD_DEPENDS= ${NONEXISTENT}:print/freetype2:build
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libpng.so:graphics/png
USES= gmake tar:xz xorg
USES= meson tar:xz xorg
USE_XORG= x11
MAKE_ARGS= EXES="${FT_PROGRAMS}" X11_PATH="${LOCALBASE}"
USE_GITLAB= yes
GL_PROJECT= freetype-demos
GL_ACCOUNT= freetype
GL_COMMIT= 07027905d9a47664251b3ee362c5cfad1cddf86f
PLIST_FILES= ${FT_PROGRAMS:S,^,bin/,}
@ -29,10 +30,11 @@ FT_PROGRAMS= ftbench ftchkwd ftdiff ftdump ftgamma ftgrid ftlint ftmemchk \
ftmulti ftpatchk ftstring fttimer ftvalid ftview
post-extract:
${LN} -sf `${MAKE} -C ${.CURDIR}/../../print/freetype2 -V WRKSRC` ${WRKDIR}/freetype2
${LN} -sf `${MAKE} -C ${.CURDIR}/../../print/freetype2 -V WRKSRC` \
${WRKDIR}/${GL_PROJECT}-${GL_COMMIT}/subprojects/freetype2
do-install:
@(cd ${WRKSRC}/bin/.libs && \
@(cd ${WRKSRC}/_build && \
${INSTALL_PROGRAM} ${FT_PROGRAMS} ${STAGEDIR}${PREFIX}/bin)
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1603568666
SHA256 (ft2demos-2.10.4.tar.xz) = 3f873ebe4fb387da3859149459f9be95320ce1fd56b50f8fdb9d2a8492887083
SIZE (ft2demos-2.10.4.tar.xz) = 236712
TIMESTAMP = 1641293484
SHA256 (freetype-freetype-demos-07027905d9a47664251b3ee362c5cfad1cddf86f_GL0.tar.gz) = 61c872dde5aa69fc0a27019950c301cd3db7f11a776e4eb9859311d2fc0d3d5e
SIZE (freetype-freetype-demos-07027905d9a47664251b3ee362c5cfad1cddf86f_GL0.tar.gz) = 342190

View File

@ -1,14 +0,0 @@
--- Makefile.orig 2017-03-29 16:20:30 UTC
+++ Makefile
@@ -136,11 +136,9 @@ else
# Enable C99 for gcc to avoid warnings.
# Note that clang++ aborts with an error if we use `-std=C99',
# so check for `++' in $(CC) also.
- ifneq ($(findstring -pedantic,$(COMPILE)),)
ifeq ($(findstring ++,$(CC)),)
COMPILE += -std=c99
endif
- endif
FTLIB := $(LIB_DIR)/$(LIBRARY).$A

View File

@ -0,0 +1,11 @@
--- meson.build.orig 2021-12-02 03:37:39.000000000 -0900
+++ meson.build 2022-01-04 02:25:43.961204000 -0900
@@ -112,7 +112,7 @@
executable('ftgrid',
'src/ftgrid.c',
- dependencies: libfreetype2_dep,
+ dependencies: [libfreetype2_dep, math_dep],
include_directories: graph_include_dir,
link_with: [ftcommon_lib, output_lib],
install: true)