- Fix compatibility with jabber 1.6.0

- Add plist support

NOTES:  Please read the UPDATING

PR:             109566
Submitted by:   Martin Matuska <martin@matuska.org> (maintainer)
This commit is contained in:
Martin Wilke 2007-02-27 13:13:49 +00:00
parent 0de9fe3a46
commit 6dd93bac13
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=186114
5 changed files with 123 additions and 15 deletions

View File

@ -6,7 +6,7 @@
PORTNAME= yahoo
PORTVERSION= 2.3.2
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= net-im
MASTER_SITES= http://files.jabberstudio.org/yahoo-transport-2/
PKGNAMEPREFIX= jabber-
@ -16,17 +16,53 @@ DIST_SUBDIR= jabber
MAINTAINER= martin@matuska.org
COMMENT= Jabber Yahoo Transport module
BUILD_DEPENDS= ${LOCALBASE}/sbin/jabberd:${PORTSDIR}/net-im/jabber
LIB_DEPENDS= jabberd.1:${PORTSDIR}/net-im/jabber
USE_GNOME= glib12
USE_GMAKE= yes
USE_ICONV= yes
WRKSRC= ${WRKDIR}/yahoo-transport-${PORTVERSION}
PLIST_FILES= lib/jabber/yahoo-transport.so etc/yahoo-jabber.xml.sample
DOCSDIR= ${TARGETDIR}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
SUB_FILES+= README.jabberd14 pkg-message
DOCS= CHANGES INSTALL LICENSE README jabber.xml yahoo-jabber.xml yahoo-jcr.xml
.if !defined(NOPORTDOCS)
PKG_MESSAGE= ${WRKDIR}/pkg-message
.endif
.include <bsd.port.pre.mk>
.if exists(${GLIB_CONFIG})
GLIB_CFLAGS!= ${GLIB_CONFIG} --cflags
GLIB_LIBS!= ${GLIB_CONFIG} --libs
.endif
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/jabber \
-I${LOCALBASE}/include/pth ${GLIB_CFLAGS}
MAKE_ARGS+= MCFLAGS="-shared" \
LDFLAGS="-L${LOCALBASE}/lib/pth -L${LOCALBASE}/lib/jabber" \
LIBS="${GLIB_LIBS}"
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
CFLAGS+= -fPIC
.endif
do-install:
${INSTALL_DATA} ${WRKSRC}/yahoo-transport.so ${PREFIX}/lib/jabber/
${INSTALL_DATA} ${WRKSRC}/yahoo-jabber.xml ${PREFIX}/etc/yahoo-jabber.xml.sample
${INSTALL_PROGRAM} ${WRKSRC}/yahoo-transport.so ${PREFIX}/lib/jabber/
.include <bsd.port.mk>
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/${FILE}
.endfor
@${INSTALL_DATA} ${WRKDIR}/README.jabberd14 ${DOCSDIR}
@${CAT} ${PKGMESSAGE}
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,62 @@
The sample configuration file for jabberd14 may be located in:
%%TARGETDIR%%/etc/jabber.xml.sample
Please make all necessary changes to your configuration file which may be:
%%TARGETDIR%%/etc/jabber.xml
NOTE: if you want this service to be accessible from other servers,
change any 'yahoo.localhost' listed below to a fully qualified domain name!
Please make sure that your directives are _NOT_ in an XML comment: there
are many multi-line comments.
To activate the YAHOO transport for your Jabber server,
add the following to your configuration file and adjust to your settings
(around line 921 in the sample configuration file):
-------------------------------------------------------------------------------
<service id="yahoo.localhost">
<load><yahoo_transport>%%TARGETDIR%%/jabber/yahoo-transport.so</yahoo_transport></load>
<config xmlns="jabber:config:yahoo">
<!-- This is the name that will appear when the transport is browsed or
discovered. REQUIRED -->
<vCard>
<NAME>Yahoo! IM Gateway</NAME>
</vCard>
<!-- This is the text that is presented to the user when they register with
transport REQUIRED -->
<instructions>Enter your YAHOO! Messenger Username and Password to registe r with the gateway.</instructions>
<!-- The Yahoo IM server REQUIRED ... should not have to be changed -->
<server>scs.yahoo.com</server>
<!-- The Yahoo IM server's port REQUIRED ... should not have to be changed -->
<port>5050</port>
<!-- The character map. This provides character set translation from UTF-8
to the indicated character map. See the man page for 'iconv' for available
character maps on your platform. CP1252 is the standard Windows character
set -->
<charmap>CP1252</charmap>
<!-- When this element exists, the transport will send new mail notifications as
well as a count of unread messages when the user initially logs in -->
<newmail/>
</config>
</service>
-------------------------------------------------------------------------------
Add this section to the browse area of the jsm to advertise it to
your users (around line 382 of the sample config):
-------------------------------------------------------------------------------
<item category="gateway" type="yahoo" jid="yahoo.localhost" name="Yahoo! Transport">
<ns>jabber:iq:gateway</ns>
<ns>jabber:iq:register</ns>
<ns>jabber:iq:version</ns>
<ns>jabber:iq:time</ns>
</item>
-------------------------------------------------------------------------------
Be sure to restart your server after reconfiguring.

View File

@ -1,16 +1,14 @@
--- Makefile.orig Mon Sep 29 02:40:44 2003
+++ Makefile Sat Jan 3 20:23:13 2004
@@ -1,10 +1,10 @@
--- Makefile.orig Fri Jun 25 18:33:56 2004
+++ Makefile Wed Feb 21 15:09:38 2007
@@ -1,11 +1,6 @@
# $Id: Makefile,v 1.5 2003/09/29 00:40:44 pcurtis Exp $
# $Id: Makefile,v 1.7 2004/06/25 18:33:56 pcurtis Exp $
-include ../platform-settings
+include ${PREFIX}/include/jabber/platform-settings
-
-CFLAGS:=$(CFLAGS) -I../jabberd `glib-config --cflags`
-LIBS:=$(LIBS) `glib-config --libs glib`
+CFLAGS:=$(CFLAGS) -I${PREFIX}/include -I${PREFIX}/include/jabber `glib12-config --cflags`
+LIBS:=$(LIBS) `glib12-config --libs glib` -liconv
-
YAHOO_OBJECTS=yahoo-transport.o yahoo-session.o yahoo-phandler.o yahoo.o \
crypt.o gaim-sha.o yahoo-presence.o yahoo-server.o md5.o yahoo-message.o \
yahoo-stats.o yahoo-composing.o yahoo-mail.o yahoo-auth.o

View File

@ -0,0 +1,2 @@
You can find a configuration example in:
%%DOCSDIR%%/README.jabberd14

View File

@ -0,0 +1,10 @@
lib/jabber/yahoo-transport.so
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.jabberd14
%%PORTDOCS%%%%DOCSDIR%%/jabber.xml
%%PORTDOCS%%%%DOCSDIR%%/yahoo-jabber.xml
%%PORTDOCS%%%%DOCSDIR%%/yahoo-jcr.xml
%%PORTDOCS%%@dirrm %%DOCSDIR%%