Update to 0.1.1.

This commit is contained in:
MANTANI Nobutaka 2003-10-13 15:39:54 +00:00
parent 0de66a209a
commit 6da0e16f98
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=91064
16 changed files with 64 additions and 162 deletions

View File

@ -6,9 +6,9 @@
#
PORTNAME= uim
PORTVERSION= 0.0.2.1
PORTVERSION= 0.1.1
CATEGORIES= japanese x11
MASTER_SITES= http://downloads.sourceforge.jp/anthy/5771/
MASTER_SITES= http://downloads.sourceforge.jp/anthy/6318/
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Input method library
@ -36,8 +36,8 @@ PLIST_SUB+= GTK=""
PLIST_SUB+= GTK="@comment "
.endif
.if ${HAVE_GNOME:Mlibgnome}
USE_GNOME+= libgnome
.if ${HAVE_GNOME:Mgnomepanel}
USE_GNOME+= gnomepanel
PLIST_SUB+= GNOME=""
.else
PLIST_SUB+= GNOME="@comment "

View File

@ -1 +1 @@
MD5 (uim-0.0.2.1.tar.gz) = d8195a47be0cff1f4a7b6e0fab8f1cd9
MD5 (uim-0.1.1.tar.gz) = 3684b4ad731b44926cdf5533345b96b8

View File

@ -1,24 +0,0 @@
--- configure.orig Mon Aug 25 23:34:01 2003
+++ configure Mon Aug 25 23:34:40 2003
@@ -21430,10 +21430,6 @@
if test $succeeded = yes; then
use_gtk2="yes"
- else
- { { echo "$as_me:$LINENO: error: Library requirements (gtk+-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&5
-echo "$as_me: error: Library requirements (gtk+-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&2;}
- { (exit 1); exit 1; }; }
fi
@@ -21528,10 +21524,6 @@
if test $succeeded = yes; then
use_gnome2="yes"
- else
- { { echo "$as_me:$LINENO: error: Library requirements (libgnome-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&5
-echo "$as_me: error: Library requirements (libgnome-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&2;}
- { (exit 1); exit 1; }; }
fi

View File

@ -1,16 +0,0 @@
--- gtk/gtk-im-uim.c.orig Sun Aug 31 15:40:29 2003
+++ gtk/gtk-im-uim.c Sun Aug 31 15:41:10 2003
@@ -109,10 +109,12 @@
static void
pushback_cb(void *ptr, int attr, char *str)
{
+ IMUIMContext *uic;
+
if(!str)
return;
- IMUIMContext *uic = ptr;
+ uic = ptr;
uic->pseg = realloc(uic->pseg,
sizeof(struct preedit_segment) *
(uic->nr_psegs + 1));

View File

@ -0,0 +1,23 @@
--- helper/helper-applet.c.orig Tue Oct 14 00:07:31 2003
+++ helper/helper-applet.c Tue Oct 14 00:24:43 2003
@@ -134,6 +134,7 @@
gchar **tmp2 = NULL;
gchar *charset = NULL;
GString *path = g_string_new("");
+ GtkItemFactoryEntry entry;
tmp2 = g_strsplit(tmp[1], "=", 0);
@@ -176,7 +177,11 @@
gtk_widget_show(button);
} else if(strcmp("leaf", tmp2[0]) == 0) {
g_string_printf(path, "/%s", tmp2[2]);
- GtkItemFactoryEntry entry = {path->str, NULL, G_CALLBACK(activate_event), 0, ""};
+ entry.path = path->str;
+ entry.accelerator = NULL;
+ entry.callback = G_CALLBACK(activate_event);
+ entry.callback_action = 0;
+ entry.item_type = "";
gtk_item_factory_create_item ( mode_item_fact, &entry, tmp2[4], 1);
}

View File

@ -1,25 +0,0 @@
--- uim/uim-func.c.orig Sun Aug 31 15:09:52 2003
+++ uim/uim-func.c Sun Aug 31 15:10:19 2003
@@ -97,15 +97,17 @@
char *
uim_code_conv(char *str, iconv_t ic)
{
+ int len, buflen;
+ char *realbuf, *outbuf, *inbuf;
if(!str)
return NULL;
- int len = strlen(str);
- int buflen = len * 6+3;
- char *realbuf = alloca(buflen);
- char *outbuf = realbuf;
- char *inbuf = str;
+ len = strlen(str);
+ buflen = len * 6+3;
+ realbuf = alloca(buflen);
+ outbuf = realbuf;
+ inbuf = str;
if (!ic) {
return strdup(str);
}

View File

@ -1,11 +0,0 @@
--- xim/Makefile.in.orig Mon Aug 25 23:44:36 2003
+++ xim/Makefile.in Mon Aug 25 23:45:03 2003
@@ -139,7 +139,7 @@
install_sh = @install_sh@
INCLUDES = -I$(top_srcdir)
-CPPFLAGS = -DLOCALEDIR=\""$(localedir)"\"
+CPPFLAGS = @CPPFLAGS@ -DLOCALEDIR=\""$(localedir)"\"
bin_PROGRAMS = uim-xim
uim_xim_LDFLAGS = -L/usr/lib -L/usr/X11R6/lib

View File

@ -1,4 +1,6 @@
bin/uim-helper-server
bin/uim-xim
include/uim/uim-helper.h
include/uim/uim.h
%%GNOME%%lib/bonobo/servers/GNOME_UimApplet.server
%%GTK%%lib/gtk-2.0/2.2.0/immodules/im-uim.a
@ -8,6 +10,7 @@ lib/libuim.a
lib/libuim.la
lib/libuim.so
lib/libuim.so.0
libexec/uim-helper-applet
%%PORTDOCS%%%%DOCSDIR_JA%%/README.ja
%%PORTDOCS%%%%DOCSDIR%%/README
share/locale/ja/LC_MESSAGES/uim.mo
@ -27,6 +30,7 @@ share/uim/key.scm
share/uim/loader.scm
share/uim/prime.scm
share/uim/rk.scm
share/uim/skk-editor.scm
share/uim/skk.scm
share/uim/tcode.scm
share/uim/tutcode.scm

View File

@ -6,9 +6,9 @@
#
PORTNAME= uim
PORTVERSION= 0.0.2.1
PORTVERSION= 0.1.1
CATEGORIES= japanese x11
MASTER_SITES= http://downloads.sourceforge.jp/anthy/5771/
MASTER_SITES= http://downloads.sourceforge.jp/anthy/6318/
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Input method library
@ -36,8 +36,8 @@ PLIST_SUB+= GTK=""
PLIST_SUB+= GTK="@comment "
.endif
.if ${HAVE_GNOME:Mlibgnome}
USE_GNOME+= libgnome
.if ${HAVE_GNOME:Mgnomepanel}
USE_GNOME+= gnomepanel
PLIST_SUB+= GNOME=""
.else
PLIST_SUB+= GNOME="@comment "

View File

@ -1 +1 @@
MD5 (uim-0.0.2.1.tar.gz) = d8195a47be0cff1f4a7b6e0fab8f1cd9
MD5 (uim-0.1.1.tar.gz) = 3684b4ad731b44926cdf5533345b96b8

View File

@ -1,24 +0,0 @@
--- configure.orig Mon Aug 25 23:34:01 2003
+++ configure Mon Aug 25 23:34:40 2003
@@ -21430,10 +21430,6 @@
if test $succeeded = yes; then
use_gtk2="yes"
- else
- { { echo "$as_me:$LINENO: error: Library requirements (gtk+-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&5
-echo "$as_me: error: Library requirements (gtk+-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&2;}
- { (exit 1); exit 1; }; }
fi
@@ -21528,10 +21524,6 @@
if test $succeeded = yes; then
use_gnome2="yes"
- else
- { { echo "$as_me:$LINENO: error: Library requirements (libgnome-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&5
-echo "$as_me: error: Library requirements (libgnome-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&2;}
- { (exit 1); exit 1; }; }
fi

View File

@ -1,16 +0,0 @@
--- gtk/gtk-im-uim.c.orig Sun Aug 31 15:40:29 2003
+++ gtk/gtk-im-uim.c Sun Aug 31 15:41:10 2003
@@ -109,10 +109,12 @@
static void
pushback_cb(void *ptr, int attr, char *str)
{
+ IMUIMContext *uic;
+
if(!str)
return;
- IMUIMContext *uic = ptr;
+ uic = ptr;
uic->pseg = realloc(uic->pseg,
sizeof(struct preedit_segment) *
(uic->nr_psegs + 1));

View File

@ -0,0 +1,23 @@
--- helper/helper-applet.c.orig Tue Oct 14 00:07:31 2003
+++ helper/helper-applet.c Tue Oct 14 00:24:43 2003
@@ -134,6 +134,7 @@
gchar **tmp2 = NULL;
gchar *charset = NULL;
GString *path = g_string_new("");
+ GtkItemFactoryEntry entry;
tmp2 = g_strsplit(tmp[1], "=", 0);
@@ -176,7 +177,11 @@
gtk_widget_show(button);
} else if(strcmp("leaf", tmp2[0]) == 0) {
g_string_printf(path, "/%s", tmp2[2]);
- GtkItemFactoryEntry entry = {path->str, NULL, G_CALLBACK(activate_event), 0, ""};
+ entry.path = path->str;
+ entry.accelerator = NULL;
+ entry.callback = G_CALLBACK(activate_event);
+ entry.callback_action = 0;
+ entry.item_type = "";
gtk_item_factory_create_item ( mode_item_fact, &entry, tmp2[4], 1);
}

View File

@ -1,25 +0,0 @@
--- uim/uim-func.c.orig Sun Aug 31 15:09:52 2003
+++ uim/uim-func.c Sun Aug 31 15:10:19 2003
@@ -97,15 +97,17 @@
char *
uim_code_conv(char *str, iconv_t ic)
{
+ int len, buflen;
+ char *realbuf, *outbuf, *inbuf;
if(!str)
return NULL;
- int len = strlen(str);
- int buflen = len * 6+3;
- char *realbuf = alloca(buflen);
- char *outbuf = realbuf;
- char *inbuf = str;
+ len = strlen(str);
+ buflen = len * 6+3;
+ realbuf = alloca(buflen);
+ outbuf = realbuf;
+ inbuf = str;
if (!ic) {
return strdup(str);
}

View File

@ -1,11 +0,0 @@
--- xim/Makefile.in.orig Mon Aug 25 23:44:36 2003
+++ xim/Makefile.in Mon Aug 25 23:45:03 2003
@@ -139,7 +139,7 @@
install_sh = @install_sh@
INCLUDES = -I$(top_srcdir)
-CPPFLAGS = -DLOCALEDIR=\""$(localedir)"\"
+CPPFLAGS = @CPPFLAGS@ -DLOCALEDIR=\""$(localedir)"\"
bin_PROGRAMS = uim-xim
uim_xim_LDFLAGS = -L/usr/lib -L/usr/X11R6/lib

View File

@ -1,4 +1,6 @@
bin/uim-helper-server
bin/uim-xim
include/uim/uim-helper.h
include/uim/uim.h
%%GNOME%%lib/bonobo/servers/GNOME_UimApplet.server
%%GTK%%lib/gtk-2.0/2.2.0/immodules/im-uim.a
@ -8,6 +10,7 @@ lib/libuim.a
lib/libuim.la
lib/libuim.so
lib/libuim.so.0
libexec/uim-helper-applet
%%PORTDOCS%%%%DOCSDIR_JA%%/README.ja
%%PORTDOCS%%%%DOCSDIR%%/README
share/locale/ja/LC_MESSAGES/uim.mo
@ -27,6 +30,7 @@ share/uim/key.scm
share/uim/loader.scm
share/uim/prime.scm
share/uim/rk.scm
share/uim/skk-editor.scm
share/uim/skk.scm
share/uim/tcode.scm
share/uim/tutcode.scm