makeztxt is a simple command line program that takes a plain ASCII text file

and compresses it into a zTXT database.  makeztxt will remove newline
characters at the end of lines that contain text so that the paragraphs flow
better on the Palm screen.

Submitted by:	Roman Shterenzon <romanbsd@yahoo.com>
This commit is contained in:
Kris Kennaway 2002-10-20 23:10:16 +00:00
parent aedf1b7a4e
commit 6d8202f80e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=68446
13 changed files with 124 additions and 0 deletions

View File

@ -13,6 +13,7 @@
SUBDIR += jpilot
SUBDIR += libmal
SUBDIR += malsync
SUBDIR += makeztxt
SUBDIR += mdbconv
SUBDIR += p5-Palm
SUBDIR += palmos-sdk

23
palm/makeztxt/Makefile Normal file
View File

@ -0,0 +1,23 @@
# New ports collection makefile for: makeztxt
# Date created: Oct 19, 2002
# Whom: Roman Shterenzon <roman@xpert.com>
#
# $FreeBSD$
#
PORTNAME= makeztxt
PORTVERSION= 1.43
CATEGORIES= palm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gutenpalm
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= roman@xpert.com
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/makeztxt ${LOCALBASE}/bin/
.include <bsd.port.mk>

1
palm/makeztxt/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (makeztxt-1.43-src.tar.gz) = 9af951a5b6d7e5633c02cd4b13bb606a

View File

@ -0,0 +1,31 @@
--- Makefile.orig Sat Oct 19 15:38:34 2002
+++ Makefile Sat Oct 19 15:40:04 2002
@@ -9,8 +9,8 @@
LIBS = -lztxt
INCLUDE = -I../common -I.
-CC = gcc
-CFLAGS = -Wall -O2 -pipe $(INCLUDE)
+CC ?= cc
+CFLAGS += -Wall $(INCLUDE)
# GNU make is mandatory
#MAKE = make
@@ -29,7 +29,7 @@
# more featureful and faster (on large strings) than POSIX regex.
# But... maybe you don't have GNU regex.
# In particular, if compiling with Cygwin, you need this.
-#USEPOSIX = 1
+USEPOSIX = 1
# DOS, in all its infinite wisdom, decided long ago to differentiate between
# text files and binary files. Text files get their \n converted to \r\n and
@@ -44,7 +44,7 @@
# If you're on a system that does not have getopt.h or does not have the
# getopt_long() function, comment this out. Regular getopt() will be used.
-LONG_OPTS = 1
+#LONG_OPTS = 1
#####################################

View File

@ -0,0 +1,10 @@
--- libztxt/ztxt.h.old Sat Mar 2 07:03:18 2002
+++ libztxt/ztxt.h Sun Sep 29 15:46:52 2002
@@ -31,6 +31,7 @@
#define _ZTXT_H_ 1
+#include <sys/types.h>
#include <regex.h>
#include "databaseHdrs.h"
#include <weasel_common.h>

View File

@ -0,0 +1,10 @@
--- libztxt/ztxt_generate_db.c.old Sat Mar 2 07:03:18 2002
+++ libztxt/ztxt_generate_db.c Sun Sep 29 15:51:55 2002
@@ -30,6 +30,7 @@
#include <stdlib.h>
#include <stdio.h>
#include <string.h>
+#include <sys/types.h>
#include <netinet/in.h>
#include <regex.h>
#include "ztxt.h"

View File

@ -0,0 +1,10 @@
--- libztxt/ztxt_init.c.old Sat Mar 2 07:03:18 2002
+++ libztxt/ztxt_init.c Sun Sep 29 15:52:33 2002
@@ -30,6 +30,7 @@
#include <stdlib.h>
#include <string.h>
#include <time.h>
+#include <sys/types.h>
#include <netinet/in.h>
#include "ztxt.h"

View File

@ -0,0 +1,10 @@
--- libztxt/ztxt_list_bookmarks.c.old Sat Mar 2 07:03:18 2002
+++ libztxt/ztxt_list_bookmarks.c Sun Sep 29 15:52:10 2002
@@ -29,6 +29,7 @@
#include <stdio.h>
#include <string.h>
+#include <sys/types.h>
#include <regex.h>
#include "ztxt.h"

View File

@ -0,0 +1,10 @@
--- libztxt/ztxt_process.c.old Sat Mar 2 07:03:18 2002
+++ libztxt/ztxt_process.c Sun Sep 29 15:52:49 2002
@@ -30,6 +30,7 @@
#include <stdlib.h>
#include <stdio.h>
#include <string.h>
+#include <sys/types.h>
#include <regex.h>
#include <zlib.h>
#include "ztxt.h"

View File

@ -0,0 +1,10 @@
--- libztxt/ztxt_set.c.old Sat Mar 2 07:03:18 2002
+++ libztxt/ztxt_set.c Sun Sep 29 15:52:21 2002
@@ -28,6 +28,7 @@
*/
#include <string.h>
+#include <sys/types.h>
#include <netinet/in.h>
#include "ztxt.h"

View File

@ -0,0 +1 @@
Command line utility to create GutenPalm's zTXT format databases

6
palm/makeztxt/pkg-descr Normal file
View File

@ -0,0 +1,6 @@
makeztxt is a simple command line program that takes a plain ASCII text file
and compresses it into a zTXT database. makeztxt will remove newline
characters at the end of lines that contain text so that the paragraphs flow
better on the Palm screen.
WWW: http://gutenpalm.sourceforge.net/

1
palm/makeztxt/pkg-plist Normal file
View File

@ -0,0 +1 @@
bin/makeztxt