Update to 0.2.16 and fix tap interface usage.
PR: 218893 Submitted by: olivier Approved by: pavelivolkov@gmail.com (maintainer) Sponsored by: Orange
This commit is contained in:
parent
73eefd56d1
commit
6d7cdc135f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=439535
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= dynamips
|
||||
PORTVERSION= 0.2.15
|
||||
PORTVERSION= 0.2.16
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= emulators
|
||||
PKGNAMESUFFIX= -community
|
||||
@ -12,8 +12,7 @@ COMMENT= Cisco 1700/2600/3600/3700/7200 Simulator
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= libelf.so:devel/libelf \
|
||||
libuuid.so:misc/e2fsprogs-libuuid
|
||||
LIB_DEPENDS= libelf.so:devel/libelf
|
||||
|
||||
CFLAGS+= -I${PREFIX}/include/libelf
|
||||
|
||||
@ -55,7 +54,7 @@ do-install:
|
||||
${INSTALL_MAN} ${WRKSRC}/man/hypervisor_mode.7 ${STAGEDIR}${MANPREFIX}/man/man7
|
||||
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for file in README README.hypervisor RELEASE-NOTES ChangeLog MAINTAINERS
|
||||
.for file in README.md README.hypervisor RELEASE-NOTES ChangeLog MAINTAINERS
|
||||
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (GNS3-dynamips-v0.2.15_GH0.tar.gz) = 4f77a88470069dccab391ce786b633061511593efbd0a9b895e5711325eceb36
|
||||
SIZE (GNS3-dynamips-v0.2.15_GH0.tar.gz) = 839493
|
||||
TIMESTAMP = 1493198102
|
||||
SHA256 (GNS3-dynamips-v0.2.16_GH0.tar.gz) = 0fcf18d701898a77cb589bd9bad16dde436ac1ccb87516fefe07d09de1a196c0
|
||||
SIZE (GNS3-dynamips-v0.2.16_GH0.tar.gz) = 832173
|
||||
|
11
emulators/dynamips-community/files/patch-CMakeLists.txt
Normal file
11
emulators/dynamips-community/files/patch-CMakeLists.txt
Normal file
@ -0,0 +1,11 @@
|
||||
--- CMakeLists.txt.orig 2016-03-16 09:05:47 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -32,7 +32,7 @@ include ( utils )
|
||||
include ( dependencies )
|
||||
include ( configure )
|
||||
|
||||
-if(APPLE)
|
||||
+if( APPLE OR (CMAKE_SYSTEM_NAME MATCHES "FreeBSD") )
|
||||
include_directories(include /usr/local/include/)
|
||||
include_directories(include /opt/local/include/)
|
||||
endif()
|
15
emulators/dynamips-community/files/patch-common_net__io.c
Normal file
15
emulators/dynamips-community/files/patch-common_net__io.c
Normal file
@ -0,0 +1,15 @@
|
||||
--- common/net_io.c.orig 2016-03-16 09:05:47 UTC
|
||||
+++ common/net_io.c
|
||||
@@ -609,9 +609,11 @@ static int netio_tap_open(char *tap_devn
|
||||
return(fd);
|
||||
#else
|
||||
int i,fd = -1;
|
||||
+ char tap_fullname[NETIO_DEV_MAXLEN];
|
||||
|
||||
if (*tap_devname) {
|
||||
- fd = open(tap_devname,O_RDWR);
|
||||
+ snprintf(tap_fullname,NETIO_DEV_MAXLEN,"/dev/%s",tap_devname);
|
||||
+ fd = open(tap_fullname,O_RDWR);
|
||||
} else {
|
||||
for(i=0;i<16;i++) {
|
||||
snprintf(tap_devname,NETIO_DEV_MAXLEN,"/dev/tap%d",i);
|
Loading…
Reference in New Issue
Block a user