Unbreak configure script
This commit is contained in:
parent
53070bf710
commit
6d225990bb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=244020
@ -17,14 +17,14 @@ COMMENT= Prelude Network Intrusion Detection System central logging point
|
||||
LIB_DEPENDS+= prelude.20:${PORTSDIR}/security/libprelude \
|
||||
gnutls.40:${PORTSDIR}/security/gnutls
|
||||
|
||||
BROKEN= does not configure
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_AUTOTOOLS= autoconf:262
|
||||
USE_RC_SUBR= prelude-manager.sh
|
||||
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
|
||||
--localstatedir=/var
|
||||
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
|
||||
LIBS="${LIBS} -L${LOCALBASE}/lib"
|
||||
|
||||
PRELUDEUSER?= prelude
|
||||
PRELUDEGROUP?= prelude
|
||||
|
29
security/prelude-manager/files/patch-configure.in
Normal file
29
security/prelude-manager/files/patch-configure.in
Normal file
@ -0,0 +1,29 @@
|
||||
--- configure.in.orig 2008-08-21 14:22:20.000000000 +0200
|
||||
+++ configure.in 2009-11-09 11:33:23.000000000 +0100
|
||||
@@ -86,15 +86,6 @@
|
||||
dnl **************************************************
|
||||
dnl * Check for GnuTLS. *
|
||||
dnl **************************************************
|
||||
-AM_PATH_LIBGNUTLS(1.0.17, gnutls=yes, gnutls=no)
|
||||
-if test x$gnutls != xyes; then
|
||||
- AC_MSG_ERROR(libgnutls is required in order to build prelude-manager.)
|
||||
-fi
|
||||
-
|
||||
-old_LIBS=$LIBS
|
||||
-old_CPPFLAGS=$CPPFLAGS
|
||||
-LIBS="$LIBGNUTLS_LIBS"
|
||||
-CPPFLAGS="$LIBGNUTLS_CFLAGS"
|
||||
|
||||
AC_CHECK_LIB(gnutls, gnutls_priority_init, gnutls_string_priority=yes, gnutls_string_priority=no)
|
||||
if test x$gnutls_string_priority = xyes; then
|
||||
@@ -104,9 +95,7 @@
|
||||
AC_CHECK_HEADER(gnutls/gnutls.h, ,
|
||||
AC_MSG_ERROR("libgnutls development headers are required to build libprelude"))
|
||||
|
||||
-CPPFLAGS=$old_CPPFLAGS
|
||||
-LIBS=$old_LIBS
|
||||
-
|
||||
+AC_SUBST(LIBGNUTLS_CFLAGS,"")
|
||||
|
||||
|
||||
dnl **************************************************
|
Loading…
Reference in New Issue
Block a user