Add a port of `x11/xdo', utility to perform elementary actions on windows.

PR:	249352
This commit is contained in:
Alexey Dokuchaev 2020-11-11 19:03:59 +00:00
parent bbd9764e27
commit 6d191eca40
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=554910
5 changed files with 57 additions and 0 deletions

View File

@ -405,6 +405,7 @@
SUBDIR += xcut
SUBDIR += xditview
SUBDIR += xdm
SUBDIR += xdo
SUBDIR += xdotool
SUBDIR += xdpyinfo
SUBDIR += xdriinfo

23
x11/xdo/Makefile Normal file
View File

@ -0,0 +1,23 @@
# $FreeBSD$
PORTNAME= xdo
PORTVERSION= 0.5.7
CATEGORIES= x11
MAINTAINER= casnix@gmail.com
COMMENT= Utility to perform elementary actions on windows
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libxcb-util.so:x11/xcb-util \
libxcb-icccm.so:x11/xcb-util-wm
USES= gmake localbase:ldflags xorg
USE_XORG= xcb
USE_GITHUB= yes
GH_ACCOUNT= baskerville
PLIST_FILES= bin/xdo man/man1/xdo.1.gz
.include <bsd.port.mk>

3
x11/xdo/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1505736007
SHA256 (baskerville-xdo-0.5.7_GH0.tar.gz) = b661229f0457939d3867cca1664c5671ae959b309feb58abe9142229c8c7ffb4
SIZE (baskerville-xdo-0.5.7_GH0.tar.gz) = 7453

View File

@ -0,0 +1,24 @@
--- Makefile.orig 2017-09-18 12:00:07 UTC
+++ Makefile
@@ -2,7 +2,7 @@ NAME := xdo
VERCMD ?= git describe 2> /dev/null
VERSION := $(shell $(VERCMD) || cat VERSION)
-CPPFLAGS += -D_POSIX_C_SOURCE=200809L -DVERSION=\"$(VERSION)\"
+CPPFLAGS += -DVERSION=\"$(VERSION)\"
CFLAGS += -std=c99 -pedantic -Wall -Wextra
LDLIBS := -lxcb -lxcb-util -lxcb-icccm -lxcb-ewmh -lxcb-xtest
@@ -26,9 +26,9 @@ $(NAME): $(OBJ)
install:
mkdir -p "$(DESTDIR)$(BINPREFIX)"
- cp -p $(NAME) "$(DESTDIR)$(BINPREFIX)"
- mkdir -p "$(DESTDIR)$(MANPREFIX)/man1"
- cp -p doc/$(NAME).1 "$(DESTDIR)$(MANPREFIX)/man1"
+ $(BSD_INSTALL_PROGRAM) $(NAME) "$(DESTDIR)$(BINPREFIX)"
+ mkdir -p "$(DESTDIR)$(MANPREFIX)/man/man1"
+ $(BSD_INSTALL_MAN) doc/$(NAME).1 "$(DESTDIR)$(MANPREFIX)/man/man1"
uninstall:
rm -f "$(DESTDIR)$(BINPREFIX)/$(NAME)"

6
x11/xdo/pkg-descr Normal file
View File

@ -0,0 +1,6 @@
Apply the given action to the given windows.
If no window IDs and no options are given,
the action applies to the focused window.
WWW: https://github.com/baskerville/xdo