Update to the sources from DragonflyBSD 4.6.1. We lost piano(6),
but gained two vitally important tools: colorbars(6), which displays a couple colors in the terminal, and hals_end(6), which displays a script of HAL's final words.
This commit is contained in:
parent
bb90ff81e7
commit
6cfb99ec3b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=425015
@ -2,8 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= bsdgames
|
||||
PORTVERSION= 4.4.2
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 4.6.1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= LOCAL/adamw
|
||||
@ -15,7 +14,7 @@ LICENSE= BSD3CLAUSE
|
||||
|
||||
CONFLICTS= hangman-[0-9]*
|
||||
|
||||
USES= uidfix tar:xz
|
||||
USES= ncurses tar:xz uidfix
|
||||
MAKE_ENV+= NO_WERROR=1
|
||||
MAKE_ARGS= BINGRP=${BINGRP}
|
||||
|
||||
@ -45,6 +44,8 @@ GAMESPATH_FILES=backgammon/backgammon/backgammon.6 \
|
||||
SGID_BINARIES= atc battlestar canfield/canfield cribbage hack phantasia \
|
||||
robots sail snake/snake
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s/NOMAN/NO_MAN/" \
|
||||
${WRKSRC}/backgammon/teachgammon/Makefile \
|
||||
@ -66,6 +67,10 @@ post-patch:
|
||||
done
|
||||
@${REINPLACE_CMD} -e "s/getline/get_line/g" ${WRKSRC}/cribbage/io.c \
|
||||
${WRKSRC}/cribbage/crib.c ${WRKSRC}/cribbage/cribbage.h
|
||||
.if ${OPSYS} == "FreeBSD"
|
||||
@${FIND} ${WRKSRC} -type f -name Makefile \
|
||||
| ${XARGS} ${REINPLACE_CMD} -e 's/-lprivate_ncurses/-lncurses/'
|
||||
.endif
|
||||
|
||||
pre-install:
|
||||
.for d in atc larn quiz.db
|
||||
@ -92,4 +97,4 @@ dist:
|
||||
tar -cvf bsdgames-${PORTVERSION}.tar bsdgames-${PORTVERSION}
|
||||
xz -v bsdgames-${PORTVERSION}.tar
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (bsdgames-4.4.2.tar.xz) = a628a6cf2608b7c6b9f00e402fd60a349f8f7fde00e67713cc39a214f97d730b
|
||||
SIZE (bsdgames-4.4.2.tar.xz) = 1750804
|
||||
TIMESTAMP = 1477932679
|
||||
SHA256 (bsdgames-4.6.1.tar.xz) = 4ecb06ac99728933a38c375035a60432eb3f861fdcbd594c9d69e53009d36f9b
|
||||
SIZE (bsdgames-4.6.1.tar.xz) = 1738852
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Makefile.orig 2009-09-24 10:46:30.000000000 +0200
|
||||
+++ Makefile 2009-11-04 18:14:08.698185298 +0100
|
||||
@@ -8,32 +8,20 @@
|
||||
--- Makefile.orig 2016-10-31 16:52:06 UTC
|
||||
+++ Makefile
|
||||
@@ -8,33 +8,21 @@ SUBDIR= adventure \
|
||||
atc \
|
||||
backgammon \
|
||||
battlestar \
|
||||
@ -9,12 +9,14 @@
|
||||
- caesar \
|
||||
canfield \
|
||||
cribbage \
|
||||
colorbars \
|
||||
- dm \
|
||||
- factor \
|
||||
fish \
|
||||
- fortune \
|
||||
- grdc \
|
||||
hack \
|
||||
hals_end \
|
||||
hangman \
|
||||
hunt \
|
||||
larn \
|
||||
@ -22,7 +24,6 @@
|
||||
- morse \
|
||||
- number \
|
||||
phantasia \
|
||||
piano \
|
||||
pig \
|
||||
- pom \
|
||||
- ppt \
|
||||
|
13
games/bsdgames/files/patch-colorbars_colorbars.c
Normal file
13
games/bsdgames/files/patch-colorbars_colorbars.c
Normal file
@ -0,0 +1,13 @@
|
||||
--- colorbars/colorbars.c.orig 2016-10-31 17:00:48 UTC
|
||||
+++ colorbars/colorbars.c
|
||||
@@ -31,6 +31,10 @@
|
||||
#include <err.h>
|
||||
#include <stdlib.h>
|
||||
|
||||
+#ifndef __arysize
|
||||
+#define __arysize(n) (sizeof(n)/sizeof((n)[0]))
|
||||
+#endif
|
||||
+
|
||||
int
|
||||
main(void)
|
||||
{
|
@ -6,16 +6,17 @@ bin/backgammon
|
||||
bin/bs-game
|
||||
@(,games,2555) bin/canfield
|
||||
bin/cfscores
|
||||
bin/colorbars
|
||||
@(,games,2555) bin/cribbage
|
||||
bin/fish-game
|
||||
@(,games,2555) bin/hack
|
||||
bin/hals_end
|
||||
bin/hangman
|
||||
bin/hunt
|
||||
bin/huntd
|
||||
bin/larn
|
||||
bin/mille
|
||||
@(,games,2555) bin/phantasia
|
||||
bin/piano
|
||||
bin/pig
|
||||
bin/quiz
|
||||
bin/rain
|
||||
@ -38,16 +39,17 @@ man/man6/battlestar.6.gz
|
||||
man/man6/bs-game.6.gz
|
||||
man/man6/canfield.6.gz
|
||||
man/man6/cfscores.6.gz
|
||||
man/man6/colorbars.6.gz
|
||||
man/man6/cribbage.6.gz
|
||||
man/man6/fish-game.6.gz
|
||||
man/man6/hack.6.gz
|
||||
man/man6/hals_end.6.gz
|
||||
man/man6/hangman.6.gz
|
||||
man/man6/hunt.6.gz
|
||||
man/man6/huntd.6.gz
|
||||
man/man6/larn.6.gz
|
||||
man/man6/mille.6.gz
|
||||
man/man6/phantasia.6.gz
|
||||
man/man6/piano.6.gz
|
||||
man/man6/pig.6.gz
|
||||
man/man6/quiz.6.gz
|
||||
man/man6/rain.6.gz
|
||||
|
Loading…
Reference in New Issue
Block a user