Remove, it has been unmaintain for years and GNOME 1.x is dead.
This commit is contained in:
parent
c5b130124d
commit
6cb331a221
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=123882
1
MOVED
1
MOVED
@ -1352,3 +1352,4 @@ chinese/gnumeric|math/gnumeric|2004-12-11|obsoleted by gtk2 version
|
||||
japanese/gnumeric|math/gnumeric|2004-12-11|obsoleted by gtk2 version
|
||||
sysutils/bacula|sysutils/bacula-server|2004-12-12|split into client and server
|
||||
x11-toolkits/gtkextra--||2004-12-12|removed obsolete port
|
||||
games/gnomoku||2004-12-12|removed obsolete port
|
||||
|
@ -175,7 +175,6 @@
|
||||
SUBDIR += gnomekiss
|
||||
SUBDIR += gnomememoryblocks
|
||||
SUBDIR += gnomermind
|
||||
SUBDIR += gnomoku
|
||||
SUBDIR += gnubg
|
||||
SUBDIR += gnuchess
|
||||
SUBDIR += gnugo
|
||||
|
@ -1,26 +0,0 @@
|
||||
# New ports collection makefile for: gnomoku
|
||||
# Date created: 21 May 2001
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gnomoku
|
||||
PORTVERSION= 1.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= games gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.4
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= A Gomoku game for GNOME Desktop
|
||||
|
||||
LIB_DEPENDS= gnomemm-1.2.10:${PORTSDIR}/x11-toolkits/gnome--
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GNOME= gnomeprefix gnomehack gnomelibs
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
MD5 (gnomoku-1.4.tar.gz) = 5d4336f3aed7b68ee0997dbaeb57f83a
|
||||
SIZE (gnomoku-1.4.tar.gz) = 178406
|
@ -1,14 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.in 2001/09/11 13:48:15 1.1
|
||||
+++ Makefile.in 2001/09/11 13:48:31
|
||||
@@ -114,7 +114,7 @@
|
||||
# Main executable
|
||||
gnomoku_SOURCES = ai.cc ai.h gnomoku.cc mainwin.cc mainwin.h opponent.h options.cc options.h point.cc point.h user.cc user.h
|
||||
|
||||
-gnomoku_LDADD = $(GNOMEMM_LIBS) $(INTLLIBS) -lpthread
|
||||
+gnomoku_LDADD = $(GNOMEMM_LIBS) $(INTLLIBS)
|
||||
bin_PROGRAMS = gnomoku
|
||||
|
||||
# Desktop entry
|
@ -1,13 +0,0 @@
|
||||
--- ai.cc.orig Sat Oct 16 11:57:28 2004
|
||||
+++ ai.cc Sat Oct 16 11:57:45 2004
|
||||
@@ -56,8 +56,8 @@
|
||||
height = arows;
|
||||
length = ((height+2) * (width+1) + 1);
|
||||
|
||||
- board = new (int)[length];
|
||||
- score = new (int)[length];
|
||||
+ board = new int[length];
|
||||
+ score = new int[length];
|
||||
for (int i=0; i<length; i++) {
|
||||
board[i] = -1;
|
||||
score[i] = -1;
|
@ -1,60 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- fdstream.cc 2002/02/05 13:27:38 1.1
|
||||
+++ fdstream.cc 2002/02/05 13:35:40
|
||||
@@ -19,6 +19,8 @@
|
||||
#include "fdstream.h"
|
||||
|
||||
#include <sys/types.h>
|
||||
+#include <errno.h>
|
||||
+#include <string.h>
|
||||
#include <unistd.h>
|
||||
|
||||
namespace {
|
||||
@@ -96,7 +98,7 @@
|
||||
return (num_written == count) ? 0 : -1;
|
||||
}
|
||||
|
||||
-fdstreambuf::int_type fdstreambuf::underflow()
|
||||
+int fdstreambuf::underflow()
|
||||
{
|
||||
// Is the buffer already empty yet?
|
||||
char *tmp_gptr = gptr();
|
||||
@@ -104,7 +106,8 @@
|
||||
|
||||
char *tmp_eback = eback();
|
||||
const std::size_t num_putback =
|
||||
- std::min <std::size_t> (tmp_gptr - tmp_eback, pback_end_ - buf);
|
||||
+ (tmp_gptr - tmp_eback > pback_end_ - buf) ? pback_end_ - buf :
|
||||
+ tmp_gptr - tmp_eback;
|
||||
|
||||
// Fill putback area.
|
||||
tmp_eback = pback_end_ - num_putback;
|
||||
@@ -132,7 +135,7 @@
|
||||
|
||||
// First, empty the current buffer.
|
||||
const std::size_t buf_avail = tmp_egptr - tmp_gptr;
|
||||
- std::streamsize idx = std::min <std::size_t> (buf_avail, count);
|
||||
+ std::streamsize idx = (buf_avail > count) ? count : buf_avail;
|
||||
|
||||
std::memcpy (dest, tmp_gptr, idx);
|
||||
|
||||
@@ -149,7 +152,7 @@
|
||||
if (tmp_gptr >= pback_end_) {
|
||||
|
||||
const std::size_t num_putback =
|
||||
- std::min <std::size_t> (idx, pback_end_ - buf);
|
||||
+ (idx > pback_end_ - buf) ? pback_end_ - buf : idx;
|
||||
|
||||
tmp_eback = pback_end_ - num_putback;
|
||||
std::memcpy (tmp_eback, dest + idx - num_putback, num_putback);
|
||||
@@ -185,7 +188,7 @@
|
||||
return (fd >= 0) ? flush() : -1;
|
||||
}
|
||||
|
||||
-fdstreambuf::int_type fdstreambuf::overflow (fdstreambuf::int_type c)
|
||||
+int fdstreambuf::overflow (int c)
|
||||
{
|
||||
if (c != EOF) {
|
||||
*pptr() = int_to_char (c);
|
@ -1,14 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- fdstream.h 2002/02/05 13:25:12 1.1
|
||||
+++ fdstream.h 2002/02/05 13:36:05
|
||||
@@ -26,6 +26,8 @@
|
||||
|
||||
namespace Gnomoku
|
||||
{
|
||||
+ typedef char char_type;
|
||||
+
|
||||
class fdstreambuf : public std::streambuf
|
||||
{
|
||||
int buf_size;
|
@ -1,14 +0,0 @@
|
||||
--- mainwin.cc.orig Sat Oct 16 11:58:08 2004
|
||||
+++ mainwin.cc Sat Oct 16 11:58:36 2004
|
||||
@@ -93,9 +93,9 @@
|
||||
// Table
|
||||
Gtk::Table* table = new Gtk::Table (rows, cols, true);
|
||||
Point *p;
|
||||
- tbl = new (Point**)[rows];
|
||||
+ tbl = new Point**[rows];
|
||||
for (int y=0; y<rows; y++) {
|
||||
- tbl[y] = new (Point*)[cols];
|
||||
+ tbl[y] = new Point*[cols];
|
||||
for (int x=0; x<cols; x++) {
|
||||
p = new Point(y,x);
|
||||
tbl[y][x] = p;
|
@ -1,14 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- po/Makefile.in.in 2001/09/11 13:53:23 1.1
|
||||
+++ po/Makefile.in.in 2001/09/11 13:53:37
|
||||
@@ -106,7 +106,7 @@
|
||||
@catalogs='$(CATALOGS)'; \
|
||||
for cat in $$catalogs; do \
|
||||
cat=`basename $$cat`; \
|
||||
- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
|
||||
+ lang=`echo $$cat | sed 's/\.mo$$//'`; \
|
||||
dir=$(localedir)/$$lang/LC_MESSAGES; \
|
||||
$(mkinstalldirs) $(DESTDIR)$$dir; \
|
||||
if test -r $$cat; then \
|
@ -1,11 +0,0 @@
|
||||
--- user.cc.orig Thu Nov 28 14:12:38 2002
|
||||
+++ user.cc Thu Nov 28 14:12:54 2002
|
||||
@@ -67,7 +67,7 @@
|
||||
int User::init()
|
||||
{
|
||||
struct sockaddr_in addr;
|
||||
- size_t size;
|
||||
+ socklen_t size;
|
||||
struct hostent *host;
|
||||
int sockn;
|
||||
|
@ -1,4 +0,0 @@
|
||||
Gnomoku is a Gomoku game (tic-tac-toe on a large scale) for the
|
||||
GNOME Desktop.
|
||||
|
||||
WWW: http://www.gnome.org/
|
@ -1,17 +0,0 @@
|
||||
bin/gnomoku
|
||||
share/gnome/apps/Games/gnomoku.desktop
|
||||
share/gnome/pixmaps/gnomoku.png
|
||||
share/locale/de/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/fi/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/fr/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/hu/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/it/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/ja/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/nn/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/no/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/pt/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/ru/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/sk/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/sv/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/uk/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/gnomoku.mo
|
Loading…
Reference in New Issue
Block a user