Update to version 3.9.3

New in this release:
~~~~~~~~~~~~~~~~~~~~

* The TAB address completion in the Compose window now matches any
  part of the address and not just the beginning.

* When copying or moving a message, the type-ahead search now matches
  any part of a folder name and not just the beginning.

* It is now possible to replace the current signature in the Compose
  window by using the '/Message/Replace signature' menu item.

* It is now possible to disable the 'Subject is empty' warning
  dialogue. See the option 'Warn when Subject is empty' option on the
  '/Configuration/Preferences/Mail handling/Sending' page.

* When sending messages, if the hostname cannot be determined,
  fallback to 'localhost' rather than 'unknown', as the latter is
  rejected by some servers.

* Added better handling of messages from broken mailers, such as
  yahoo groups.

* PDF plugin: the minimum required version of poppler is 0.12.0.

* PGP/* plugin: long key IDs are now displayed in the dialogues
  instead of short IDs.

* PGP/* plugin: The automatic signature check is now non-blocking.

* Python plugin: can now access accounts, mailboxes, folder
  properties

* vCalendar plugin: webcals:// URLs are now treated as https://

* Translation updates: Brazilian Portuguese, Czech, Dutch, French,
  German, Hebrew, Slovak, Spanish, and Swedish.

* Support for Maemo has been removed.
This commit is contained in:
Pawel Pekala 2013-12-14 22:02:10 +00:00
parent bcf6d6fba2
commit 6c95bb7ab3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=336489
11 changed files with 20 additions and 456 deletions

View File

@ -6,6 +6,8 @@ PORTREVISION= 0
COMMENT= Spam filtering, bsfilter based plugin for Claws Mail
RUN_DEPENDS= bsfilter:${PORTSDIR}/mail/bsfilter
CLAWS_PLUGINS_BUILD= bsfilter
.include "../claws-mail/Makefile.claws"

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= notification
PORTREVISION= 1
PORTREVISION= 0
COMMENT= New mail notification plugin for Claws Mail

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pgp
PORTREVISION= 1
PORTREVISION= 0
COMMENT= PGP plugins for Claws Mail

View File

@ -2,12 +2,10 @@
# $FreeBSD$
PORTNAME= vcalendar
PORTREVISION= 2
PORTREVISION= 0
COMMENT= vCalendar plugin for Claws Mail
EXTRA_PATCHES= ${FILESDIR}/patch-src__plugins__vcalendar__vcal_meeting_gtk.c
CLAWS_PLUGINS_BUILD= vcalendar
.include "../claws-mail/Makefile.claws"

View File

@ -1,71 +0,0 @@
--- ./src/plugins/vcalendar/vcal_meeting_gtk.c.orig 2013-03-19 07:31:04.000000000 +0100
+++ ./src/plugins/vcalendar/vcal_meeting_gtk.c 2013-09-28 16:28:18.000000000 +0200
@@ -1433,15 +1433,31 @@
times = get_predefined_times();
- meet->start_time = gtk_combo_box_entry_new_text ();
+#if !GTK_CHECK_VERSION(2, 24, 0)
+ meet->start_time = gtk_combo_box_entry_new_text();
+#else
+ meet->start_time = gtk_combo_box_text_new_with_entry();
+#endif
gtk_combo_box_set_active(GTK_COMBO_BOX(meet->start_time), -1);
menu = GTK_LIST_STORE(gtk_combo_box_get_model(GTK_COMBO_BOX(meet->start_time)));
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(meet->start_time), times);
-
- meet->end_time = gtk_combo_box_entry_new_text ();
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(meet->start_time), times);
+#endif
+
+#if !GTK_CHECK_VERSION(2, 24, 0)
+ meet->end_time = gtk_combo_box_entry_new_text();
+#else
+ meet->end_time = gtk_combo_box_text_new_with_entry();
+#endif
gtk_combo_box_set_active(GTK_COMBO_BOX(meet->end_time), -1);
menu = GTK_LIST_STORE(gtk_combo_box_get_model(GTK_COMBO_BOX(meet->end_time)));
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(meet->end_time), times);
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(meet->end_time), times);
+#endif
list_free_strings(times);
g_list_free(times);
@@ -1597,12 +1613,14 @@
date_hbox = gtk_hbox_new(FALSE, 6);
date_vbox = gtk_vbox_new(FALSE, 6);
hbox = gtk_hbox_new(FALSE, 6);
- label = gtk_label_new(_("<b>Starts at:</b> ")); gtk_misc_set_alignment(GTK_MISC(label), 0, 0.5);
+ label = gtk_label_new(_("<b>Starts at:</b> "));
+ gtk_misc_set_alignment(GTK_MISC(label), 0, 0.5);
gtk_label_set_use_markup(GTK_LABEL(label), TRUE);
gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 0);
gtk_box_pack_start(GTK_BOX(hbox), meet->start_time, FALSE, FALSE, 0);
- label = gtk_label_new(_("<b> on:</b>")); gtk_misc_set_alignment(GTK_MISC(label), 0, 0.5);
+ label = gtk_label_new(_("<b> on:</b>"));
+ gtk_misc_set_alignment(GTK_MISC(label), 0, 0.5);
gtk_label_set_use_markup(GTK_LABEL(label), TRUE);
gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 0);
gtk_box_pack_start(GTK_BOX(date_vbox), hbox, FALSE, FALSE, 0);
@@ -1619,12 +1637,14 @@
date_vbox = gtk_vbox_new(FALSE, 6);
hbox = gtk_hbox_new(FALSE, 6);
- label = gtk_label_new(_("<b>Ends at:</b> ")); gtk_misc_set_alignment(GTK_MISC(label), 0, 0.5);
+ label = gtk_label_new(_("<b>Ends at:</b> "));
+ gtk_misc_set_alignment(GTK_MISC(label), 0, 0.5);
gtk_label_set_use_markup(GTK_LABEL(label), TRUE);
gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 0);
gtk_box_pack_start(GTK_BOX(hbox), meet->end_time, FALSE, FALSE, 0);
- label = gtk_label_new(_("<b> on:</b>")); gtk_misc_set_alignment(GTK_MISC(label), 0, 0.5);
+ label = gtk_label_new(_("<b> on:</b>"));
+ gtk_misc_set_alignment(GTK_MISC(label), 0, 0.5);
gtk_label_set_use_markup(GTK_LABEL(label), TRUE);
gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 0);
gtk_box_pack_start(GTK_BOX(date_vbox), hbox, FALSE, FALSE, 0);

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= claws-mail
PORTREVISION= 1
CATEGORIES= mail news ipv6
COMMENT= Lightweight and featureful GTK+ based e-mail and news client
@ -45,6 +44,7 @@ JPILOT_LIB_DEPENDS= libpisock.so:${PORTSDIR}/palm/pilot-link
JPILOT_RUN_DEPENDS= jpilot:${PORTSDIR}/palm/jpilot
LDAP_CONFIGURE_ENABLE= ldap
LDAP_USE= openldap=yes
MANUAL_CONFIGURE_ON= --enable-manual --with-manualdir=${DOCSDIR}/manual
MANUAL_CONFIGURE_OFF= --disable-manual
@ -59,11 +59,6 @@ STARTUP_LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notifi
THEMES_RUN_DEPENDS= ${LOCALBASE}/share/claws-mail/themes/ZX-0_1.1/down_arrow.xpm:${PORTSDIR}/x11-themes/claws-mail-themes
.include "Makefile.claws"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
.endif
post-patch:
@${REINPLACE_CMD} -e 's|-lresolv||g; s|-lpisock\"|${ICONV_LIB} &|g' \

View File

@ -1,6 +1,6 @@
# $FreeBSD$
PORTVERSION= 3.9.2
PORTVERSION= 3.9.3
CATEGORIES?= mail
MASTER_SITES= SF/sylpheed-claws/Claws%20Mail/${PORTVERSION}

View File

@ -1,2 +1,2 @@
SHA256 (claws-mail-3.9.2.tar.bz2) = e396cb67e8ecdae926dfcd59da4b3f26a633aabc0f4f00b1f24cb207f3ff2330
SIZE (claws-mail-3.9.2.tar.bz2) = 9413758
SHA256 (claws-mail-3.9.3.tar.bz2) = 53aacceab45af6c3ee1f0668956a6e3328d21ac4efcfc0aa8dfd7d7552a62372
SIZE (claws-mail-3.9.3.tar.bz2) = 9463943

View File

@ -1,361 +0,0 @@
--- src/gtk/inputdialog.c.orig 2013-03-19 07:31:04.000000000 +0100
+++ src/gtk/inputdialog.c 2013-10-04 23:12:25.000000000 +0200
@@ -1,6 +1,6 @@
/*
* Sylpheed -- a GTK+ based, lightweight, and fast e-mail client
- * Copyright (C) 1999-2012 Hiroyuki Yamamoto and the Claws Mail team
+ * Copyright (C) 1999-2013 Hiroyuki Yamamoto and the Claws Mail team
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
@@ -197,10 +197,13 @@
gtk_widget_show(icon_q);
gtk_widget_hide(icon_p);
is_pass = FALSE;
-
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_unset_popdown_strings(GTK_COMBO_BOX(combo));
combobox_set_popdown_strings(GTK_COMBO_BOX(combo), list);
-
+#else
+ combobox_unset_popdown_strings(GTK_COMBO_BOX_TEXT(combo));
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(combo), list);
+#endif
return input_dialog_open(title, message, NULL, default_string, FALSE, remember);
}
--- src/gtk/quicksearch.c.orig 2013-03-19 07:31:04.000000000 +0100
+++ src/gtk/quicksearch.c 2013-10-04 23:12:25.000000000 +0200
@@ -1,6 +1,6 @@
/*
* Claws Mail -- a GTK+ based, lightweight, and fast e-mail client
- * Copyright (C) 1999-2012 Colin Leroy <colin@colino.net>
+ * Copyright (C) 1999-2013 Colin Leroy <colin@colino.net>
* and the Claws Mail team
*
* This program is free software; you can redistribute it and/or modify
@@ -208,14 +208,23 @@
{
GtkWidget *search_string_entry = quicksearch->search_string_entry;
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_unset_popdown_strings(GTK_COMBO_BOX(search_string_entry));
-
if (prefs_common.summary_quicksearch_type == ADVANCED_SEARCH_EXTENDED)
combobox_set_popdown_strings(GTK_COMBO_BOX(search_string_entry),
quicksearch->extended_search_strings);
else
combobox_set_popdown_strings(GTK_COMBO_BOX(search_string_entry),
quicksearch->normal_search_strings);
+#else
+ combobox_unset_popdown_strings(GTK_COMBO_BOX_TEXT(search_string_entry));
+ if (prefs_common.summary_quicksearch_type == ADVANCED_SEARCH_EXTENDED)
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(search_string_entry),
+ quicksearch->extended_search_strings);
+ else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(search_string_entry),
+ quicksearch->normal_search_strings);
+#endif
}
static void update_extended_buttons (QuickSearch *quicksearch)
--- src/editaddress.c.orig 2013-03-19 07:31:04.000000000 +0100
+++ src/editaddress.c 2013-10-04 23:12:25.000000000 +0200
@@ -1,6 +1,6 @@
/*
* Sylpheed -- a GTK+ based, lightweight, and fast e-mail client
- * Copyright (C) 1999-2012 Hiroyuki Yamamoto and the Claws Mail team
+ * Copyright (C) 1999-2013 Hiroyuki Yamamoto and the Claws Mail team
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
@@ -1366,9 +1366,13 @@
#endif
gtk_combo_box_set_active(GTK_COMBO_BOX(entry_name), -1);
if (prefs_common.addressbook_custom_attributes)
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(entry_name),
prefs_common.addressbook_custom_attributes);
-
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(entry_name),
+ prefs_common.addressbook_custom_attributes);
+#endif
/* Button box */
vboxb = gtk_vbox_new( FALSE, 4 );
gtk_box_pack_start(GTK_BOX(hbox), vboxb, FALSE, FALSE, 2);
@@ -1760,10 +1764,19 @@
void addressbook_edit_reload_attr_list( void )
{
if (personeditdlg.entry_atname) {
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_unset_popdown_strings(GTK_COMBO_BOX(personeditdlg.entry_atname));
+#else
+ combobox_unset_popdown_strings(GTK_COMBO_BOX_TEXT(personeditdlg.entry_atname));
+#endif
if (prefs_common.addressbook_custom_attributes)
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(personeditdlg.entry_atname),
prefs_common.addressbook_custom_attributes);
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(personeditdlg.entry_atname),
+ prefs_common.addressbook_custom_attributes);
+#endif
}
}
--- src/compose.c.orig 2013-06-08 21:58:31.000000000 +0200
+++ src/compose.c 2013-10-04 23:12:25.000000000 +0200
@@ -1,6 +1,6 @@
/*
* Sylpheed -- a GTK+ based, lightweight, and fast e-mail client
- * Copyright (C) 1999-2012 Hiroyuki Yamamoto and the Claws Mail team
+ * Copyright (C) 1999-2013 Hiroyuki Yamamoto and the Claws Mail team
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
@@ -930,11 +930,20 @@
{
GtkEditable *entry;
if (folderidentifier) {
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_unset_popdown_strings(GTK_COMBO_BOX(compose->savemsg_combo));
+#else
+ combobox_unset_popdown_strings(GTK_COMBO_BOX_TEXT(compose->savemsg_combo));
+#endif
prefs_common.compose_save_to_history = add_history(
prefs_common.compose_save_to_history, folderidentifier);
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(compose->savemsg_combo),
prefs_common.compose_save_to_history);
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(compose->savemsg_combo),
+ prefs_common.compose_save_to_history);
+#endif
}
entry = GTK_EDITABLE(gtk_bin_get_child(GTK_BIN(compose->savemsg_combo)));
@@ -952,11 +961,20 @@
result = gtk_editable_get_chars(entry, 0, -1);
if (result) {
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_unset_popdown_strings(GTK_COMBO_BOX(compose->savemsg_combo));
+#else
+ combobox_unset_popdown_strings(GTK_COMBO_BOX_TEXT(compose->savemsg_combo));
+#endif
prefs_common.compose_save_to_history = add_history(
prefs_common.compose_save_to_history, result);
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(compose->savemsg_combo),
prefs_common.compose_save_to_history);
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(compose->savemsg_combo),
+ prefs_common.compose_save_to_history);
+#endif
}
return result;
}
@@ -6709,7 +6727,7 @@
GtkCellRenderer *cell = gtk_cell_renderer_text_new();
gtk_cell_renderer_set_alignment(cell, 0.0, 0.5);
gtk_cell_layout_pack_start(GTK_CELL_LAYOUT(combo), cell, TRUE);
- gtk_combo_box_set_entry_text_column(combo, 0);
+ gtk_combo_box_set_entry_text_column(GTK_COMBO_BOX(combo), 0);
#endif
gtk_combo_box_set_active(GTK_COMBO_BOX(combo), 0);
g_signal_connect(G_OBJECT(gtk_bin_get_child(GTK_BIN(combo))), "grab_focus",
@@ -7077,9 +7095,13 @@
gtk_widget_show(savemsg_combo);
if (prefs_common.compose_save_to_history)
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(savemsg_combo),
prefs_common.compose_save_to_history);
-
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(savemsg_combo),
+ prefs_common.compose_save_to_history);
+#endif
gtk_table_attach(GTK_TABLE(table), savemsg_combo, 1, 2, rowcount, rowcount + 1, GTK_FILL|GTK_EXPAND, GTK_SHRINK, 0, 0);
gtk_widget_set_sensitive(GTK_WIDGET(savemsg_combo), prefs_common.savemsg);
g_signal_connect_after(G_OBJECT(savemsg_combo), "grab_focus",
--- src/message_search.c.orig 2013-03-19 07:31:04.000000000 +0100
+++ src/message_search.c 2013-10-04 23:12:25.000000000 +0200
@@ -1,6 +1,6 @@
/*
* Sylpheed -- a GTK+ based, lightweight, and fast e-mail client
- * Copyright (C) 1999-2012 Hiroyuki Yamamoto and the Claws Mail team
+ * Copyright (C) 1999-2013 Hiroyuki Yamamoto and the Claws Mail team
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
@@ -193,8 +193,13 @@
#endif
gtk_combo_box_set_active(GTK_COMBO_BOX(body_entry), -1);
if (prefs_common.message_search_history)
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(body_entry),
prefs_common.message_search_history);
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(body_entry),
+ prefs_common.message_search_history);
+#endif
gtk_widget_show (body_entry);
gtk_box_pack_start (GTK_BOX (hbox1), body_entry, TRUE, TRUE, 0);
g_signal_connect(G_OBJECT(body_entry), "changed",
@@ -290,11 +295,20 @@
if (!body_str || *body_str == '\0') return;
/* add to history */
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_unset_popdown_strings(GTK_COMBO_BOX(search_window.body_entry));
+#else
+ combobox_unset_popdown_strings(GTK_COMBO_BOX_TEXT(search_window.body_entry));
+#endif
prefs_common.message_search_history = add_history(
prefs_common.message_search_history, body_str);
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(search_window.body_entry),
prefs_common.message_search_history);
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(search_window.body_entry),
+ prefs_common.message_search_history);
+#endif
case_sens = gtk_toggle_button_get_active
(GTK_TOGGLE_BUTTON(search_window.case_checkbtn));
--- src/prefs_matcher.c.orig 2013-04-27 09:06:57.000000000 +0200
+++ src/prefs_matcher.c 2013-10-04 23:12:26.000000000 +0200
@@ -655,7 +655,7 @@
GtkCellRenderer *cell = gtk_cell_renderer_text_new();
gtk_cell_renderer_set_alignment(cell, 0.0, 0.5);
gtk_cell_layout_pack_start(GTK_CELL_LAYOUT(headers_combo), cell, TRUE);
- gtk_combo_box_set_entry_text_column(headers_combo, 0);
+ gtk_combo_box_set_entry_text_column(GTK_COMBO_BOX(headers_combo), 0);
#endif
gtk_widget_set_size_request(headers_combo, 100, -1);
gtk_box_pack_start(GTK_BOX(upper_hbox), headers_combo, TRUE, TRUE, 0);
--- src/prefs_toolbar.c.orig 2013-03-19 07:31:04.000000000 +0100
+++ src/prefs_toolbar.c 2013-10-04 23:12:26.000000000 +0200
@@ -1,6 +1,6 @@
/*
* Sylpheed -- a GTK+ based, lightweight, and fast e-mail client
- * Copyright (C) 2002-2012 Hiroyuki Yamamoto & the Claws Mail team
+ * Copyright (C) 2002-2013 Hiroyuki Yamamoto & the Claws Mail team
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
@@ -382,8 +382,13 @@
GHashTable **hash;
prefs_toolbar->combo_action_list = toolbar_get_action_items(prefs_toolbar->source);
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(prefs_toolbar->item_func_combo),
prefs_toolbar->combo_action_list);
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(prefs_toolbar->item_func_combo),
+ prefs_toolbar->combo_action_list);
+#endif
/* get currently defined sylpheed actions */
if (prefs_common.actions_list != NULL) {
--- src/summary_search.c.orig 2013-03-19 07:31:04.000000000 +0100
+++ src/summary_search.c 2013-10-04 23:12:26.000000000 +0200
@@ -1,6 +1,6 @@
/*
* Sylpheed -- a GTK+ based, lightweight, and fast e-mail client
- * Copyright (C) 1999-2012 Hiroyuki Yamamoto and the Claws Mail team
+ * Copyright (C) 1999-2013 Hiroyuki Yamamoto and the Claws Mail team
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
@@ -181,10 +181,17 @@
if (result && result[0] != '\0') {
/* add to history */
-
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_unset_popdown_strings(GTK_COMBO_BOX(from));
+#else
+ combobox_unset_popdown_strings(GTK_COMBO_BOX_TEXT(from));
+#endif
*history = add_history(*history, result);
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(from), *history);
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(from), *history);
+#endif
return result;
} else {
@@ -311,8 +318,13 @@
#endif
gtk_combo_box_set_active(GTK_COMBO_BOX(from_entry), -1);
if (prefs_common.summary_search_from_history)
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(from_entry),
prefs_common.summary_search_from_history);
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(from_entry),
+ prefs_common.summary_search_from_history);
+#endif
gtk_widget_show (from_entry);
gtk_table_attach (GTK_TABLE (table1), from_entry, 1, 3, 0, 1,
GTK_EXPAND|GTK_FILL, 0, 0, 0);
@@ -330,8 +342,13 @@
#endif
gtk_combo_box_set_active(GTK_COMBO_BOX(to_entry), -1);
if (prefs_common.summary_search_to_history)
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(to_entry),
prefs_common.summary_search_to_history);
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(to_entry),
+ prefs_common.summary_search_to_history);
+#endif
gtk_widget_show (to_entry);
gtk_table_attach (GTK_TABLE (table1), to_entry, 1, 3, 1, 2,
GTK_EXPAND|GTK_FILL, 0, 0, 0);
@@ -349,8 +366,13 @@
#endif
gtk_combo_box_set_active(GTK_COMBO_BOX(subject_entry), -1);
if (prefs_common.summary_search_subject_history)
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(subject_entry),
prefs_common.summary_search_subject_history);
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(subject_entry),
+ prefs_common.summary_search_subject_history);
+#endif
gtk_widget_show (subject_entry);
gtk_table_attach (GTK_TABLE (table1), subject_entry, 1, 3, 2, 3,
GTK_EXPAND|GTK_FILL, 0, 0, 0);
@@ -368,8 +390,13 @@
#endif
gtk_combo_box_set_active(GTK_COMBO_BOX(body_entry), -1);
if (prefs_common.summary_search_body_history)
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(body_entry),
prefs_common.summary_search_body_history);
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(body_entry),
+ prefs_common.summary_search_body_history);
+#endif
gtk_widget_show (body_entry);
gtk_table_attach (GTK_TABLE (table1), body_entry, 1, 3, 3, 4,
GTK_EXPAND|GTK_FILL, 0, 0, 0);
@@ -387,8 +414,13 @@
#endif
gtk_combo_box_set_active(GTK_COMBO_BOX(adv_condition_entry), -1);
if (prefs_common.summary_search_adv_condition_history)
+#if !GTK_CHECK_VERSION(2, 24, 0)
combobox_set_popdown_strings(GTK_COMBO_BOX(adv_condition_entry),
prefs_common.summary_search_adv_condition_history);
+#else
+ combobox_set_popdown_strings(GTK_COMBO_BOX_TEXT(adv_condition_entry),
+ prefs_common.summary_search_adv_condition_history);
+#endif
gtk_widget_show (adv_condition_entry);
gtk_table_attach (GTK_TABLE (table1), adv_condition_entry, 1, 2, 4, 5,
GTK_EXPAND|GTK_FILL, 0, 0, 0);

View File

@ -1,11 +1,10 @@
--- configure.orig 2013-06-12 17:09:02.000000000 +0200
+++ configure 2013-06-12 17:10:54.000000000 +0200
@@ -21627,7 +21627,7 @@
# libpython.so
PYTHON_SHARED_LIB="libpython${PYTHON_VERSION}.so"
_save_libs="$LIBS"
- LIBS="-ldl"
+ LIBS="$lt_cv_dlopen_libs"
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to dlopen $PYTHON_SHARED_LIB works" >&5
--- configure.orig 2013-12-14 14:13:44.125318907 +0100
+++ configure 2013-12-14 14:15:18.705347095 +0100
@@ -21459,7 +21459,6 @@
if test x"$platform_win32" = xno; then
# libpython.so
PYTHON_SHARED_LIB="libpython${PYTHON_VERSION}.so"
- LIBS="-ldl"
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to dlopen $PYTHON_SHARED_LIB works" >&5
$as_echo_n "checking whether to dlopen $PYTHON_SHARED_LIB works... " >&6; }
if test "$cross_compiling" = yes; then :
if test "$cross_compiling" = yes; then :

View File

@ -78,6 +78,7 @@ include/claws-mail/expldifdlg.h
include/claws-mail/export.h
include/claws-mail/exporthtml.h
include/claws-mail/exportldif.h
include/claws-mail/file_checker.h
include/claws-mail/filtering.h
include/claws-mail/folder.h
include/claws-mail/folder_item_prefs.h
@ -171,6 +172,7 @@ include/claws-mail/plugins/claws-mail/gtkhotkey/gtkhotkey.h
include/claws-mail/plugins/claws-mail/gtkhotkey/tomboykeybinder.h
include/claws-mail/plugins/claws-mail/ical.h
include/claws-mail/plugins/pgpcore/passphrase.h
include/claws-mail/plugins/pgpcore/pgp_utils.h
include/claws-mail/plugins/pgpcore/pgp_viewer.h
include/claws-mail/plugins/pgpcore/prefs_gpg.h
include/claws-mail/plugins/pgpcore/select-keys.h