This extension provides API for communicating with ZooKeeper service.

WWW: http://pecl.php.net/package/zookeeper

PR:		ports/175917
Submitted by:	Gea-Suan Lin <gslin@gslin.org>
This commit is contained in:
Martin Wilke 2013-02-08 09:09:47 +00:00
parent 5da731a1c0
commit 6c66bd5138
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=311924
6 changed files with 48 additions and 0 deletions

View File

@ -3178,6 +3178,7 @@
SUBDIR += pecl-uuid
SUBDIR += pecl-vld
SUBDIR += pecl-xhprof
SUBDIR += pecl-zookeeper
SUBDIR += pep8
SUBDIR += performance
SUBDIR += perlconsole

View File

@ -0,0 +1,25 @@
# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
PORTNAME= zookeeper
PORTVERSION= 0.2.1
CATEGORIES= devel
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
EXTRACT_SUFX= .tgz
DIST_SUBDIR= PECL
MAINTAINER= gslin@gslin.org
COMMENT= PHP extension for interfacing with Apache ZooKeeper
LIB_DEPENDS= zookeeper_st:${PORTSDIR}/devel/zookeeper
USE_PHP= session
USE_PHP_BUILD= session
USE_PHPEXT= yes
post-install:
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/zookeeper-api.php ${DATADIR}/
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
SHA256 (PECL/zookeeper-0.2.1.tgz) = 17352a58a216273cb0883eddd0a8bbcefb00a73817a99649f42baea128f398d6
SIZE (PECL/zookeeper-0.2.1.tgz) = 17974

View File

@ -0,0 +1,14 @@
--- php_zookeeper.c.orig 2012-01-14 06:08:49.000000000 +0800
+++ php_zookeeper.c 2013-01-12 16:24:08.000000000 +0800
@@ -715,7 +715,11 @@
i_obj = ecalloc(1, sizeof(*i_obj));
zend_object_std_init( &i_obj->zo, ce TSRMLS_CC );
+#if PHP_VERSION_ID < 50399
zend_hash_copy(i_obj->zo.properties, &ce->default_properties, (copy_ctor_func_t) zval_add_ref, (void *) &tmp, sizeof(zval *));
+#else
+ object_properties_init(&(i_obj->zo), ce);
+#endif
retval.handle = zend_objects_store_put(i_obj, (zend_objects_store_dtor_t)zend_objects_destroy_object, (zend_objects_free_object_storage_t)php_zk_free_storage, NULL TSRMLS_CC);
retval.handlers = zend_get_std_object_handlers();

View File

@ -0,0 +1,3 @@
This extension provides API for communicating with ZooKeeper service.
WWW: http://pecl.php.net/package/zookeeper

View File

@ -0,0 +1,3 @@
@comment $FreeBSD$
%%DATADIR%%/zookeeper-api.php
@dirrmtry %%DATADIR%%