Add gnomebuild 0.0.2, a GNOME Build Framework (GBF).

This commit is contained in:
Maxim Sobolev 2001-07-24 12:19:37 +00:00
parent 7d2d0a6b4a
commit 6c2ea8b207
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=45434
17 changed files with 231 additions and 0 deletions

View File

@ -149,6 +149,7 @@
SUBDIR += glib13
SUBDIR += global
SUBDIR += gmake
SUBDIR += gnomebuild
SUBDIR += gnomecrash
SUBDIR += gnomedebug
SUBDIR += gnomevfs

View File

@ -0,0 +1,34 @@
# New ports collection makefile for: gnomebuild
# Date created: 24 July 2001
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gnomebuild
PORTVERSION= 0.0.2
CATEGORIES?= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/${PORTNAME:S/gnome/gnome-/}
DISTNAME= ${PORTNAME:S/gnome/gnome-/}-${PORTVERSION}
MAINTAINER?= gnome@FreeBSD.org
LIB_DEPENDS= gdl.0:${PORTSDIR}/x11-toolkits/gdl
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (gnome-build-0.0.2.tar.bz2) = b11ea327dfec58a80b62c1ef41f3f889

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- Makefile.in 2001/07/24 11:40:27 1.1
+++ Makefile.in 2001/07/24 11:40:57
@@ -148,7 +148,7 @@
SUBDIRS = po intl src idl
-confexecdir = $(libdir)
+confexecdir = $(sysconfdir)
confexec_DATA = gnome_buildConf.sh
bin_SCRIPTS = gnome-build-clean.sh

View File

@ -0,0 +1,18 @@
$FreeBSD$
--- ltmain.sh 2001/07/23 09:45:58 1.1
+++ ltmain.sh 2001/07/23 09:46:28
@@ -4175,10 +4175,12 @@
fi
# Install the pseudo-library for information purposes.
+ if false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -0,0 +1,17 @@
$FreeBSD$
--- src/backends/libgbf_am/gbf-am-project.c 2001/07/24 11:44:39 1.1
+++ src/backends/libgbf_am/gbf-am-project.c 2001/07/24 11:46:14
@@ -33,6 +33,11 @@
#include "../../lib/gnome-build.h"
#include "gbf-am-project.h"
+#ifdef __FreeBSD__
+extern char **environ;
+#define __environ environ
+#endif
+
#define SCRIPT_NAME "gbf-am-parse"
#define BUILD_SCRIPT_NAME "gbf-am-build"

View File

@ -0,0 +1 @@
A GNOME Build Framework (GBF)

View File

@ -0,0 +1,3 @@
This is a GNOME Build Framework (GBF).
WWW: http://www.gnome.org/

View File

@ -0,0 +1,27 @@
bin/gbf-am-build
bin/gbf-am-parse
bin/gbf-am-project
bin/gbf-controls-server
bin/gnome-build-clean.sh
etc/gnome_buildConf.sh
include/gbf/gbf-build-info.h
include/gbf/gbf-project-client.h
include/gbf/gbf-project-tree.h
include/gbf/gbf-target-tree.h
include/gbf/gbf-widgets.h
include/gbf/gbf.h
include/gbf/gnome-build.h
lib/libgbf-widgets.a
lib/libgbf-widgets.so
lib/libgbf-widgets.so.0
lib/libgbf.a
lib/libgbf.so
lib/libgbf.so.0
share/gnome/idl/gbf-project.idl
share/gnome/idl/gnome-build.idl
share/gnome/oaf/GNOME_Development_BuildControls.oaf
share/gnome/oaf/GNOME_Development_Project_Automake.oaf
share/gnome/pixmaps/gbf-build.png
share/gnome/pixmaps/gbf-install.png
share/gnome/ui/gbf-tree.xml
@dirrm include/gbf

34
devel/gnomebuild/Makefile Normal file
View File

@ -0,0 +1,34 @@
# New ports collection makefile for: gnomebuild
# Date created: 24 July 2001
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gnomebuild
PORTVERSION= 0.0.2
CATEGORIES?= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/${PORTNAME:S/gnome/gnome-/}
DISTNAME= ${PORTNAME:S/gnome/gnome-/}-${PORTVERSION}
MAINTAINER?= gnome@FreeBSD.org
LIB_DEPENDS= gdl.0:${PORTSDIR}/x11-toolkits/gdl
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (gnome-build-0.0.2.tar.bz2) = b11ea327dfec58a80b62c1ef41f3f889

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- Makefile.in 2001/07/24 11:40:27 1.1
+++ Makefile.in 2001/07/24 11:40:57
@@ -148,7 +148,7 @@
SUBDIRS = po intl src idl
-confexecdir = $(libdir)
+confexecdir = $(sysconfdir)
confexec_DATA = gnome_buildConf.sh
bin_SCRIPTS = gnome-build-clean.sh

View File

@ -0,0 +1,18 @@
$FreeBSD$
--- ltmain.sh 2001/07/23 09:45:58 1.1
+++ ltmain.sh 2001/07/23 09:46:28
@@ -4175,10 +4175,12 @@
fi
# Install the pseudo-library for information purposes.
+ if false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -0,0 +1,17 @@
$FreeBSD$
--- src/backends/libgbf_am/gbf-am-project.c 2001/07/24 11:44:39 1.1
+++ src/backends/libgbf_am/gbf-am-project.c 2001/07/24 11:46:14
@@ -33,6 +33,11 @@
#include "../../lib/gnome-build.h"
#include "gbf-am-project.h"
+#ifdef __FreeBSD__
+extern char **environ;
+#define __environ environ
+#endif
+
#define SCRIPT_NAME "gbf-am-parse"
#define BUILD_SCRIPT_NAME "gbf-am-build"

View File

@ -0,0 +1 @@
A GNOME Build Framework (GBF)

View File

@ -0,0 +1,3 @@
This is a GNOME Build Framework (GBF).
WWW: http://www.gnome.org/

View File

@ -0,0 +1,27 @@
bin/gbf-am-build
bin/gbf-am-parse
bin/gbf-am-project
bin/gbf-controls-server
bin/gnome-build-clean.sh
etc/gnome_buildConf.sh
include/gbf/gbf-build-info.h
include/gbf/gbf-project-client.h
include/gbf/gbf-project-tree.h
include/gbf/gbf-target-tree.h
include/gbf/gbf-widgets.h
include/gbf/gbf.h
include/gbf/gnome-build.h
lib/libgbf-widgets.a
lib/libgbf-widgets.so
lib/libgbf-widgets.so.0
lib/libgbf.a
lib/libgbf.so
lib/libgbf.so.0
share/gnome/idl/gbf-project.idl
share/gnome/idl/gnome-build.idl
share/gnome/oaf/GNOME_Development_BuildControls.oaf
share/gnome/oaf/GNOME_Development_Project_Automake.oaf
share/gnome/pixmaps/gbf-build.png
share/gnome/pixmaps/gbf-install.png
share/gnome/ui/gbf-tree.xml
@dirrm include/gbf