- Add port for graphics/visprint

Visprint makes fractal fingerprint png images based on the contents of any
file. The image will be different for almost every file with even slightly
different contents. Visprint uses the IFS fractal generation process,
pioneered by Michael Barnsley. It is a way to create images which are
self-similar to infinite depths. In other words, the picture is made up of
smaller versions of itself.

Author: Goiz "Samhain" <hackerbunny@tastyrabbit.net>
WWW:    http://www.tastyrabbit.net/visprint/
This commit is contained in:
Stanislav Sedov 2006-11-11 16:12:32 +00:00
parent 4907ff8ace
commit 6c283f47a9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=177058
5 changed files with 58 additions and 0 deletions

View File

@ -664,6 +664,7 @@
SUBDIR += vigra
SUBDIR += vips
SUBDIR += visionegg
SUBDIR += visprint
SUBDIR += vp
SUBDIR += vvv
SUBDIR += whirlgif

View File

@ -0,0 +1,35 @@
# New ports collection makefile for: visprint
# Date created: 11 November 2006
# Whom: stas
#
# $FreeBSD$
#
PORTNAME= visprint
PORTVERSION= 2.0
CATEGORIES= graphics
MASTER_SITES= http://www.tastyrabbit.net/visprint/download/
MAINTAINER= stas@FreeBSD.org
COMMENT= Creates fractal fingerprint images based on any data
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lpng
MANCOMPRESSED= yes
PLIST_FILES= bin/visprint
MAN1= visprint.1
do-build:
(cd ${WRKSRC} && ${CC} ${CFLAGS} -c visprint.c)
(cd ${WRKSRC} && ${CC} ${LDFLAGS} visprint.o -o visprint)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/visprint ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/visprint.1.gz ${PREFIX}/man/man1
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (visprint-2.0.tar.gz) = f40a2e90779b105b43a72c2aada161d1
SHA256 (visprint-2.0.tar.gz) = f153e2feacd2eaa71014fa0a62bd93088c936b2dea7f0c480d308be9906a5526
SIZE (visprint-2.0.tar.gz) = 14411

View File

@ -0,0 +1,10 @@
--- visprint.c.orig Sat Nov 11 18:58:22 2006
+++ visprint.c Sat Nov 11 18:58:25 2006
@@ -33,7 +33,6 @@
#include <string.h>
#include <fcntl.h>
#include <png.h>
-#include <sys/io.h>
#define MAX_RES 1000
#define DEFAULT_RES 300

View File

@ -0,0 +1,9 @@
Visprint makes fractal fingerprint png images based on the contents of any
file. The image will be different for almost every file with even slightly
different contents. Visprint uses the IFS fractal generation process,
pioneered by Michael Barnsley. It is a way to create images which are
self-similar to infinite depths. In other words, the picture is made up of
smaller versions of itself.
Author: Goiz "Samhain" <hackerbunny@tastyrabbit.net>
WWW: http://www.tastyrabbit.net/visprint/