Remove guile-gobject. It hasn't worked, and wasn't showing signs of
changing that fact.
This commit is contained in:
parent
896b32cc70
commit
6bfd46bf46
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=97588
@ -1,30 +0,0 @@
|
||||
# New ports collection makefile for: guile-gobject
|
||||
# Date created: 02 May 2003
|
||||
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= guile-gobject
|
||||
PORTVERSION= 0.4.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= x11-toolkits scheme
|
||||
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
|
||||
MASTER_SITE_SUBDIR= guile-gtk
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= Guile bindings for core GNOME 2 libraries
|
||||
|
||||
LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
|
||||
|
||||
IGNORE= "Does not build with GNOME 2.4"
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_BISON= yes
|
||||
USE_GNOME= gtk20 libbonobo
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1 +0,0 @@
|
||||
MD5 (guile-gobject-0.4.0.tar.gz) = 670b9e0198062238a197945e46273359
|
@ -1,10 +0,0 @@
|
||||
--- configure.orig Wed Dec 11 18:31:51 2002
|
||||
+++ configure Thu Dec 12 12:07:17 2002
|
||||
@@ -7414,6 +7414,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
@ -1,15 +0,0 @@
|
||||
--- corba/Makefile.in.orig Fri May 2 01:41:50 2003
|
||||
+++ corba/Makefile.in Fri May 2 01:42:11 2003
|
||||
@@ -484,9 +484,9 @@
|
||||
guile-snarf $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< > $@ \
|
||||
|| { rm $@; false; }
|
||||
.c.doc:
|
||||
- -(guile-func-name-check $<)
|
||||
- (guile-snarf-docs $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< | \
|
||||
- guile_filter_doc_snarfage --filter-snarfage) > $@ || { rm $@; false; }
|
||||
+# -(guile-func-name-check $<)
|
||||
+# (guile-snarf-docs $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< | \
|
||||
+# guile_filter_doc_snarfage --filter-snarfage) > $@ || { rm $@; false; }
|
||||
|
||||
guile-gnome-corba.texi: $(DOT_DOC_FILES)
|
||||
cat $(DOT_DOC_FILES) | guile-snarf-docs-texi > $@ \
|
@ -1,53 +0,0 @@
|
||||
--- gobject/Makefile.in.orig Mon Nov 4 09:54:05 2002
|
||||
+++ gobject/Makefile.in Fri May 2 01:48:41 2003
|
||||
@@ -160,8 +160,8 @@
|
||||
|
||||
|
||||
DOT_DOC_FILES = \
|
||||
- guile-gnome-gobject.doc \
|
||||
- guile-gnome-gobject-primitives.doc
|
||||
+# guile-gnome-gobject.doc \
|
||||
+# guile-gnome-gobject-primitives.doc
|
||||
|
||||
|
||||
SUFFIXES = .x .doc
|
||||
@@ -173,7 +173,7 @@
|
||||
$(DOT_X_FILES) $(DOT_DOC_FILES)
|
||||
|
||||
|
||||
-CLEANFILES = $(BUILT_SOURCES) guile-gnome-gobject.texi
|
||||
+CLEANFILES = $(BUILT_SOURCES) # guile-gnome-gobject.texi
|
||||
|
||||
EXTRA_DIST = gobject.scm primitives.scm gnome-gobject.gwp
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
@@ -486,9 +486,9 @@
|
||||
guile-snarf $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< > $@ \
|
||||
|| { rm $@; false; }
|
||||
.c.doc:
|
||||
- -(guile-func-name-check $<)
|
||||
- (guile-snarf-docs $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< | \
|
||||
- guile_filter_doc_snarfage --filter-snarfage) > $@ || { rm $@; false; }
|
||||
+# -(guile-func-name-check $<)
|
||||
+# (guile-snarf-docs $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< | \
|
||||
+# guile_filter_doc_snarfage --filter-snarfage) > $@ || { rm $@; false; }
|
||||
|
||||
gnomegobject.h gnomegobject.c gnomegobject.html: gnome-gobject.gwp
|
||||
FLAVOR=gnome guile -c \
|
||||
@@ -496,12 +496,12 @@
|
||||
(primitive-load \"$(srcdir)/gnome-gobject.gwp\")"
|
||||
|
||||
guile-gnome-gobject.texi: $(DOT_DOC_FILES)
|
||||
- cat $(DOT_DOC_FILES) | guile-snarf-docs-texi > $@ \
|
||||
- || { rm $@; false; }
|
||||
+# cat $(DOT_DOC_FILES) | guile-snarf-docs-texi > $@ \
|
||||
+# || { rm $@; false; }
|
||||
|
||||
-guile-gnome-gobject-procedures.txt: guile-gnome-gobject.texi
|
||||
- rm -f $@
|
||||
- makeinfo --force -o $@ $< || test -f $@
|
||||
+guile-gnome-gobject-procedures.txt: # guile-gnome-gobject.texi
|
||||
+# rm -f $@
|
||||
+# makeinfo --force -o $@ $< || test -f $@
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
@ -1,3 +0,0 @@
|
||||
GUILE bindings for core GNOME 2 libraries.
|
||||
|
||||
WWW: http://www.gnu.org/software/guile-gtk/index.html
|
@ -1,25 +0,0 @@
|
||||
lib/libguile-gnome-corba.a
|
||||
lib/libguile-gnome-corba.so
|
||||
lib/libguile-gnome-corba.so.0
|
||||
lib/libguile-gnome-gobject.a
|
||||
lib/libguile-gnome-gobject.so
|
||||
lib/libguile-gnome-gobject.so.0
|
||||
lib/libguile-gnome-gtk.a
|
||||
lib/libguile-gnome-gtk.so
|
||||
lib/libguile-gnome-gtk.so.0
|
||||
lib/orbit/Foo_module.a
|
||||
lib/orbit/Foo_module.so
|
||||
lib/orbit/Foo_module.so.0
|
||||
share/guile/gnome/corba.scm
|
||||
share/guile/gnome/corba/primitives.scm
|
||||
share/guile/gnome/corba/types.scm
|
||||
share/guile/gnome/gobject.scm
|
||||
share/guile/gnome/gobject/primitives.scm
|
||||
share/guile/gnome/gtk.scm
|
||||
@dirrm share/guile/gnome/gobject
|
||||
@dirrm share/guile/gnome/corba
|
||||
@dirrm share/guile/gnome
|
||||
@dirrm share/guile-gobject/0.4.0
|
||||
@dirrm share/guile-gobject
|
||||
@dirrm share/guile
|
||||
@dirrm lib/orbit
|
Loading…
Reference in New Issue
Block a user