Upgrade from 0.6.0 to 0.6.1. Samba >= 3.5 is now required and

the use of gnome-ring was replaced with use of libsecret (now
off by default).

Make sure to use our native iconv-implementation and only use
glib20 at build-time for its built-in atomic macros.

Claim maintainership for now to deal with any fallout...
This commit is contained in:
Mikhail Teterin 2018-01-29 18:32:31 +00:00
parent cc325f3a8f
commit 6be6883de3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=460320
5 changed files with 77 additions and 20 deletions

View File

@ -2,32 +2,40 @@
# $FreeBSD$
PORTNAME= smbnetfs
PORTVERSION= 0.6.0
PORTREVISION= 3
PORTVERSION= 0.6.1
CATEGORIES= sysutils net
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/SMBNetFS-${PORTVERSION}
PKGNAMEPREFIX= fusefs-
MAINTAINER= ports@FreeBSD.org
MAINTAINER= mi@aldan.algebra.com
COMMENT= Mount smb shares (Fuse filesystem)
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
OPTIONS_DEFINE= DOCS GNOME_KEYRING
OPTIONS_DEFAULT=GNOME_KEYRING
OPTIONS_DEFINE= DOCS LIBSECRET
GNOME_KEYRING_DESC= Build with gnome-keyring support
GNOME_KEYRING_CONFIGURE_WITH= gnome-keyring
GNOME_KEYRING_LIB_DEPENDS= libgnome-keyring.so:security/libgnome-keyring
LIBSECRET_DESC= Use libsecret to store credentials
LIBSECRET_CONFIGURE_WITH= libsecret
LIBSECRET_LIB_DEPENDS= libsecret-*.so:security/libsecret
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
USES= fuse iconv pkgconfig samba:lib tar:bzip2
USE_GNOME= glib20
USE_GNOME= glib20:build
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
# A hack to disable gratuitous linking with -lglib-2.0
CONFIGURE_ENV+= GLIB_LIBS=-L/var/empty
CFLAGS+= -I${SAMBAINCLUDES}
LDFLAGS+= -L${SAMBALIBS}
SUB_FILES= pkg-message
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
.if ${ICONV_LIB} == ""
CONFIGURE_ENV+= ac_cv_lib_iconv_iconv_open=yes
CONFIGURE_ARGS+=--with-libiconv=native
.endif
.include <bsd.port.post.mk>

View File

@ -1,2 +1,3 @@
SHA256 (smbnetfs-0.6.0.tar.bz2) = 6dd20bf01201f8be4b5d20cfbfba627f6825bcb60fe71f54d8c8de18509e519b
SIZE (smbnetfs-0.6.0.tar.bz2) = 147946
TIMESTAMP = 1517243562
SHA256 (smbnetfs-0.6.1.tar.bz2) = 848b8ee4c1b5cc4c83ee35736cb28e1ddcd5789cca948f060e8cb76baa95380a
SIZE (smbnetfs-0.6.1.tar.bz2) = 171032

View File

@ -0,0 +1,12 @@
--- src/function.c 2018-01-04 20:59:38 UTC
+++ src/function.c
@@ -8,7 +8,9 @@
#include <dirent.h>
#include <sys/statvfs.h>
#include <sys/types.h>
+#ifdef __linux__
#include <attr/xattr.h>
+#endif
#include <time.h>
#include <pthread.h>
#include <libsmbclient.h>

View File

@ -0,0 +1,38 @@
--- src/list.h 2018-01-04 20:59:38 UTC
+++ src/list.h
@@ -23,7 +23,7 @@ static inline LIST* last_list_elem(LIST
static inline void add_to_list(LIST *list, LIST *elem){
/* Yes, i want SIGSEGV for debug */
- if ((elem->next != NULL) || (elem->prev != NULL)) *((char*)NULL) = '\0';
+ if ((elem->next != NULL) || (elem->prev != NULL)) __builtin_trap();
elem->next = list->next;
elem->prev = list;
@@ -33,7 +33,7 @@ static inline void add_to_list(LIST *lis
static inline void add_to_list_back(LIST *list, LIST *elem){
/* Yes, i want SIGSEGV for debug */
- if ((elem->next != NULL) || (elem->prev != NULL)) *((char*)NULL) = '\0';
+ if ((elem->next != NULL) || (elem->prev != NULL)) __builtin_trap();
elem->next = list;
elem->prev = list->prev;
@@ -45,7 +45,7 @@ static inline void insert_to_list_after(
(void)list;
/* Yes, i want SIGSEGV for debug */
- if ((new_elem->next != NULL) || (new_elem->prev != NULL)) *((char*)NULL) = '\0';
+ if ((new_elem->next != NULL) || (new_elem->prev != NULL)) __builtin_trap();
new_elem->next = elem->next;
new_elem->prev = elem;
@@ -57,7 +57,7 @@ static inline void insert_to_list_before
(void)list;
/* Yes, i want SIGSEGV for debug */
- if ((new_elem->next != NULL) || (new_elem->prev != NULL)) *((char*)NULL) = '\0';
+ if ((new_elem->next != NULL) || (new_elem->prev != NULL)) __builtin_trap();
new_elem->next = elem;
new_elem->prev = elem->prev;

View File

@ -1,23 +1,21 @@
===> Basic Instructions:
After kldload fuse.ko (see sysutils/fusefs-kmod documentation) and setting
After kldload fuse.ko and setting
# sysctl vfs.usermount=1
you should make .smb directory in your homedir:
% mkdir ~/.smb
Copy your smb.conf (usually in %%PREFIX%%/etc/) and
%%DOCSDIR%%/smbnetfs.conf to this directory:
% cp %%PREFIX%%/etc/smb.conf %%DOCSDIR%%/smbnetfs.conf ~/.smb/
Make mountpoint for smb network and mount it:
% mkdir ~/mountpoint
% smbnetfs ~/mountpoint
Now you can get access to smb shares in your network, for example:
% cd ~/mountpoint/ip-addr
XXX Note, use of Gnome keyring was replaced in version 0.6.1 with
XXX libsecret, which this port no longer enables by default.