add sigit 0.0.4

A tool to create random signatures

PR:		29881
This commit is contained in:
Pete Fritchman 2001-08-26 04:55:22 +00:00
parent 48666decfc
commit 6be5f1bed3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46920
7 changed files with 107 additions and 0 deletions

View File

@ -175,6 +175,7 @@
SUBDIR += sendmail-ldap
SUBDIR += sendmail-sasl
SUBDIR += serialmail
SUBDIR += sigit
SUBDIR += sigrot
SUBDIR += smail
SUBDIR += smapi

27
mail/sigit/Makefile Normal file
View File

@ -0,0 +1,27 @@
# New ports collection makefile for: sigit
# Date created: 18 August 2001
# Whom: petef
#
# $FreeBSD$
#
PORTNAME= sigit
PORTVERSION= 0.0.4
CATEGORIES= mail
MASTER_SITES= http://www.math.ku.dk/~m99khn/download/stable/
MAINTAINER= petef@FreeBSD.org
USE_GMAKE= yes
MAN1= sigit.1 sigit.rc.1
post-patch:
@${PERL} -pi -e 's,/etc/sigit.rc,${PREFIX}/etc/sigit.rc,; \
s,/usr/share/sigit,${DATADIR},' ${WRKSRC}/config.h
post-install:
@(if [ ! -f ${PREFIX}/etc/sigit.rc ]; then \
${CP} ${PREFIX}/etc/sigit.rc.dist ${PREFIX}/etc/sigit.rc; fi)
.include <bsd.port.mk>

1
mail/sigit/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (sigit-0.0.4.tar.gz) = a35bf12b85617254af81dcf5728c4291

View File

@ -0,0 +1,62 @@
--- Makefile.orig Thu Mar 15 18:28:16 2001
+++ Makefile Sat Aug 18 21:03:35 2001
@@ -6,23 +6,22 @@
OS=$(shell uname -s)
# Compiler
-CC=gcc
+CC?=gcc
# Install prefix Where the database and original file is placed..
-PREFIX=/usr/share/sigit
# Installation directory -- where the binary will go
-INSTALLDIR=/usr/bin
+INSTALLDIR=${PREFIX}/bin
# Where the default sigit configuration will be
-RCDIR=/etc
+RCDIR=${PREFIX}/etc
# Where the systems man pages are placed..
-MANDIR=/usr/share/man
+MANDIR=${PREFIX}/man
# if you want to test something..
@@ -47,11 +46,11 @@
endif
# Compiler flags
-CFLAGS= -Wall -O2 -D$(OS) $(FLAGS)
+CFLAGS+= -Wall -D$(OS) $(FLAGS)
# This is needed for "make install"
OWNER = root
-GROUP = root
+GROUP = wheel
INSTALL = /usr/bin/install -o $(OWNER) -g $(GROUP)
@@ -98,14 +97,14 @@
install:
- $(INSTALL) -d $(PREFIX)
+ $(INSTALL) -d $(PREFIX)/share/sigit
$(INSTALL) -d $(INSTALLDIR)
$(INSTALL) -d $(RCDIR)
$(INSTALL) -d $(MANDIR)/man1
$(INSTALL) -m 555 $(EXE) $(INSTALLDIR)
- $(INSTALL) -m 664 sigit.data $(PREFIX)
- $(INSTALL) -m 664 sigit.sig $(PREFIX)
- $(INSTALL) -m 664 sigit.rc $(RCDIR)
+ $(INSTALL) -m 664 sigit.data $(PREFIX)/share/sigit
+ $(INSTALL) -m 664 sigit.sig $(PREFIX)/share/sigit
+ $(INSTALL) -m 664 sigit.rc $(RCDIR)/sigit.rc.dist
$(INSTALL) -m 444 sigit.1 $(MANDIR)/man1
$(INSTALL) -m 444 sigit.rc.1 $(MANDIR)/man1

1
mail/sigit/pkg-comment Normal file
View File

@ -0,0 +1 @@
A tool to create random signatures

8
mail/sigit/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
sigit is a tool that runs in the background and puts a random quote
in a file (usually .plan or .signature) at a configurable interval.
It comes with sample data, and custom quotes can be added.
WWW: http://www.redhead.dk/download/sigit-download.html
- Pete
petef@FreeBSD.org

7
mail/sigit/pkg-plist Normal file
View File

@ -0,0 +1,7 @@
bin/sigit
@unexec if cmp -s %D/etc/sigit.rc.dist %D/etc/sigit.rc; then rm -f %D/etc/sigit.rc; fi
etc/sigit.rc.dist
@exec if [ ! -f %D/etc/sigit.rc ]; then cp %D/etc/%f %D/etc/sigit.rc; fi
share/sigit/sigit.data
share/sigit/sigit.sig
@dirrm share/sigit