- Update to 2.9

- Add knob to build with SDL instead of glut.

PR:		ports/59319
Submitted by:	Mezz <mezz7@cox.net>
Approved by:	Thomas Vogt (maintainer)
Approved by:	marcus (backup mentor)
This commit is contained in:
Pav Lucistnik 2003-11-16 18:56:32 +00:00
parent cad4a555e6
commit 6b84f63230
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=94116
6 changed files with 58 additions and 33 deletions

View File

@ -6,34 +6,58 @@
#
PORTNAME= foobillard
PORTVERSION= 2.6
PORTREVISION= 1
PORTVERSION= 2.9
CATEGORIES= games
MASTER_SITES= http://foobillard.sunsite.dk/dnl/
MAINTAINER= thomas.vogt@bsdunix.ch
COMMENT= A free OpenGL-billard game
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
png.5:${PORTSDIR}/graphics/png \
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
USE_GETOPT_LONG=yes
USE_MESA= yes
USE_GMAKE= yes
MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CPPFLAGS= -I${X11BASE}/include
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
.if defined(WITH_SDL)
USE_SDL= yes
CONFIGURE_ARGS+= --enable-SDL
.else
LIB_DEPENDS+= glut.3:${PORTSDIR}/graphics/libglut
CONFIGURE_ARGS+= --enable-glut
.endif
.if !defined(WITH_NVIDIA_BUMPREF)
CONFIGURE_ARGS+= --disable-bumpref
CONFIGURE_ARGS+= --disable-nvidia
.endif
MAN6= foobillard.6
MANCOMPRESSED= no
pre-everything::
.if !defined(WITH_SDL) || !defined(WITH_NVIDIA_BUMPREF)
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} ""
.endif
.if !defined(WITH_SDL)
@${ECHO_MSG} "WITH_SDL=yes to use SDL-lib instead of glut"
.endif
.if !defined(WITH_NVIDIA_BUMPREF)
@${ECHO_MSG} "WITH_NVIDIA_BUMPREF=yes to enable NV-extensions"
.endif
post-patch:
@${REINPLACE_CMD} -e 's|%%FREETYPE_CONFIG%%|${FREETYPE_CONFIG}|g' \
${WRKSRC}/src/Makefile.in
post-install:
@${INSTALL_MAN} ${WRKSRC}/foobillard.6 ${PREFIX}/man/man6/foobillard.6

View File

@ -1 +1 @@
MD5 (foobillard-2.6.tar.gz) = 988dde14ecb7765bc28e365295ec082d
MD5 (foobillard-2.9.tar.gz) = b8b10d7d3ade07a9e0c497165beadbca

View File

@ -1,9 +1,9 @@
--- src/Makefile.in.orig Thu May 1 08:44:52 2003
+++ src/Makefile.in Fri Jul 25 13:44:28 2003
@@ -69,9 +69,9 @@
INCLUDES = -DNDEBUG -DDATA_DIRECTORY='"${pkgdatadir}/"'
--- src/Makefile.in.orig Sat Nov 15 21:06:49 2003
+++ src/Makefile.in Sat Nov 15 21:09:47 2003
@@ -171,9 +171,9 @@
#CXXFLAGS = -O6 -s
#CFLAGS = -DXMESA -Wall -O3 -I$(INCDIR)
#CFLAGS = -Wall -O3 -I$(INCDIR) `freetype-config --cflags`
-@USE_SDL_TRUE@SDL_CFLAGS = `sdl-config --cflags` -DUSE_SDL
+@USE_SDL_TRUE@SDL_CFLAGS = `$(SDL_CONFIG) --cflags` -DUSE_SDL
@USE_SDL_FALSE@SDL_CFLAGS =
@ -12,17 +12,17 @@
@USE_SDL_FALSE@SDL_LIBS =
@USE_SDL_TRUE@GLUT_LIBS =
@USE_SDL_FALSE@GLUT_LIBS = -lglut
@@ -80,11 +80,11 @@
@USE_BUMPREF_TRUE@BUMPREF_CFLAGS =
@USE_BUMPREF_FALSE@BUMPREF_CFLAGS = -DNO_NV_BUMPREF
@@ -187,11 +187,11 @@
@USE_SOUND_TRUE@SOUND_CFLAGS = -DUSE_SOUND
@USE_SOUND_FALSE@SOUND_CFLAGS =
-CFLAGS = -Wall `freetype-config --cflags` ${SDL_CFLAGS} ${BUMPREF_CFLAGS} ${DEBUG_CFLAGS}
+CFLAGS += -Wall `freetype-config --cflags` ${SDL_CFLAGS} ${BUMPREF_CFLAGS} ${DEBUG_CFLAGS}
-AM_CFLAGS = -Wall `freetype-config --cflags` ${SDL_CFLAGS} ${NVIDIA_CFLAGS} ${SOUND_CFLAGS} ${DEBUG_CFLAGS}
+AM_CFLAGS = -Wall `%%FREETYPE_CONFIG%% --cflags` ${SDL_CFLAGS} ${NVIDIA_CFLAGS} ${SOUND_CFLAGS} ${DEBUG_CFLAGS}
#LIBS = -L$(LIBDIR) -lglut -lGLU -lGL -lXext -lXaw -lm -lXi -lpng -lz
#LIBS = -L$(LIBDIR) -lglut -lGLU -lGL -lXext -lXaw -lm -lXi -lpng -lz
-LDFLAGS = ${all_libraries} `freetype-config --libs` ${SDL_LIBS} ${GLUT_LIBS}
+LDFLAGS = ${all_libraries} `freetype-config --libs` ${SDL_LIBS} ${GLUT_LIBS} @LDFLAGS@
-AM_LDFLAGS = ${all_libraries} `freetype-config --libs` ${SDL_LIBS} ${GLUT_LIBS}
+AM_LDFLAGS = ${all_libraries} `%%FREETYPE_CONFIG%% --libs` ${SDL_LIBS} ${GLUT_LIBS}
#LDADD = ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz -L/home/floh/nvsdk/OpenGL/lib/ -lnvparse
LDADD = ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
subdir = src

View File

@ -1,5 +1,5 @@
--- src/billard3d.c.orig Thu May 1 08:32:10 2003
+++ src/billard3d.c Mon Jul 7 04:29:04 2003
--- src/billard3d.c.orig Sat Nov 15 21:10:47 2003
+++ src/billard3d.c Sat Nov 15 21:12:13 2003
@@ -24,7 +24,7 @@
#include <string.h>
#include <math.h>
@ -9,16 +9,16 @@
#ifndef USE_SDL
#include <GL/glut.h>
@@ -4270,7 +4270,7 @@
@@ -4960,7 +4960,7 @@
/* config file */
load_config( &confv, &confc, argv, argc );
- while( ( act_option = getopt_long_only(confc, confv, "+", long_options, &option_index) ) >= 0){
+ while( ( act_option = getopt_long(confc, confv, "+", long_options, &option_index) ) >= 0){
DPRINTF("processing option %d=%s\n",act_option,optarg);
process_option(act_option);
}
DPRINTF("main:rgstereo=%d",options_rgstereo_on);
@@ -4359,7 +4359,7 @@
@@ -5058,7 +5058,7 @@
fread( &ball_ball_snd.data[SOUND_NULLOFFS*2], 1, ball_ball_snd.len-SOUND_NULLOFFS*2*2 , f );
fclose(f);

View File

@ -1,11 +1,11 @@
--- src/sys_stuff.c.orig Sat Oct 26 20:47:23 2002
+++ src/sys_stuff.c Sat Oct 26 20:47:32 2002
--- src/sys_stuff.c.orig Sat Nov 15 21:24:23 2003
+++ src/sys_stuff.c Sat Nov 15 21:25:20 2003
@@ -5,7 +5,7 @@
#ifndef USE_SDL
#include <GL/glut.h>
#else
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
+#include <SDL.h>
#include <GL/gl.h>
#include <GL/glu.h>
#endif

View File

@ -3,6 +3,7 @@ share/foobillard/ball_ball.raw
share/foobillard/blende.png
share/foobillard/bluebold.ttf
share/foobillard/bumpref.png
share/foobillard/cloth.png
share/foobillard/cue_shadow.png
share/foobillard/foobillard.gif
share/foobillard/foobillard.png