Update to 0.93.5.

Submitted by:	tkato@prontomail.ne.jp
PR:		ports/25869
This commit is contained in:
Jun Kuriyama 2001-03-26 08:27:32 +00:00
parent f7e80325c6
commit 6b6836c132
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=40390
6 changed files with 43 additions and 52 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= qtez
PORTVERSION= 0.93.2
PORTVERSION= 0.93.5
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://qtez.ibl.sk/qtez/download/
@ -21,9 +21,9 @@ USE_AUTOMAKE= yes
AUTOMAKE= automake -a -i && ${PERL} automoc
USE_LIBTOOL= yes
CONFIGURE_ENV= QTDIR="${X11BASE}" MOC="${X11BASE}/bin/moc2" \
QTEZ="${X11BASE}/share/qtez"
CONFIGURE_ARGS= --disable-shared
MAKE_ENV= QTEZ="${X11BASE}/share/qtez"
QTEZ="${PREFIX}/share/qtez"
MAKE_ENV= QTEZ="${PREFIX}/share/qtez"
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
@ -31,10 +31,6 @@ MAKE_ENV= QTEZ="${X11BASE}/share/qtez"
CFLAGS+= -O0
.endif
post-patch:
@find ${WRKSRC} -name "Makefile.am" | xargs ${PERL} -pi -e \
's|\@DEBUG\@|\@CXXFLAGS\@ \@DEBUG\@|g'
pre-configure:
@cd ${WRKSRC}/src && ${SH} ./autolinks.sh

View File

@ -1 +1 @@
MD5 (qtez-0.93.2.tar.bz2) = 65c4d9f0628ca8f5815accc8fd29e7b6
MD5 (qtez-0.93.5.tar.bz2) = fc1a7445dcd24324b7cf6cdac3e39796

View File

@ -1,22 +1,22 @@
--- configure.in.orig Tue Jul 18 16:43:22 2000
+++ configure.in Tue Sep 26 00:47:45 2000
--- configure.in.orig Wed Nov 22 16:55:07 2000
+++ configure.in Fri Feb 2 22:45:34 2001
@@ -48,15 +48,15 @@
if test "$enableval" = "yes"; then \
DEBUG="-g -DDEBUG -W -Wall"; \
else
- DEBUG="-O2 -DNO_DEBUG -DNO_CHECK"; \
+ DEBUG="-DNO_DEBUG -DNO_CHECK"; \
+ DEBUG="$CXXFLAGS -DNO_DEBUG -DNO_CHECK"; \
fi,
enableval=no
-DEBUG="-O2 -DNO_DEBUG -DNO_CHECK")
+DEBUG="-DNO_DEBUG -DNO_CHECK")
+DEBUG="$CXXFLAGS -DNO_DEBUG -DNO_CHECK")
AC_MSG_RESULT($enableval)
AC_SUBST(DEBUG)
AC_MSG_CHECKING(for Qt >= 2.1.0)
-if ! test -r $QTDIR/include/qinputdialog.h; then
+if ! test -r $QTDIR/include/qt2/qinputdialog.h; then
AC_MSG_ERROR([ Sorry, but you need Qt version 2.1.0 or higher to compile $PACKAGE])
AC_MSG_CHECKING(for Qt >= 2.2.0)
-if ! test -r $QTDIR/include/qaction.h; then
+if ! test -r $QTDIR/include/qt2/qaction.h; then
AC_MSG_ERROR([ Sorry, but you need Qt version 2.2.0 or higher to compile $PACKAGE])
else
AC_MSG_RESULT(yes)
@@ -64,12 +64,12 @@

View File

@ -5,7 +5,7 @@
libbugreport_la_METASOURCES = USE_AUTOMOC
-libdir = $(prefix)/qtez/plugins
+libdir = $(QTEZ)/plugins
+libdir = $(prefix)/lib/qtez/plugins
#noinst_PROGRAMS = bug
#bug_SOURCES = main.cpp

View File

@ -0,0 +1,8 @@
--- src/plugins/srceditor/Makefile.am.orig Thu Dec 7 20:45:50 2000
+++ src/plugins/srceditor/Makefile.am Sat Feb 3 04:16:19 2001
@@ -11,4 +11,4 @@
MainEditor.h MainEditor.cpp
libSyntaxEditor_la_METASOURCES = USE_AUTOMOC
-libdir = $(prefix)/qtez/plugins/sourceditor
+libdir = $(prefix)/lib/qtez/plugins/sourceditor

View File

@ -1,15 +1,30 @@
bin/qtez
lib/libPluginManager.a
lib/libPluginManager.so
lib/libPluginManager.so.0
lib/libQt2Dialogs.a
lib/libQt2Dialogs.so
lib/libQt2Dialogs.so.0
lib/libQt2Geometry.a
lib/libQt2Geometry.so
lib/libQt2Geometry.so.0
lib/libQt2Misc.a
lib/libQt2Misc.so
lib/libQt2Misc.so.0
lib/libQt2Network.a
lib/libQt2Network.so
lib/libQt2Network.so.0
lib/libQt2Widgets.a
share/qtez/.configs
lib/libQt2Widgets.so
lib/libQt2Widgets.so.0
lib/libcomponents.so
lib/libcomponents.so.1
lib/qtez/plugins/libbugreport.so
lib/qtez/plugins/sourceditor/libSyntaxEditor.so
share/qtez/acinclude.m4
share/qtez/am_edit
share/qtez/autogen.sh
share/qtez/automoc
share/qtez/doc/changes.html
share/qtez/doc/compcret.html
share/qtez/doc/index-1.html
share/qtez/doc/index-2.html
@ -37,48 +52,20 @@ share/qtez/doc/tutorial/projview.html
share/qtez/doc/tutorial/sigslot.html
share/qtez/doc/tutorial/srcedit.html
share/qtez/doc_Makefile.am
share/qtez/fine/.editor
share/qtez/fine/C++.template
share/qtez/fine/C++.template.blue
share/qtez/fine/C++.template.white
share/qtez/fine/LaTeX.template
share/qtez/fine/am.template
share/qtez/fine/blue/C++.template
share/qtez/fine/blue/am.template
share/qtez/fine/blue/h.template
share/qtez/fine/blue/html.template
share/qtez/fine/blue/lsm.template
share/qtez/fine/blue/po.template
share/qtez/fine/blue/qtz.template
share/qtez/fine/html.template
share/qtez/fine/lsm.template
share/qtez/fine/po.template
share/qtez/fine/qtz.template
share/qtez/fine/white/C++.template
share/qtez/fine/white/am.template
share/qtez/fine/white/h.template
share/qtez/fine/white/html.template
share/qtez/fine/white/lsm.template
share/qtez/fine/white/po.template
share/qtez/fine/white/qtz.template
share/qtez/icons/qtez-project.png
share/qtez/icons/qtez.png
share/qtez/icons/qtez48x48.png
share/qtez/img/about.gif
share/qtez/img/bwiz.png
share/qtez/img/tm.png
share/qtez/img/unstable.gif
share/qtez/po_KDE_Makefile.am
share/qtez/po_Makefile.am
share/qtez/prepare.sh
@exec mkdir -p %D/share/qtez/plugins
@unexec rmdir %D/share/qtez/plugins
share/qtez/qtez.udb
@dirrm share/qtez/img
@dirrm share/qtez/icons
@dirrm share/qtez/fine/white
@dirrm share/qtez/fine/blue
@dirrm share/qtez/fine
@dirrm share/qtez/doc/tutorial/images
@dirrm share/qtez/doc/tutorial
@dirrm share/qtez/doc
@dirrm share/qtez
@dirrm lib/qtez/plugins/sourceditor
@dirrm lib/qtez/plugins
@dirrm lib/qtez