New port: shells/klish
A framework for implementing a CISCO-like CLI on a UNIX systems. WWW: http://libcode.org/projects/klish/ PR: 206772 Submitted by: umeno@rr.iij4u.or.jp
This commit is contained in:
parent
52b18e2c4c
commit
6b61eebefe
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=407578
@ -20,6 +20,7 @@
|
||||
SUBDIR += hs-shelly
|
||||
SUBDIR += ibsh
|
||||
SUBDIR += jailkit
|
||||
SUBDIR += klish
|
||||
SUBDIR += ksh93
|
||||
SUBDIR += lshell
|
||||
SUBDIR += mksh
|
||||
|
21
shells/klish/Makefile
Normal file
21
shells/klish/Makefile
Normal file
@ -0,0 +1,21 @@
|
||||
# Created by: UMENO Takashi <umeno@rr.iij4u.or.jp>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= klish
|
||||
PORTVERSION= 2.1.1
|
||||
CATEGORIES= shells
|
||||
MASTER_SITES= http://libcode.org/attachments/download/61/
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= umeno@rr.iij4u.or.jp
|
||||
COMMENT= Klish - Kommand Line Interface Shell
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENCE
|
||||
|
||||
USES= libtool tar:xz
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
.include <bsd.port.mk>
|
2
shells/klish/distinfo
Normal file
2
shells/klish/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (klish-2.1.1.tar.xz) = 9093406248a7ef3b57a2b818aad77eddad6784dc7f9e86bf0b7bf9e577e237a0
|
||||
SIZE (klish-2.1.1.tar.xz) = 366040
|
17
shells/klish/files/patch-clish_shell_shell__execute.c
Normal file
17
shells/klish/files/patch-clish_shell_shell__execute.c
Normal file
@ -0,0 +1,17 @@
|
||||
--- clish/shell/shell_execute.c.orig 2015-10-06 14:51:41 UTC
|
||||
+++ clish/shell/shell_execute.c
|
||||
@@ -19,12 +19,14 @@
|
||||
#include <signal.h>
|
||||
#include <fcntl.h>
|
||||
|
||||
+#if !defined(__XSI_VISIBLE)
|
||||
/* Empty signal handler to ignore signal but don't use SIG_IGN. */
|
||||
static void sigignore(int signo)
|
||||
{
|
||||
signo = signo; /* Happy compiler */
|
||||
return;
|
||||
}
|
||||
+#endif
|
||||
|
||||
/*-------------------------------------------------------- */
|
||||
static int clish_shell_lock(const char *lock_path)
|
3
shells/klish/pkg-descr
Normal file
3
shells/klish/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
||||
The klish is a framework for implementing a CISCO-like CLI on a UNIX systems.
|
||||
|
||||
WWW: http://libcode.org/projects/klish/
|
55
shells/klish/pkg-plist
Normal file
55
shells/klish/pkg-plist
Normal file
@ -0,0 +1,55 @@
|
||||
bin/clish
|
||||
bin/konfd
|
||||
bin/konf
|
||||
bin/sigexec
|
||||
include/tinyrl/tinyrl.h
|
||||
include/tinyrl/history.h
|
||||
include/tinyrl/vt100.h
|
||||
include/lub/argv.h
|
||||
include/lub/bintree.h
|
||||
include/lub/list.h
|
||||
include/lub/ctype.h
|
||||
include/lub/c_decl.h
|
||||
include/lub/dump.h
|
||||
include/lub/string.h
|
||||
include/lub/types.h
|
||||
include/lub/system.h
|
||||
include/lub/db.h
|
||||
include/lub/ini.h
|
||||
include/lub/log.h
|
||||
include/konf/tree.h
|
||||
include/konf/query.h
|
||||
include/konf/buf.h
|
||||
include/konf/net.h
|
||||
include/clish/types.h
|
||||
include/clish/command.h
|
||||
include/clish/param.h
|
||||
include/clish/pargv.h
|
||||
include/clish/ptype.h
|
||||
include/clish/shell.h
|
||||
include/clish/view.h
|
||||
include/clish/nspace.h
|
||||
include/clish/var.h
|
||||
include/clish/action.h
|
||||
include/clish/config.h
|
||||
include/clish/hotkey.h
|
||||
include/clish/plugin.h
|
||||
include/clish/udata.h
|
||||
lib/clish_plugin_clish.a
|
||||
lib/clish_plugin_clish.so
|
||||
lib/libclish.a
|
||||
lib/libclish.so
|
||||
lib/libclish.so.1
|
||||
lib/libclish.so.1.0.0
|
||||
lib/libkonf.a
|
||||
lib/libkonf.so
|
||||
lib/libkonf.so.1
|
||||
lib/libkonf.so.1.0.0
|
||||
lib/liblub.a
|
||||
lib/liblub.so
|
||||
lib/liblub.so.1
|
||||
lib/liblub.so.1.0.0
|
||||
lib/libtinyrl.a
|
||||
lib/libtinyrl.so
|
||||
lib/libtinyrl.so.1
|
||||
lib/libtinyrl.so.1.0.0
|
Loading…
Reference in New Issue
Block a user