- Update to version 0.7 [1]
- Switch to dynamic plist [1] - lpr-wrapper-cups needs same patch as lpr-wrapper - Fix bash invocation in all installed scripts PR: ports/158935 [1] Submitted by: Jin-Sih Lin <linpct@gmail.com> [1] Approved by: maintainer
This commit is contained in:
parent
79cc3a1b3b
commit
6b4b1372fe
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=288204
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= lpr-wrapper
|
||||
PORTVERSION= 0.6
|
||||
PORTREVISION= 5
|
||||
PORTVERSION= 0.7
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://www.mathstat.dal.ca/~selinger/lpr-wrapper/download/
|
||||
|
||||
@ -29,4 +28,11 @@ RUN_DEPENDS+= pstops:${PORTSDIR}/print/psutils-a4
|
||||
RUN_DEPENDS+= pstops:${PORTSDIR}/print/psutils-letter
|
||||
.endif
|
||||
|
||||
PLIST_FILES= bin/lpr-wrapper bin/lpr-wrapper-cups bin/lpr-wrapper-features
|
||||
|
||||
post-build:
|
||||
${REINPLACE_CMD} -e 's|#!/bin/bash|#!/usr/bin/env bash|' \
|
||||
${WRKSRC}/lpr-wrapper ${WRKSRC}/lpr-wrapper-cups \
|
||||
${WRKSRC}/lpr-wrapper-features
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (lpr-wrapper-0.6.tar.gz) = 829aa2ac41e66074b7b56242bbc4aa05f63d65f8da6419cbb8756907de6144b1
|
||||
SIZE (lpr-wrapper-0.6.tar.gz) = 46394
|
||||
SHA256 (lpr-wrapper-0.7.tar.gz) = 72fd4e6ce70eb1510b43d15ff5a84a1c88a69f28335d0672b25e514019e5d3f9
|
||||
SIZE (lpr-wrapper-0.7.tar.gz) = 67365
|
||||
|
@ -1,13 +1,7 @@
|
||||
--- lpr-wrapper.in.orig Fri Apr 22 12:01:13 2005
|
||||
+++ lpr-wrapper.in Fri Apr 22 12:16:22 2005
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/usr/local/bin/bash
|
||||
|
||||
# lpr-wrapper --- a wrapper around the lpr command, which can handle
|
||||
# any-to-postscript conversion, options for duplex and n-up printing,
|
||||
@@ -103,7 +103,7 @@
|
||||
PPDDIR=@datadir@/@PACKAGE@
|
||||
--- lpr-wrapper-cups.in.orig 2011-12-28 22:04:02.000000000 +0100
|
||||
+++ lpr-wrapper-cups.in 2011-12-28 22:05:03.000000000 +0100
|
||||
@@ -88,7 +88,7 @@
|
||||
prefix=@prefix@
|
||||
|
||||
# global options file
|
||||
-SYST_CONFIG=/etc/lprrc
|
||||
@ -15,11 +9,11 @@
|
||||
|
||||
# user's options file
|
||||
USER_CONFIG=.lprrc
|
||||
@@ -488,17 +488,17 @@
|
||||
@@ -464,17 +464,17 @@
|
||||
OPTSTRING=o:P:#:K:C:J:T:U:i:1:2:3:4:w:cdfghlnmprstv
|
||||
LONGOPTS=help,version,verbose,test,ppd:,tmpdir:
|
||||
|
||||
-if [ "$HAVE[getopt]" ]; then
|
||||
-if [ "$HAVE_getopt" ]; then
|
||||
- OPTIONS=`getopt -n $NAME -s bash -l $LONGOPTS -o $OPTSTRING -- $XOPTS "$@"`
|
||||
- if [ $? != 0 ]; then
|
||||
- echo "Try --help for more information" > /dev/stderr
|
||||
@ -28,7 +22,7 @@
|
||||
- eval set -- "$OPTIONS"
|
||||
- dopts "$@"
|
||||
-else
|
||||
+#if [ "$HAVE[getopt]" ]; then
|
||||
+#if [ "$HAVE_getopt" ]; then
|
||||
+# OPTIONS=`getopt -n $NAME -s bash -l $LONGOPTS -o $OPTSTRING -- $XOPTS "$@"`
|
||||
+# if [ $? != 0 ]; then
|
||||
+# echo "Try --help for more information" > /dev/stderr
|
||||
@ -42,4 +36,4 @@
|
||||
+#fi
|
||||
|
||||
#if no printer given (as option or through environment), use default
|
||||
if [ x"$PRINTER" == x ]; then
|
||||
if [ -z "$PRINTER" ]; then
|
39
print/lpr-wrapper/files/patch-lpr-wrapper.in
Normal file
39
print/lpr-wrapper/files/patch-lpr-wrapper.in
Normal file
@ -0,0 +1,39 @@
|
||||
--- lpr-wrapper.in.orig 2011-07-15 13:17:49.000000000 +0800
|
||||
+++ lpr-wrapper.in 2011-07-15 13:18:56.000000000 +0800
|
||||
@@ -90,7 +90,7 @@
|
||||
prefix=@prefix@
|
||||
|
||||
# global options file
|
||||
-SYST_CONFIG=/etc/lprrc
|
||||
+SYST_CONFIG=@prefix@/etc/lprrc
|
||||
|
||||
# user's options file
|
||||
USER_CONFIG=.lprrc
|
||||
@@ -465,17 +465,17 @@
|
||||
OPTSTRING=o:P:#:K:C:J:T:U:i:1:2:3:4:w:cdfghlnmprstv
|
||||
LONGOPTS=help,version,verbose,test,ppd:,tmpdir:
|
||||
|
||||
-if [ "$HAVE_getopt" ]; then
|
||||
- OPTIONS=`getopt -n $NAME -s bash -l $LONGOPTS -o $OPTSTRING -- $XOPTS "$@"`
|
||||
- if [ $? != 0 ]; then
|
||||
- echo "Try --help for more information" > /dev/stderr
|
||||
- exit 1
|
||||
- fi
|
||||
- eval set -- "$OPTIONS"
|
||||
- dopts "$@"
|
||||
-else
|
||||
+#if [ "$HAVE_getopt" ]; then
|
||||
+# OPTIONS=`getopt -n $NAME -s bash -l $LONGOPTS -o $OPTSTRING -- $XOPTS "$@"`
|
||||
+# if [ $? != 0 ]; then
|
||||
+# echo "Try --help for more information" > /dev/stderr
|
||||
+# exit 1
|
||||
+# fi
|
||||
+# eval set -- "$OPTIONS"
|
||||
+# dopts "$@"
|
||||
+#else
|
||||
dopts $XOPTS "$@"
|
||||
-fi
|
||||
+#fi
|
||||
|
||||
#if no printer given (as option or through environment), use default
|
||||
if [ -z "$PRINTER" ]; then
|
@ -1,3 +0,0 @@
|
||||
bin/lpr-wrapper
|
||||
share/lpr-wrapper/default.ppd
|
||||
@dirrm share/lpr-wrapper
|
Loading…
Reference in New Issue
Block a user