Version up to 1.63. This one actually works!
This commit is contained in:
parent
9453403a78
commit
6b44787b7b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=621
@ -1,9 +1,14 @@
|
||||
DISTNAME= chimera-1.61
|
||||
# New ports collection makefile for: chimera
|
||||
# Version required: 1.63
|
||||
# Date created: 26 December 1994
|
||||
# Whom: asami
|
||||
#
|
||||
# $Id:$
|
||||
#
|
||||
|
||||
DISTNAME= chimera-1.63
|
||||
USE_IMAKE= yes
|
||||
MASTER_SITES= ftp://ftp.cs.unlv.edu/pub/chimera/
|
||||
|
||||
pre-install:
|
||||
@mkdir -p ${PREFIX}/man/man1
|
||||
@install -c -m 644 ${WRKSRC}/src/chimera.man ${PREFIX}/man/man1/chimera.1
|
||||
INSTALL_MANPAGES= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,14 +1,11 @@
|
||||
*** libhtmlw/HTML-PSformat.c~ Wed Sep 14 19:53:22 1994
|
||||
--- libhtmlw/HTML-PSformat.c Tue Oct 18 14:41:47 1994
|
||||
***************
|
||||
*** 47,53 ****
|
||||
--- 47,55 ----
|
||||
#include <stdio.h>
|
||||
#include <ctype.h>
|
||||
#include <math.h>
|
||||
+ #ifndef __FreeBSD__
|
||||
#include <malloc.h>
|
||||
+ #endif
|
||||
#include "HTMLP.h"
|
||||
|
||||
/* Fix thanks to robm. */
|
||||
--- ./Common.tmpl.dist.org Fri Dec 16 20:10:16 1994
|
||||
+++ ./Common.tmpl.dist Mon Dec 19 02:52:52 1994
|
||||
@@ -103,7 +103,7 @@
|
||||
NEEDFUNCS = -DNEED_STRSTR -DNEED_GETCWD
|
||||
*/
|
||||
|
||||
-EXTRA_DEFINES = -DHAVE_STDLIB_H -DHAVE_STRING_H -DHAVE_UNISTD_H -DHAVE_MALLOC_H $(MYPROTO) $(MYBSD) $(NEEDFUNCS)
|
||||
+EXTRA_DEFINES = -DHAVE_STDLIB_H -DHAVE_STRING_H -DHAVE_UNISTD_H $(MYPROTO) $(MYBSD) $(NEEDFUNCS)
|
||||
|
||||
/*
|
||||
* Extra libraries
|
||||
|
@ -1 +1 @@
|
||||
chimera - X/Athena World-Wide Web Client. Version 1.60
|
||||
chimera - X/Athena World-Wide Web Client. Version 1.63
|
||||
|
@ -2,8 +2,8 @@
|
||||
@owner bin
|
||||
@mode 755
|
||||
bin/chimera
|
||||
bin/giftrans
|
||||
@mode 444
|
||||
lib/cacheinfo
|
||||
lib/convert
|
||||
lib/help.html
|
||||
lib/home.html
|
||||
@ -12,12 +12,9 @@ lib/mime.types
|
||||
lib/protocol
|
||||
lib/chimera/Chimera
|
||||
@mode 755
|
||||
lib/chimera/chimera-giftoppm
|
||||
lib/chimera/do3270
|
||||
lib/chimera/dotelnet
|
||||
lib/chimera/playaudio
|
||||
lib/chimera/pstopxm
|
||||
lib/chimera/textencode
|
||||
lib/chimera/wrapencode
|
||||
@mode 644
|
||||
man/man1/chimera.1
|
||||
man/man1/chimera.1.gz
|
||||
|
@ -1,9 +1,14 @@
|
||||
DISTNAME= chimera-1.61
|
||||
# New ports collection makefile for: chimera
|
||||
# Version required: 1.63
|
||||
# Date created: 26 December 1994
|
||||
# Whom: asami
|
||||
#
|
||||
# $Id:$
|
||||
#
|
||||
|
||||
DISTNAME= chimera-1.63
|
||||
USE_IMAKE= yes
|
||||
MASTER_SITES= ftp://ftp.cs.unlv.edu/pub/chimera/
|
||||
|
||||
pre-install:
|
||||
@mkdir -p ${PREFIX}/man/man1
|
||||
@install -c -m 644 ${WRKSRC}/src/chimera.man ${PREFIX}/man/man1/chimera.1
|
||||
INSTALL_MANPAGES= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,14 +1,11 @@
|
||||
*** libhtmlw/HTML-PSformat.c~ Wed Sep 14 19:53:22 1994
|
||||
--- libhtmlw/HTML-PSformat.c Tue Oct 18 14:41:47 1994
|
||||
***************
|
||||
*** 47,53 ****
|
||||
--- 47,55 ----
|
||||
#include <stdio.h>
|
||||
#include <ctype.h>
|
||||
#include <math.h>
|
||||
+ #ifndef __FreeBSD__
|
||||
#include <malloc.h>
|
||||
+ #endif
|
||||
#include "HTMLP.h"
|
||||
|
||||
/* Fix thanks to robm. */
|
||||
--- ./Common.tmpl.dist.org Fri Dec 16 20:10:16 1994
|
||||
+++ ./Common.tmpl.dist Mon Dec 19 02:52:52 1994
|
||||
@@ -103,7 +103,7 @@
|
||||
NEEDFUNCS = -DNEED_STRSTR -DNEED_GETCWD
|
||||
*/
|
||||
|
||||
-EXTRA_DEFINES = -DHAVE_STDLIB_H -DHAVE_STRING_H -DHAVE_UNISTD_H -DHAVE_MALLOC_H $(MYPROTO) $(MYBSD) $(NEEDFUNCS)
|
||||
+EXTRA_DEFINES = -DHAVE_STDLIB_H -DHAVE_STRING_H -DHAVE_UNISTD_H $(MYPROTO) $(MYBSD) $(NEEDFUNCS)
|
||||
|
||||
/*
|
||||
* Extra libraries
|
||||
|
@ -1 +1 @@
|
||||
chimera - X/Athena World-Wide Web Client. Version 1.60
|
||||
chimera - X/Athena World-Wide Web Client. Version 1.63
|
||||
|
@ -2,8 +2,8 @@
|
||||
@owner bin
|
||||
@mode 755
|
||||
bin/chimera
|
||||
bin/giftrans
|
||||
@mode 444
|
||||
lib/cacheinfo
|
||||
lib/convert
|
||||
lib/help.html
|
||||
lib/home.html
|
||||
@ -12,12 +12,9 @@ lib/mime.types
|
||||
lib/protocol
|
||||
lib/chimera/Chimera
|
||||
@mode 755
|
||||
lib/chimera/chimera-giftoppm
|
||||
lib/chimera/do3270
|
||||
lib/chimera/dotelnet
|
||||
lib/chimera/playaudio
|
||||
lib/chimera/pstopxm
|
||||
lib/chimera/textencode
|
||||
lib/chimera/wrapencode
|
||||
@mode 644
|
||||
man/man1/chimera.1
|
||||
man/man1/chimera.1.gz
|
||||
|
Loading…
Reference in New Issue
Block a user