New port: www/campsite - The free and open multilingual web publishing tool for
news sites PR: ports/89243 Submitted by: Ondra Koutek <koutek@o-k.cz>
This commit is contained in:
parent
4ebb4aa862
commit
6b36b7e80e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=148814
@ -57,6 +57,7 @@
|
||||
SUBDIR += bugmenot-firefox
|
||||
SUBDIR += cadaver
|
||||
SUBDIR += calamaris
|
||||
SUBDIR += campsite
|
||||
SUBDIR += caudium10
|
||||
SUBDIR += caudium12
|
||||
SUBDIR += cgi-lib
|
||||
|
69
www/campsite/Makefile
Normal file
69
www/campsite/Makefile
Normal file
@ -0,0 +1,69 @@
|
||||
# New ports collection makefile for: campsite
|
||||
# Date created: 5 August 2005
|
||||
# Whom: Ondra Koutek <koutek@o-k.cz>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= campsite
|
||||
PORTVERSION= 2.3.3
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= koutek@o-k.cz
|
||||
COMMENT= The free and open multilingual web publishing tool for news sites
|
||||
|
||||
LIB_DEPENDS= Magick.8:${PORTSDIR}/graphics/ImageMagick \
|
||||
idn.16:${PORTSDIR}/dns/libidn
|
||||
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
|
||||
gm4:${PORTSDIR}/devel/m4
|
||||
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
|
||||
${LOCALBASE}/share/pear/HTTP/Client.php:${PORTSDIR}/www/pear-HTTP_Client \
|
||||
${LOCALBASE}/share/pear/File.php:${PORTSDIR}/sysutils/pear-File \
|
||||
${LOCALBASE}/share/pear/File/Find.php:${PORTSDIR}/sysutils/pear-File_Find \
|
||||
${LOCALBASE}/share/pear/XML/Util.php:${PORTSDIR}/devel/pear-XML_Util \
|
||||
${LOCALBASE}/share/pear/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
|
||||
|
||||
USE_RC_SUBR= zcampsite.sh
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
USE_APACHE= YES
|
||||
|
||||
BROKEN_WITH_PHP= 5
|
||||
USE_PHP= mysql curl pcre xml xmlrpc
|
||||
WANT_PHP_CLI= YES
|
||||
WANT_PHP_PEAR= YES
|
||||
USE_PHP_BUILD= YES
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --apache_user www --apache_group www --prefix ${PREFIX}
|
||||
|
||||
USE_GMAKE= yes
|
||||
|
||||
USE_REINPLACE= yes
|
||||
|
||||
SUB_FILES= pkg-message pkg-install pkg-deinstall crontab.in
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -type f -perm 755 \
|
||||
-or -name create_instance \
|
||||
-or -name global_functions \
|
||||
-or -name check4_functions \
|
||||
-or -name conf_functions | ${XARGS} \
|
||||
${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|'
|
||||
@${FIND} ${WRKSRC} -type f -name autopublish | ${XARGS} \
|
||||
${REINPLACE_CMD} -e 's|php |${LOCALBASE}/bin/php |'
|
||||
@${FIND} ${WRKSRC} -type f -name "*.php" | ${XARGS} \
|
||||
${REINPLACE_CMD} -e 's|$cmd = "pushd |$cmd = "${LOCALBASE}/bin/bash -c \\\"pushd |'
|
||||
@${FIND} ${WRKSRC} -type f -name "*.php" | ${XARGS} \
|
||||
${REINPLACE_CMD} -e 's|popd > /dev/null";|popd > /dev/null\\\"";|'
|
||||
@${FIND} ${WRKSRC} -name "*.bak" -delete
|
||||
|
||||
post-install:
|
||||
@${INSTALL_DATA} ${WRKDIR}/crontab.in ${PREFIX}/campsite/etc
|
||||
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
3
www/campsite/distinfo
Normal file
3
www/campsite/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
MD5 (campsite-2.3.3.tar.gz) = 39a63ff719c44b45688fc65c661b5f90
|
||||
SHA256 (campsite-2.3.3.tar.gz) = 8e37467a8e4d70e3c1227ec0fb111e6f340045be397a240afabf96a252e1d67f
|
||||
SIZE (campsite-2.3.3.tar.gz) = 2198061
|
14
www/campsite/files/crontab.in.in
Normal file
14
www/campsite/files/crontab.in.in
Normal file
@ -0,0 +1,14 @@
|
||||
|
||||
#Campsite job sending expiration message to subscribers
|
||||
0 */8 * * * %%PREFIX%%/campsite/bin/notifyendsubs
|
||||
|
||||
# Campsite job takes care about notifying editors/authors about changes
|
||||
# of their articles
|
||||
*/2 * * * * %%PREFIX%%/campsite/bin/notifyevents
|
||||
|
||||
# Campsite job indexing database of articles.
|
||||
# it is used for both, search in site and in admin interface
|
||||
0 */4 * * * %%PREFIX%%/campsite/bin/gather
|
||||
|
||||
# Campsite job takes care about scheduled publishing of articles
|
||||
* * * * * %%PREFIX%%/campsite/bin/autopublish
|
17
www/campsite/files/patch-Makefile
Normal file
17
www/campsite/files/patch-Makefile
Normal file
@ -0,0 +1,17 @@
|
||||
--- implementation/management/Makefile.orig Tue Sep 20 14:40:40 2005
|
||||
+++ implementation/management/Makefile Fri Nov 18 19:43:02 2005
|
||||
@@ -55,10 +55,10 @@
|
||||
chown -R $(APACHE_USER):$(APACHE_GROUP) $(HTML_COMMON_DIR)/*
|
||||
chmod -R u+rw $(HTML_COMMON_DIR)/*
|
||||
chmod -R g+r $(HTML_COMMON_DIR)/*
|
||||
- $(PEAR) install --soft Archive_Tar Console_Getopt XML_RPC PEAR Net_Socket
|
||||
- $(PEAR) upgrade Archive_Tar Console_Getopt XML_RPC Net_Socket
|
||||
- $(PEAR) install --soft Net_URL HTTP_Request HTTP_Client File File_Find XML_Util XML_Parser
|
||||
- $(PEAR) upgrade Net_URL HTTP_Request HTTP_Client File File_Find XML_Util XML_Parser
|
||||
+# $(PEAR) install --soft Archive_Tar Console_Getopt XML_RPC PEAR Net_Socket
|
||||
+# $(PEAR) upgrade Archive_Tar Console_Getopt XML_RPC Net_Socket
|
||||
+# $(PEAR) install --soft Net_URL HTTP_Request HTTP_Client File File_Find XML_Util XML_Parser
|
||||
+# $(PEAR) upgrade Net_URL HTTP_Request HTTP_Client File File_Find XML_Util XML_Parser
|
||||
|
||||
clean: dummy
|
||||
$(MAKE) -C root clean
|
19
www/campsite/files/patch-install_autopublish
Normal file
19
www/campsite/files/patch-install_autopublish
Normal file
@ -0,0 +1,19 @@
|
||||
--- implementation/management/bin/install_autopublish.orig Wed Jul 27 14:03:04 2005
|
||||
+++ implementation/management/bin/install_autopublish Sat Nov 19 00:28:45 2005
|
||||
@@ -3,10 +3,10 @@
|
||||
[ "$USER_INSTALL" = "" ] && USER_INSTALL=false
|
||||
if $USER_INSTALL; then exit 0; fi
|
||||
|
||||
-. ${INSTALL_CONF}/cron_functions
|
||||
-if [ -f /etc/crontab ]; then
|
||||
- uninstall_cron_task "$BIN_DIR/autopublish" /etc/crontab
|
||||
-fi
|
||||
-install_cron_task "*" "*" "*" "*" "*" "$ROOT_USER" "$BIN_DIR/autopublish" /etc/cron.d/campsite_autopublish -c || exit 1
|
||||
-restart_cron || exit 1
|
||||
+#. ${INSTALL_CONF}/cron_functions
|
||||
+#if [ -f /etc/crontab ]; then
|
||||
+# uninstall_cron_task "$BIN_DIR/autopublish" /etc/crontab
|
||||
+#fi
|
||||
+#install_cron_task "*" "*" "*" "*" "*" "$ROOT_USER" "$BIN_DIR/autopublish" /etc/cron.d/campsite_autopublish -c || exit 1
|
||||
+#restart_cron || exit 1
|
||||
exit 0
|
23
www/campsite/files/patch-install_mailnotify
Normal file
23
www/campsite/files/patch-install_mailnotify
Normal file
@ -0,0 +1,23 @@
|
||||
--- implementation/mailnotify/install_mailnotify.orig Tue Sep 20 09:38:31 2005
|
||||
+++ implementation/mailnotify/install_mailnotify Sat Nov 19 00:18:06 2005
|
||||
@@ -6,12 +6,12 @@
|
||||
|
||||
if $USER_INSTALL; then exit 0; fi
|
||||
|
||||
-. ${INSTALL_CONF}/cron_functions
|
||||
-if [ -f /etc/crontab ]; then
|
||||
- uninstall_cron_task "$BIN_DIR/notifyendsubs" /etc/crontab
|
||||
- uninstall_cron_task "$BIN_DIR/notifyevents" /etc/crontab
|
||||
-fi
|
||||
-install_cron_task "0" "*/8" "*" "*" "*" "$ROOT_USER" "$BIN_DIR/notifyendsubs" "/etc/cron.d/notifyendsubs" || exit 1
|
||||
-install_cron_task "*/2" "*" "*" "*" "*" "$ROOT_USER" "$BIN_DIR/notifyevents" "/etc/cron.d/notifyevents" || exit 1
|
||||
-restart_cron || exit 1
|
||||
+#. ${INSTALL_CONF}/cron_functions
|
||||
+#if [ -f /etc/crontab ]; then
|
||||
+# uninstall_cron_task "$BIN_DIR/notifyendsubs" /etc/crontab
|
||||
+# uninstall_cron_task "$BIN_DIR/notifyevents" /etc/crontab
|
||||
+#fi
|
||||
+#install_cron_task "0" "*/8" "*" "*" "*" "$ROOT_USER" "$BIN_DIR/notifyendsubs" "/etc/cron.d/notifyendsubs" || exit 1
|
||||
+#install_cron_task "*/2" "*" "*" "*" "*" "$ROOT_USER" "$BIN_DIR/notifyevents" "/etc/cron.d/notifyevents" || exit 1
|
||||
+#restart_cron || exit 1
|
||||
exit 0
|
29
www/campsite/files/patch-install_parser
Normal file
29
www/campsite/files/patch-install_parser
Normal file
@ -0,0 +1,29 @@
|
||||
--- implementation/parser/parser/install_parser.orig Sat Nov 19 20:46:16 2005
|
||||
+++ implementation/parser/parser/install_parser Sat Nov 19 20:50:16 2005
|
||||
@@ -39,26 +39,4 @@
|
||||
|
||||
if $USER_INSTALL; then exit 0; fi
|
||||
|
||||
-RC_INIT=/etc/init.d
|
||||
-if [ -d "$RC_INIT" ]; then
|
||||
- cp -f "$CAMPSITEINIT" "$RC_INIT"
|
||||
- chown ${ROOT_USER}:${ROOT_GROUP} $"${RC_INIT}/$CAMPSITEINIT"
|
||||
- [ $? -ne 0 ] && echo "ERROR installing start/stop script" && exit 1
|
||||
- chmod 755 "$RC_INIT/$CAMPSITEINIT"
|
||||
- ln -s "$RC_INIT/$CAMPSITEINIT" "/etc/rc2.d/S95$CAMPSITEINIT"
|
||||
- ln -s "$RC_INIT/$CAMPSITEINIT" "/etc/rc3.d/S95$CAMPSITEINIT"
|
||||
- ln -s "$RC_INIT/$CAMPSITEINIT" "/etc/rc5.d/S95$CAMPSITEINIT"
|
||||
- ln -s "$RC_INIT/$CAMPSITEINIT" "/etc/rc0.d/K50$CAMPSITEINIT"
|
||||
- ln -s "$RC_INIT/$CAMPSITEINIT" "/etc/rc6.d/K50$CAMPSITEINIT"
|
||||
-elif [ -d /etc/rc.d ]; then
|
||||
- if [ ! -f /etc/rc.d/rc.local ]; then
|
||||
- echo -e "#!/bin/bash\n" > /etc/rc.d/rc.local
|
||||
- fi
|
||||
- grep -w $CAMPSITECTL /etc/rc.d/rc.local > /dev/null
|
||||
- if [ "$?" != "0" ]; then
|
||||
- echo "$BIN_DIR/$CAMPSITECTL start" >> /etc/rc.d/rc.local
|
||||
- [ $? -ne 0 ] && echo "ERROR installing start/stop script" && exit 1
|
||||
- fi
|
||||
-fi
|
||||
-
|
||||
exit 0
|
19
www/campsite/files/patch-install_search
Normal file
19
www/campsite/files/patch-install_search
Normal file
@ -0,0 +1,19 @@
|
||||
--- implementation/search/install_search.orig Tue Sep 20 09:38:31 2005
|
||||
+++ implementation/search/install_search Sat Nov 19 00:33:12 2005
|
||||
@@ -6,10 +6,10 @@
|
||||
|
||||
if $USER_INSTALL; then exit 0; fi
|
||||
|
||||
-. ${INSTALL_CONF}/cron_functions
|
||||
-if [ -f /etc/crontab ]; then
|
||||
- uninstall_cron_task "$BIN_DIR/gather" /etc/crontab
|
||||
-fi
|
||||
-install_cron_task "0" "*/4" "*" "*" "*" "$ROOT_USER" "$BIN_DIR/gather" /etc/cron.d/campsite_gather -c || exit 1
|
||||
-restart_cron || exit 1
|
||||
+#. ${INSTALL_CONF}/cron_functions
|
||||
+#if [ -f /etc/crontab ]; then
|
||||
+# uninstall_cron_task "$BIN_DIR/gather" /etc/crontab
|
||||
+#fi
|
||||
+#install_cron_task "0" "*/4" "*" "*" "*" "$ROOT_USER" "$BIN_DIR/gather" /etc/cron.d/campsite_gather -c || exit 1
|
||||
+#restart_cron || exit 1
|
||||
exit 0
|
21
www/campsite/files/pkg-deinstall.in
Normal file
21
www/campsite/files/pkg-deinstall.in
Normal file
@ -0,0 +1,21 @@
|
||||
#! /bin/sh
|
||||
#
|
||||
|
||||
PATH=/bin:/usr/bin:/usr/sbin
|
||||
|
||||
case $2 in
|
||||
|
||||
DEINSTALL)
|
||||
echo "---> Starting deinstall script:"
|
||||
|
||||
if /usr/bin/crontab -u root -l | \
|
||||
/usr/bin/diff - %%PREFIX%%/campsite/etc/crontab.in >/dev/null 2>&1 ; then
|
||||
echo "---> Zeroing crontab for \"root\""
|
||||
/usr/bin/crontab -u root /dev/null
|
||||
else
|
||||
echo "---> Crontab for \"root\" not removed: please deinstall"
|
||||
echo "---> manually if you no-longer wish to use Campsite. eg:"
|
||||
echo "---> /usr/bin/crontab -u root -r"
|
||||
fi
|
||||
|
||||
esac
|
29
www/campsite/files/pkg-install.in
Normal file
29
www/campsite/files/pkg-install.in
Normal file
@ -0,0 +1,29 @@
|
||||
#! /bin/sh
|
||||
#
|
||||
|
||||
PATH=/bin:/usr/bin:/usr/sbin
|
||||
|
||||
case $2 in
|
||||
|
||||
POST-INSTALL)
|
||||
echo "---> Starting post-install script:"
|
||||
|
||||
echo "---> Checking crontab(5) file for user \"root\""
|
||||
|
||||
if /usr/bin/crontab -u root -l >/tmp/csctab$$ 2>&1 ; then
|
||||
if test -s /tmp/csctab$$; then
|
||||
echo "---> \"root\" already has a crontab. Not overwriting it"
|
||||
echo "---> Please merge any changes from the standard crontab file"
|
||||
echo "---> %%PREFIX%%/campsite/etc/crontab.in"
|
||||
else
|
||||
echo "---> Installing crontab(5) file for user \"root\""
|
||||
/usr/bin/crontab -u root "%%PREFIX%%/campsite/etc/crontab.in" || exit 1
|
||||
fi
|
||||
else
|
||||
echo "---> Creating crontab(5) file for user \"root\""
|
||||
/usr/bin/crontab -u root "%%PREFIX%%/campsite/etc/crontab.in" || exit 1
|
||||
fi
|
||||
rm -f /tmp/csctab$$
|
||||
;;
|
||||
|
||||
esac
|
14
www/campsite/files/pkg-message.in
Normal file
14
www/campsite/files/pkg-message.in
Normal file
@ -0,0 +1,14 @@
|
||||
|
||||
---------------------------------------------------------------------------------
|
||||
Good. Now you have installed campsite. Continue by reading documentation,
|
||||
specialy the section how to create new instance:
|
||||
%%PREFIX%%/campsite/bin/create_instance --help
|
||||
|
||||
---------------------------------------------------------------------------------
|
||||
!!! Note, that campsite schedules its periodic jobs.
|
||||
See /var/cron/tabs/root for details
|
||||
|
||||
---------------------------------------------------------------------------------
|
||||
This ports requires pear libraries properly set in PHP
|
||||
See include_path in php.ini
|
||||
|
23
www/campsite/files/zcampsite.sh.in
Normal file
23
www/campsite/files/zcampsite.sh.in
Normal file
@ -0,0 +1,23 @@
|
||||
#!/bin/sh
|
||||
|
||||
# PROVIDE: campsite
|
||||
# REQUIRE: DAEMON mysqld
|
||||
# KEYWORD: FreeBSD
|
||||
#
|
||||
# Add the following lines to /etc/rc.conf to enable campsite
|
||||
# campsite_enable (bool): Set to "NO" by default.
|
||||
# Set it to "YES" to enable campsite
|
||||
|
||||
|
||||
. %%RC_SUBR%%
|
||||
|
||||
name="campsite"
|
||||
rcvar=`set_rcvar`
|
||||
|
||||
load_rc_config $name
|
||||
|
||||
: ${campsite_enable="NO"}
|
||||
|
||||
command="%%PREFIX%%/campsite/bin/campsite_server"
|
||||
|
||||
run_rc_command "$1"
|
11
www/campsite/pkg-descr
Normal file
11
www/campsite/pkg-descr
Normal file
@ -0,0 +1,11 @@
|
||||
Campsite is a multilingual content management system (CMS) for news websites.
|
||||
|
||||
Campsite follows a print publication paradigm, so it structures sites
|
||||
by default as Publications> Issues > Sections > Articles.
|
||||
Campsite works best for medium-to-large-size online news publications,
|
||||
but it is capable of handling smaller sites as well.
|
||||
Some of its main features are ease of use, total design freedom for
|
||||
web designers, built-in subscription support, automatic publishing,
|
||||
easy article translation and internationalization.
|
||||
|
||||
WWW: http://www.campware.org/
|
2200
www/campsite/pkg-plist
Normal file
2200
www/campsite/pkg-plist
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user