original distribution updated to 1.1f.

simplify xpg4 related things.
do not depend on emacs.

PR:		5251
This commit is contained in:
Jun-ichiro itojun Hagino 1998-03-20 16:49:43 +00:00
parent 70b7215000
commit 6b204d5c44
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=10241
5 changed files with 53 additions and 86 deletions

View File

@ -1,69 +1,26 @@
# New ports collection makefile for: jman - japanese man with EUC
# Version required: 1.1c
# Version required: 1.1f
# Date created: 4 December 1996
# Whom: Kiriyama Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
#
# $Id: Makefile,v 1.12 1997/09/09 08:38:50 asami Exp $
# $Id: Makefile,v 1.13 1997/09/16 10:48:03 max Exp $
#
DISTNAME= jp-man-1.1c
PKGNAME= ja-man-1.1c
DISTNAME= jp-man-1.1f
PKGNAME= ja-man-1.1f
CATEGORIES= japanese
MASTER_SITES= ftp://jaz.jp.freebsd.org/pub/FreeBSD-jp/man-jp/ \
ftp://ports.jp.freebsd.org/pub/FreeBSD-jp/ports-jp/LOCAL_PORTS/
MAINTAINER= kiri@kiri.toba-cmt.ac.jp
MAINTAINER= kuriyama@opt.phys.waseda.ac.jp
#do not run-depend on mule because dependency will be pulled in to package
#and we don't know which one the user wants
RUN_DEPENDS= ${PREFIX}/bin/groff:${PORTSDIR}/japanese/groff \
jless:${PORTSDIR}/japanese/less
MANLANG= ja_JP.EUC
MAN1= jcatman.1 jman.1 jmanpath.1 japropos.1 jwhatis.1 jmakewhatis.1
MANCOMPRESSED= yes
JMANELDIR= ${PREFIX}/lib/mule/site-lisp/jman
MAKE_ENV= GZCAT=${GZCAT} GZIP_CMD="${GZIP_CMD}"
# XPG4LIBPATH specifies the path name of the xpg4 library.
# The xpg4 library include setlocale() function and etc. for I18N,
# when using EUC code(e.g. ja_JP.EUC). At version 2.1.5 of FreeBSD or older,
# there isn't the xpg4 library in system, because include C library.
# But 2.2.0 or newer, the set of code for xpg4 was removed from C library,
# and included in new created xpg4 libray(/usr/lib/libxpg4*) .
# If your system have xpg4 library(libxpg4*) in /usr/lib, this patch
# automatically apply to srource file. If your system have xpg4 library
# in other directory, you must define XPG4LIBPATH. And if you don't want to
# use xpg4 library, you must define NOUSE_XPG4LIB. At default, you don't
# have to define XPG4LIBPATH and NOUSE_XPG4LIB.
# See a make rule of target pre-patch for details.
#
XPG4LIBPATH?= /usr/lib
pre-patch:
@${MKDIR} ${PATCHDIR}
@${RM} -f ${PATCHDIR}/patch-aa
.if !defined(NOUSE_XPG4LIB)
@${SED} -e "s,%XPG4LIBPATH%,${XPG4LIBPATH},g" \
< ${FILESDIR}/patch-xpg4.tmpl > ${FILESDIR}/patch-xpg4
@(for libfile in ${XPG4LIBPATH}/libxpg4*; do \
if [ ! "$$libfile" = "" ]; then \
ln -sf ${FILESDIR}/patch-xpg4 \
${PATCHDIR}/patch-aa; \
break 1; \
fi; \
done)
.else
@ln -sf ${FILESDIR}/patch-noxpg4 ${PATCHDIR}/patch-aa
.endif
post-install:
@${MKDIR} ${JMANELDIR}
@${INSTALL_DATA} ${FILESDIR}/jman.el ${JMANELDIR}
@${SETENV} CP=${CP} PKG_PREFIX=${PREFIX} \
${SH} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
pre-clean:
@${RM} -f ${PATCHDIR}/patch-aa ${FILESDIR}/patch-xpg4
-@${RMDIR} ${PATCHDIR}
pre-install:
@${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGDIR}/INSTALL ${PKGNAME} PRE-INSTALL
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (jp-man-1.1c.tar.gz) = 503186dbc9db87d78429447ecf49feef
MD5 (jp-man-1.1f.tar.gz) = e19b7153bbd421198da8e2621dc9c2dc

View File

@ -0,0 +1,12 @@
--- man/Makefile Sun Dec 7 20:01:18 1997
+++ man/Makefile Thu Mar 5 09:44:02 1998
@@ -12,7 +12,9 @@
CFLAGS+= -I${LIBDESTDIR}
DPADD= ${LIBDESTDIR}/libman.a
LDADD= -L${LIBDESTDIR} -lman
+.if exists(/usr/lib/libxpg4.a)
LDADD+= -L/usr/lib -lxpg4
+.endif
.if exists(${.OBJDIR})
MAN1= ${.OBJDIR}/jman.1

View File

@ -1,28 +1,14 @@
#!/bin/sh
TOUCH=${TOUCH:-/usr/bin/touch}
elispdir=${PKG_PREFIX}/lib/mule/site-lisp
OptionStart=";;; Jman configuration options"
OptionEnd=";;; End of Jman configuration options"
if [ "X$2" = X"POST-INSTALL" ]; then
if [ ! -f ${elispdir}/site-start.el ]; then
${TOUCH} ${elispdir}/site-start.el
if [ "X$2" = X"PRE-INSTALL" ]; then
for d in /usr/local/man /usr/X11R6/man; do
if [ -d ${d}/ja_JP.EUC ]; then
if [ -d ${d}/ja ]; then
(cd ${d}; tar cf - -C ja_JP.EUC . | tar xfp - -C ja; \
rm -rf ${d}/ja_JP.EUC; ln -s ja ja_JP.EUC )
else
(cd ${d}; mv ja_JP.EUC ja; ln -s ja ja_JP.EUC )
fi
fi
if [ "`grep \"^${OptionStart}\" ${elispdir}/site-start.el`" ]; then
sed -e "/^${OptionStart}/,/^${OptionEnd}/d" \
${elispdir}/site-start.el > ${elispdir}/site-start.el.bak
mv ${elispdir}/site-start.el.bak ${elispdir}/site-start.el
fi
echo "Adding \"Jman\" entry to ${elispdir}/site-start.el"
echo "${OptionStart}" >> ${elispdir}/site-start.el
echo "(setq load-path (cons \"${elispdir}/jman\" load-path))" \
>> ${elispdir}/site-start.el
echo "(autoload 'jman \"jman\" nil t)" >> ${elispdir}/site-start.el
echo "${OptionEnd}" \
>> ${elispdir}/site-start.el
exit 0
done
fi

View File

@ -1,14 +1,26 @@
bin/jman
bin/jmanpath
@unexec chflags noschg %B/jman
bin/jman
bin/japropos
bin/jwhatis
bin/jmakewhatis
bin/jcatman
man/ja_JP.EUC/man1/jcatman.1.gz
man/ja_JP.EUC/man1/jman.1.gz
man/ja_JP.EUC/man1/jmanpath.1.gz
man/ja_JP.EUC/man1/japropos.1.gz
man/ja_JP.EUC/man1/jwhatis.1.gz
man/ja_JP.EUC/man1/jmakewhatis.1.gz
lib/mule/site-lisp/jman/jman.el
@dirrm lib/mule/site-lisp/jman
etc/manpath.config.sample
libexec/jmakewhatis.local
libexec/jcatman.local
man/man1/jman.1.gz
man/man1/jmanpath.1.gz
man/man1/japropos.1.gz
man/man1/jwhatis.1.gz
man/man1/jmakewhatis.1.gz
man/man1/jcatman.1.gz
man/man8/jmakewhatis.local.8.gz
man/man8/jcatman.local.8.gz
man/ja/man1/jman.1.gz
man/ja/man1/jmanpath.1.gz
man/ja/man1/japropos.1.gz
man/ja/man1/jwhatis.1.gz
man/ja/man1/jmakewhatis.1.gz
man/ja/man1/jcatman.1.gz
man/ja/man8/jmakewhatis.local.8.gz
man/ja/man8/jcatman.local.8.gz