- Sanitize and cleanup the port a bit: remove "Portname is ..." from COMMENT,

drop useless EXTRACT_SUFX, define LICENSE (GPLv3), sort the knobs, etc.
- Do not patch ./install.zsh file; it is nearly identical to ./install.sh
  except for the _f file, which can be installed separately (do so)
- Stagify, use OPTIONS helpers, trim superfluous whitespace here and there
This commit is contained in:
Alexey Dokuchaev 2014-03-15 08:01:49 +00:00
parent afa418b908
commit 6adc132072
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=348293
5 changed files with 35 additions and 99 deletions

View File

@ -7,53 +7,45 @@ CATEGORIES= sysutils
MASTER_SITES= http://cloud.github.com/downloads/joelthelion/autojump/ \
http://www.vermatech.com/distfiles/
DISTNAME= autojump_v${PORTVERSION}
EXTRACT_SUFX= .tar.gz
MAINTAINER= neeraj.verma.ports@vermatech.com
COMMENT= Autojump is a tool that acts as a complement to cd
COMMENT= Tool that acts as a complement to cd
RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
LICENSE= GPLv3
USE_PYTHON_RUN= YES
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
NO_BUILD= YES
SUB_FILES+= pkg-install
NO_BUILD= yes
USE_PYTHON_RUN= yes
SUB_FILES= pkg-install
PLIST_FILES= bin/autojump \
bin/jumpapplet \
man/man1/autojump.1.gz \
share/autojump/autojump.bash \
share/autojump/autojump.zsh \
share/autojump/icon.png
MAN1= autojump.1
PLIST_DIRS= share/autojump
OPTIONS_DEFINE= ZSH
OPTIONS_DEFAULT= ZSH
NO_STAGE= yes
ZSH_RUN_DEPENDS= zsh:${PORTSDIR}/shells/zsh
ZSH_PLIST_FILES= share/zsh/site-functions/_j
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MZSH}
RUN_DEPENDS+= ${LOCALBASE}/bin/zsh:${PORTSDIR}/shells/zsh
PLIST_FILES+= share/zsh/site-functions/_j
.endif
PLIST_DIRS= share/autojump
post-patch:
@${REINPLACE_CMD} 's|/usr/bin/python|${PYTHON_CMD}|' ${WRKSRC}/autojump
@${REINPLACE_CMD} -e 's|/usr$$|${PREFIX}|' -e 's|/usr/local|${PREFIX}|' -e 's|/bin/bash|${PREFIX}/bin/bash|' ${WRKSRC}/install.sh
@${REINPLACE_CMD} -e 's|/usr$$|${PREFIX}|' -e 's|/usr/local|${PREFIX}|' -e 's|/bin/zsh|${PREFIX}/bin/zsh|' ${WRKSRC}/install.zsh
@${REINPLACE_CMD} -e '/#!\/usr\/bin/s|python|env &|' \
${WRKSRC}/autojump
do-install:
@(cd ${INSTALL_WRKSRC} && ${SETENV} ${SH} ./install.sh \
--prefix ${STAGEDIR}${PREFIX})
.if ${PORT_OPTIONS:MZSH}
@(cd ${INSTALL_WRKSRC} && ${SETENV} PREFIX=${PREFIX} ./install.zsh )
.else
@(cd ${INSTALL_WRKSRC} && ${SETENV} PREFIX=${PREFIX} ./install.sh )
@${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions
${INSTALL_DATA} ${WRKSRC}/_j \
${STAGEDIR}${PREFIX}/share/zsh/site-functions
.endif
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -1,6 +1,15 @@
--- ./install.sh.orig 2010-10-01 10:49:18.000000000 -0400
+++ ./install.sh 2011-12-03 23:04:22.000000000 -0500
@@ -41,56 +41,12 @@
@@ -15,7 +15,7 @@
#You should have received a copy of the GNU General Public License
#along with autojump. If not, see <http://www.gnu.org/licenses/>.
-function show_help {
+show_help() {
echo "sudo ./install.sh [--prefix /usr/local]"
}
@@ -41,56 +41,12 @@ done
echo "Installing to ${prefix} ..."
# INSTALL AUTOJUMP

View File

@ -1,65 +0,0 @@
--- ./install.zsh.orig 2010-10-01 10:49:18.000000000 -0400
+++ ./install.zsh 2011-12-03 23:25:09.000000000 -0500
@@ -39,19 +39,21 @@
echo "Installing main files to ${prefix} ..."
-sudo mkdir -p ${prefix}/share/autojump/
-sudo mkdir -p ${prefix}/bin/
-sudo mkdir -p ${prefix}/share/man/man1/
-sudo cp icon.png ${prefix}/share/autojump/
-sudo cp jumpapplet ${prefix}/bin/
-sudo cp autojump ${prefix}/bin/
-sudo cp autojump.1 ${prefix}/share/man/man1/
+mkdir -p ${prefix}/share/autojump/
+mkdir -p ${prefix}/bin/
+mkdir -p ${prefix}/man/man1/
+cp icon.png ${prefix}/share/autojump/
+cp autojump.bash ${prefix}/share/autojump/
+cp autojump.zsh ${prefix}/share/autojump/
+cp jumpapplet ${prefix}/bin/
+cp autojump ${prefix}/bin/
+cp autojump.1 ${prefix}/man/man1/
# autocompletion file in the first directory of the FPATH variable
fail=true
for f in $fpath
do
- sudo cp _j $f && fail=false && break
+ cp _j $f && fail=false && break
done
if $fail
then
@@ -60,32 +60,3 @@
else
echo "Installed autocompletion file to $f"
fi
-
-if [ -d "/etc/profile.d" ]; then
- sudo cp autojump.zsh /etc/profile.d/
- sudo cp autojump.sh /etc/profile.d/
- echo "Remember to add the line"
- echo " source /etc/profile.d/autojump.zsh"
- echo "or"
- echo " source /etc/profile"
- echo "to your ~/.zshrc if it's not there already"
- echo
- echo "You need to source your ~/.zshrc (source ~/.zshrc) before you can start using autojump."
-else
- echo "Your distribution does not have a /etc/profile.d directory, the default that we install one of the scripts to. Would you like us to copy it into your ~/.zshrc file to make it work? (If you have done this once before, delete the old version before doing it again.) [y/n]"
- read ans
- if [ ${#ans} -gt 0 ]; then
- if [ $ans = "y" -o $ans = "Y" -o $ans = "yes" -o $ans = "Yes" ]; then
- echo "" >> ~/.zshrc
- echo "#autojump" >> ~/.zshrc
- cat autojump.zsh >> ~/.zshrc
- echo "Done!"
- echo
- echo "You need to source your ~/.zshrc (source ~/.zshrc) before you can start using autojump."
- else
- echo "Then you need to put autojump.zsh, or the code from it, somewhere where it will get read. Good luck!"
- fi
- else
- echo "Then you need to put autojump.zsh, or the code from it, somewhere where it will get read. Good luck!"
- fi
-fi

View File

@ -5,11 +5,11 @@ POST-DEINSTALL)
rm -f /etc/profile.autojump
rm -f /etc/zshrc.autojump
# delete the source (.) line from the /etc/profile and /etc/zshrc
if [ -f /etc/profile ] ; then
sed -i '' -e '/profile.autojump/d' /etc/profile
fi
if [ -f /etc/zshrc ] ; then
sed -i '' -e '/zshrc.autojump/d' /etc/zshrc
fi
if [ -f /etc/profile ] ; then
sed -i '' -e '/profile.autojump/d' /etc/profile
fi
if [ -f /etc/zshrc ] ; then
sed -i '' -e '/zshrc.autojump/d' /etc/zshrc
fi
;;
esac

View File

@ -2,5 +2,5 @@
* AutoJump installed
**************************************************************
* Note: Your /etc/profile was changed for this installation.
* changes will be reverted when you un-install the package.
* changes will be reverted when you un-install the package.
**************************************************************