Create a generic PKGMESSAGE, and use it where appropriate.

Make sure that bsd.port.pre.mk is included before bsd.squirrelmail.mk.

For ports with maintainers, I haven't switched you to the new
PKGMESSAGE, but I have corrected paths in pkg-message.in where
necessary. I also got a little over-zealous in cleaning redundant
definitions from the headers. Apologies in advance if this rubs
you the wrong way.
This commit is contained in:
Adam Weinberger 2013-12-08 18:59:35 +00:00
parent e8ca1d4030
commit 6ad04afc40
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=335921
54 changed files with 158 additions and 264 deletions

View File

@ -12,5 +12,7 @@ COMMENT= Allows for the importing of addressbooks from a CSV (comma separated va
SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,7 +1,7 @@
================================================================
You may want to copy the file
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config_default.php
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config_default.php
to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
and edit the configuration to meet your needs.
================================================================

View File

@ -3,11 +3,12 @@
PORTNAME= askuserinfo
PORTVERSION= 1.1
DISTNAME= ${PORTNAME}.${PORTVERSION}-1.4.0
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Ask user to enter Full name and Email address at initial logon
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -4,20 +4,17 @@
PORTNAME= avelsieve
PORTVERSION= 1.9.7
PORTREVISION= 2
DIST_SUBDIR= squirrelmail
MAINTAINER= neil@darlow.co.uk
COMMENT= SquirrelMail plugin for Server-Side Mail Filtering management
USES= perl5
USE_PERL5= run
NO_STAGE= yes
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
pre-install:
${RM} -Rf ${WRKSRC}/${SQUIRREL_PLUGIN_NAME}/po
${FIND} ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} -type f \
\( -name '.cvsignore' -o -name '*.bak' -o -name '*.orig' \) -exec ${RM} {} \;
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.post.mk>

View File

@ -1,8 +1,8 @@
*** IMPORTANT *** IMPORTANT *** IMPORTANT ***
To configure the plugin, please copy
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config/config_sample.php to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config/config.php
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config/config_sample.php to
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config/config.php
then review, and modify, its content for your environment.
*** IMPORTANT *** IMPORTANT *** IMPORTANT ***

View File

@ -2,16 +2,15 @@
# $FreeBSD$
PORTNAME= calendar_file_backend
PORTVERSION= 1.0
PORTVERSION= 1.0
PORTREVISION= 1
DISTNAME= ${PORTNAME}-${PORTVERSION}-2.0
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= File backend for SquirrelMail Calendar plugin
SQUIRREL_PLUGIN_NAME= ${PORTNAME}
NO_STAGE= yes
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -5,7 +5,6 @@ PORTNAME= change_ldappass
PORTVERSION= 2.2
PORTREVISION= 4
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.4.0
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Allows users to change their passwords stored in LDAP Tree
@ -15,6 +14,10 @@ LICENSE= GPLv2
USE_PHP+= ldap
USES= gettext
USE_GENERIC_PKGMESSAGE= yes
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>

View File

@ -1,5 +0,0 @@
For the port to work properly you must copy the file
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/change_ldappass/config_sample.php
to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/change_ldappass/config.php
and edit the configuration to meet your needs.

View File

@ -5,7 +5,6 @@ PORTNAME= change-sqlpass
PORTVERSION= 3.3
PORTREVISION= 1
DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}-1.2
DIST_SUBDIR= squirrelmail
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Allows users to change their passwords stored in a SQL database
@ -17,5 +16,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,7 +1,7 @@
================================================================
For the port to work properly you must copy the file
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php.sample
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php.sample
to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
and edit the configuration to meet your needs.
================================================================

View File

@ -5,7 +5,6 @@ PORTNAME= check-quota
PORTVERSION= 2.2
PORTREVISION= 1
DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}-1.4.0
DIST_SUBDIR= squirrelmail
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Check/display users' mail quota (filesystem, IMAP-based, and cPanel)
@ -15,6 +14,7 @@ USE_SM_COMPAT= YES
SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
NO_STAGE= yes
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.post.mk>

View File

@ -1,7 +1,7 @@
================================================================
For the port to work properly you must copy the file
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.sample.php
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.sample.php
to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
and edit the configuration to meet your needs.
================================================================

View File

@ -4,18 +4,11 @@
PORTNAME= compatibility
PORTVERSION= 2.0.16
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
PKGNAMEPREFIX= squirrelmail-
PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.0
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Required by many plugins for compatibility with SquirrelMail
USES= perl5
USE_PERL5= install
NO_STAGE= yes
.include <bsd.port.pre.mk>

View File

@ -2,17 +2,19 @@
# $FreeBSD$
PORTNAME= email_footer
PORTVERSION= 0.6
PORTVERSION=0.6
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.4.2
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Automatically appends footer to SquirrelMail-generated emails
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
USE_SM_COMPAT= yes
USE_GENERIC_PKGMESSAGE= yes
LICENSE= GPLv2
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,5 +0,0 @@
For the port to work properly you must copy the file
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/email_footer/config.php.sample
to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/email_footer/config.php
and edit the configuration to meet your needs.

View File

@ -6,7 +6,6 @@ PORTVERSION= 3.0
MASTER_SITES= http://www.squirrelmail.org/plugins/ \
http://www.transit.hanse.de/mirror/www.squirrelmail.org/plugins/
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.4.0
DIST_SUBDIR= squirrelmail
MAINTAINER= stb@lassitu.de
COMMENT= Automatically log in user based on HTTP authentication
@ -14,5 +13,7 @@ COMMENT= Automatically log in user based on HTTP authentication
SQUIRREL_PLUGIN_NAME= ${PORTNAME}
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -2,20 +2,19 @@
# $FreeBSD$
PORTNAME= login_notes
PORTVERSION= 1.2
PORTVERSION=1.2
DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}-1.4.0
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Place notes on the login screen
LICENSE= GPLv2
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
USES= perl5
USE_PERL5= run
USE_SM_COMPAT= yes
USE_GENERIC_PKGMESSAGE= yes
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,5 +0,0 @@
For the port to work properly you must copy the file
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/login_notes/config.sample.php
to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/login_notes/config.php
and edit the configuration to meet your needs.

View File

@ -5,14 +5,11 @@ PORTNAME= mark_read
PORTVERSION= 1.4.2
PORTREVISION= 2
DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}-1.2
DIST_SUBDIR= squirrelmail
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Provides one-click link to mark read/unread all mails in a folder
USE_SM_COMPAT= YES
USES= perl5
USE_PERL5= run
SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
@ -20,5 +17,6 @@ NO_STAGE= yes
post-patch:
@${RM} ${WRKSRC}/${SQUIRREL_PLUGIN_NAME}/mark_read.php.orig
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,7 +1,7 @@
================================================================
For the port to work properly you must copy the file
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.sample.php
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.sample.php
to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
and edit the configuration to meet your needs.
================================================================

View File

@ -1,21 +1,15 @@
# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
PORTNAME= multilogin
PORTNAME= multilogin
PORTVERSION= 2.4
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
PKGNAMEPREFIX= squirrelmail-
PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.2.9
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Allows manual selection of login server on login page
USES= perl5
USE_PERL5= install
USE_SM_COMPAT= yes
USE_GENERIC_PKGMESSAGE= yes
NO_STAGE= yes

View File

@ -1,5 +0,0 @@
For the port to work properly you must copy the file
%%SQUIRRELDIR%%/plugins/multilogin/config.sample.php
to
%%SQUIRRELDIR%%/plugins/multilogin/config.php
and edit the configuration to meet your needs.

View File

@ -4,19 +4,13 @@
PORTNAME= notes
PORTVERSION= 1.2
PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
PKGNAMEPREFIX= squirrelmail-
PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}.${PORTVERSION}-1.4.0
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Allows you to create notes
USES= perl5
USE_PERL5= install
USE_SM_COMPAT= yes
USE_GENERIC_PKGMESSAGE= yes
NO_STAGE= yes

View File

@ -1,5 +0,0 @@
For the port to work properly you must copy the file
%%SQUIRRELDIR%%/plugins/notes/config.php.sample
to
%%SQUIRRELDIR%%/plugins/notes/config.php
and edit the configuration to meet your needs.

View File

@ -4,18 +4,11 @@
PORTNAME= notify
PORTVERSION= 1.3
PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
PKGNAMEPREFIX= squirrelmail-
PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Notify when new mail arrives
USES= perl5
USE_PERL5= install
USE_SM_COMPAT= yes
NO_STAGE= yes

View File

@ -3,21 +3,15 @@
PORTNAME= password_forget
PORTVERSION= 2.2
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
PKGNAMEPREFIX= squirrelmail-
PKGNAMESUFFIX= -plugin
DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}-1.0.1
DIST_SUBDIR= squirrelmail
MAINTAINER= neil@darlow.co.uk
COMMENT= Prevent reuse of login details by browsers at public terminals
RUN_DEPENDS= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
USES= perl5
USE_PERL5= run
USE_SM_COMPAT= yes
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -5,13 +5,16 @@ PORTNAME= pupdate
PORTVERSION= 0.7
PORTREVISION= 2
DISTNAME= ${PORTNAME}.${PORTVERSION}-1.4.2
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Checks for plugin updates by parsing the SM site
LICENSE= GPLv2
USE_GENERIC_PKGMESSAGE= yes
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,5 +0,0 @@
For the port to work properly you must copy the file
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/pupdate/config.php.sample
to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/pupdate/config.php
and edit the configuration to meet your needs.

View File

@ -4,15 +4,17 @@
PORTNAME= qmailadmin_login
PORTVERSION= 1.1
PORTREVISION= 2
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.4.3
DIST_SUBDIR= squirrelmail
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.4.3
MAINTAINER= ports@FreeBSD.org
COMMENT= Using the QmailAdmin cgi interface from SquirrelMail
SQUIRREL_PLUGIN_NAME= ${PORTNAME}
RUN_DEPENDS= ${PREFIX}/www/cgi-bin.default/qmailadmin/qmailadmin:${PORTSDIR}/mail/qmailadmin
USE_GENERIC_PKGMESSAGE= yes
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,5 +0,0 @@
For the port to work properly you must copy the file
%%SQUIRRELDIR%%/plugins/qmailadmin_login/config_default.php
to
%%SQUIRRELDIR%%/plugins/qmailadmin_login/config.php
and edit the configuration to meet your needs.

View File

@ -4,19 +4,13 @@
PORTNAME= quota_usage
PORTVERSION= 1.3.1
PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
PKGNAMEPREFIX= squirrelmail-
PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.2.7
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= View quota and current usage
USES= perl5
USE_PERL5= install
USE_SM_COMPAT= yes
USE_GENERIC_PKGMESSAGE= yes
NO_STAGE= yes

View File

@ -1,5 +0,0 @@
For the port to work properly you must copy the file
%%SQUIRRELDIR%%/plugins/quota_usage/config.php.sample
to
%%SQUIRRELDIR%%/plugins/quota_usage/config.php
and edit the configuration to meet your needs.

View File

@ -4,25 +4,22 @@
PORTNAME= sasql
PORTVERSION= 3.2.0
PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
PKGNAMEPREFIX= squirrelmail-
PKGNAMESUFFIX= -plugin
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Edit SpamAssassin settings stored in an SQL DB
RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
USES= perl5
USE_PERL5= install
USE_SM_COMPAT= yes
USE_GENERIC_PKGMESSAGE= yes
NO_STAGE= yes
post-patch:
@${RM} ${WRKSRC}/${SQUIRREL_PLUGIN_NAME}/*.orig ${WRKSRC}/${SQUIRREL_PLUGIN_NAME}/.cvsignore
@${REINPLACE_CMD} -e "s/\(\$$imap_server_type == \'cyrus\'\)/\1 || \$$imap_server_type == \'courier\'/g" \
-e 's/session_register/sqsession_register/g' \
${WRKSRC}/${SQUIRREL_PLUGIN_NAME}/sasql_hooks.php
-@${RM} ${WRKSRC}/${SQUIRREL_PLUGIN_NAME}/*.bak ${WRKSRC}/${SQUIRREL_PLUGIN_NAME}/.cvsignore
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"

View File

@ -1,31 +0,0 @@
diff -Nur sasql.orig/sasql_hooks.php sasql/sasql_hooks.php
--- sasql.orig/sasql_hooks.php 2006-11-09 21:29:21.000000000 +0100
+++ sasql/sasql_hooks.php 2006-12-10 12:13:12.000000000 +0100
@@ -74,23 +74,23 @@
if (!sqimap_mailbox_exists($imap_stream, $mailbox)) {
sqimap_mailbox_create($imap_stream, $mailbox, '');
- if ($imap_server_type == 'cyrus') {
+ if ($imap_server_type == 'cyrus' || $imap_server_type == 'courier') {
$boxes = sqimap_mailbox_list($imap_stream);
} else {
$boxes = sqimap_mailbox_list($imap_stream, true);
}
- session_register($boxes, 'boxesnew');
+ sqsession_register($boxes, 'boxesnew');
// echo "<foo sasql created: $box />";
}
if (!sqimap_mailbox_is_subscribed($imap_stream, $mailbox)) {
sqimap_subscribe($imap_stream, $mailbox);
- if ($imap_server_type == 'cyrus') {
+ if ($imap_server_type == 'cyrus' || $imap_server_type == 'courier') {
$boxes = sqimap_mailbox_list($imap_stream);
} else {
$boxes = sqimap_mailbox_list($imap_stream, true);
}
- session_register($boxes, 'boxesnew');
+ sqsession_register($boxes, 'boxesnew');
// echo "<foo sasql subscried: $box />";
}
}

View File

@ -1,5 +0,0 @@
For the port to work properly you must copy the file
%%SQUIRRELDIR%%/plugins/sasql/sasql_conf.php.dist
to
%%SQUIRRELDIR%%/plugins/sasql/sasql_conf.php
and edit the configuration to meet your needs.

View File

@ -4,16 +4,16 @@ PORTNAME= secure_login
PORTVERSION= 1.4
PORTREVISION= 1
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.2.8
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= This plugin will automatically turn on SSL security during login
LICENSE= GPLv2
USES= perl5
USE_PERL5= run
USE_GENERIC_PKGMESSAGE= yes
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,5 +0,0 @@
For the port to work properly you must copy the file
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/secure_login/config.sample.php
to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/secure_login/config.php
and edit the configuration to meet your needs.

View File

@ -4,31 +4,19 @@
PORTNAME= shared_calendars
PORTVERSION= 2.0.1
PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
PKGNAMEPREFIX= squirrelmail-
PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.4.0
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= iCal-compliant calendaring for SquirrelMail
USES= perl5
USE_PERL5= install
USE_SM_COMPAT= yes
_SMSRCDIR= calendar
RUN_DEPENDS= ${SQUIRRELDIR}/plugins/calendar_file_backend:${PORTSDIR}/mail/squirrelmail-calendar_file_backend-plugin
OPTIONS_DEFINE= SQL
USE_SM_COMPAT= yes
USE_GENERIC_PKGMESSAGE= yes
_SMSRCDIR= calendar
NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MSQL}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/calendar_sql_backend:${PORTSDIR}/mail/squirrelmail-calendar_sql_backend-plugin
.else
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/calendar_file_backend:${PORTSDIR}/mail/squirrelmail-calendar_file_backend-plugin
.endif
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>

View File

@ -10,12 +10,11 @@ MAINTAINER= itetcu@FreeBSD.org
COMMENT= Provides buttons with customizable action (for reporting spam, etc.)
USE_SM_COMPAT= yes
USES= perl5
USE_PERL5= run
SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
post-extract:
@ -27,4 +26,4 @@ post-extract:
@${MV} ${WRKSRC}/${_SMSRCDIR}/docs ${WRKSRC}/${_SMSRCDIR}/doc
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,7 +1,7 @@
================================================================
For the port to work properly you must copy the file
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.sample.php
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.sample.php
to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
and edit the configuration to meet your needs.
================================================================

View File

@ -3,12 +3,7 @@
PORTNAME= squirrel_logger
PORTVERSION= 2.3
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
PKGNAMEPREFIX= squirrelmail-
PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.2.7
DIST_SUBDIR= squirrelmail
MAINTAINER= morinaga@riken.jp
COMMENT= Logging functionality for your webmail interface
@ -16,6 +11,7 @@ COMMENT= Logging functionality for your webmail interface
USE_SM_COMPAT= yes
NO_STAGE= yes
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.post.mk>

View File

@ -1,7 +1,7 @@
================================================================
For the port to work properly you must copy the file
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config_example.php
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config_example.php
to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
and edit the configuration to meet your needs.
================================================================

View File

@ -4,15 +4,20 @@ PORTNAME= timeout_user
PORTVERSION= 1.1.1
PORTREVISION= 2
DISTNAME= ${PORTNAME}-${PORTVERSION}-0.5
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Automatically logs a user out if they're idle for a set amount of time
LICENSE= GPLv2
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
USE_SM_COMPAT= yes
USE_GENERIC_PKGMESSAGE= yes
NO_STAGE= yes
post-patch:
@${MV} ${WRKSRC}/${SQUIRREL_PLUGIN_NAME}/config.php ${WRKSRC}/${SQUIRREL_PLUGIN_NAME}/config.php.sample
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -5,6 +5,6 @@
%%SQUIRRELDIR%%/plugins/timeout_user/setup.php
%%SQUIRRELDIR%%/plugins/timeout_user/INSTALL
%%SQUIRRELDIR%%/plugins/timeout_user/functions.php
%%SQUIRRELDIR%%/plugins/timeout_user/config.php
%%SQUIRRELDIR%%/plugins/timeout_user/config.php.sample
@dirrm %%SQUIRRELDIR%%/plugins/timeout_user
@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin %%SQUIRREL_PLUGIN_NAME%%; fi

View File

@ -5,18 +5,16 @@ PORTNAME= unsafe_image_rules
PORTVERSION= 0.8
PORTREVISION= 1
DISTNAME= ${PORTNAME:S/-/_/}.${PORTVERSION}-1.4
DIST_SUBDIR= squirrelmail
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Determines what unsafe (web) images will be shown
USE_SM_COMPAT= yes
USES= perl5
USE_PERL5= run
SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
NO_STAGE= yes
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.post.mk>

View File

@ -1,7 +1,7 @@
================================================================
For the port to work properly you must copy the file
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php.sample
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php.sample
to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
and edit the configuration to meet your needs.
================================================================

View File

@ -5,17 +5,16 @@ PORTNAME= user_special_mailboxes
PORTVERSION= 0.1
PORTREVISION= 1
DISTNAME= ${PORTNAME:S/-/_/}.${PORTVERSION}-1.4
DIST_SUBDIR= squirrelmail
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Lets define folders to be displayed at the top of the folders list
USE_SM_COMPAT= yes
USES= perl5
USE_PERL5= run
SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -3,23 +3,17 @@
PORTNAME= vlogin
PORTVERSION= 3.10.2
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
PKGNAMEPREFIX= squirrelmail-
PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.2.7
DIST_SUBDIR= squirrelmail
MAINTAINER= neil@darlow.co.uk
COMMENT= Adds multi-site-hosting capabilities to SquirrelMail
USES= perl5
USE_PERL5= run
USE_SM_COMPAT= yes
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
# We need to rearrange, install and cleanup documentation pre-install

View File

@ -5,17 +5,23 @@ PORTNAME= websearch
PORTVERSION= 0.1.6
PORTREVISION= 1
DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Plugin for Websearch
LICENSE= GPLv2
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
USE_SM_COMPAT= yes
USE_GENERIC_PKGMESSAGE= yes
SQUIRREL_PLUGIN_NAME= web_search
SQUIRREL_PLUGIN_CONFIG= ${SQUIRREL_PLUGIN_NAME}.conf.php
NO_STAGE= yes
post-patch:
@${MV} ${WRKSRC}/${_SMSRCDIR}/${SQUIRREL_PLUGIN_CONFIG}.dist ${WRKSRC}/${_SMSRCDIR}/${SQUIRREL_PLUGIN_CONFIG}.sample
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,5 +0,0 @@
For the port to work properly you must copy the file
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/web_search/web_search.conf.php.dist
to
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/web_search/config.php
and edit the configuration to meet your needs.

View File

@ -4,6 +4,6 @@
%%SQUIRRELDIR%%/plugins/web_search/hooks.php
%%SQUIRRELDIR%%/plugins/web_search/setup.php
%%SQUIRRELDIR%%/plugins/web_search/version
%%SQUIRRELDIR%%/plugins/web_search/web_search.conf.php.dist
%%SQUIRRELDIR%%/plugins/web_search/web_search.conf.php.sample
@dirrm %%SQUIRRELDIR%%/plugins/web_search/
@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin web_search; fi

View File

@ -4,17 +4,10 @@
PORTNAME= wetteronline
PORTVERSION= 0.1
PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
PKGNAMEPREFIX= squirrelmail-
PKGNAMESUFFIX= -plugin
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Plugin for the weather in Germany
USES= perl5
USE_PERL5= install
USE_SM_COMPAT= yes
NO_STAGE= yes

View File

@ -2,7 +2,20 @@
#
# $LastChangedDate: 2010-02-01 22:21:34 -0500 (Mon, 01 Feb 2010) $
#
# Common code for squirrelmail plugins.
# To create a plugin, put the following at the bottom of your makefile:
#
# .include <bsd.port.pre.mk>
# .include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
# .include <bsd.port.post.mk>
#
# Variables you can set:
# USE_SM_COMPAT = creates a dependency on mail/squirrelmail-compatibility-plugin
# USE_GENERIC_PKGMESSAGE = to use a default message about editing config.php
# *****NOTE this clobbers FILESDIR, so you cannot use this if you have any files/patch-*
# SQUIRREL_PLUGIN_NAME = defaults to PORTNAME
# SQUIRREL_PLUGIN_CONFIG = the config file name (for the PKGMESSAGE)
# _SMSRCDIR = WRKSRC=${WRKDIR}/${_SMSRCDIR}
#
#
# Created & tested by
# Thomas Abthorpe <tabthorpe@FreeBSD.org>
@ -19,6 +32,7 @@ CATEGORIES?= mail www
MASTER_SITES?= http://www.squirrelmail.org/plugins/
PKGNAMEPREFIX?= squirrelmail-
PKGNAMESUFFIX?= -plugin
DIST_SUBDIR?= squirrelmail
RUN_DEPENDS+= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
@ -26,6 +40,11 @@ RUN_DEPENDS+= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
.endif
.ifndef WITHOUT_ACTIVATE
USES+= perl5
USE_PERL5+= install
.endif
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_PHP?= yes
@ -41,8 +60,17 @@ SQUIRRELDIR?= ${PREFIX}/www/squirrelmail
PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR:S,${PREFIX}/,,}
SUB_LIST+= SQUIRRELDIR=${SQUIRRELDIR}
.if exists(${FILESDIR}/pkg-message.in)
SUB_FILES= pkg-message
SQUIRREL_PLUGIN_CONFIG?= config.php
PLIST_SUB+= SQUIRREL_PLUGIN_CONFIG=${SQUIRREL_PLUGIN_CONFIG}
SUB_LIST+= SQUIRREL_PLUGIN_CONFIG=${SQUIRREL_PLUGIN_CONFIG}
.if defined(USE_GENERIC_PKGMESSAGE)
# NOTE: we have to change FILESDIR to make this work...
FILESDIR= ${.CURDIR}/../squirrelmail/files
SUB_FILES+= plugin-pkg-message
PKGMESSAGE= ${WRKDIR}/plugin-pkg-message
.elif exists(${FILESDIR}/pkg-message.in)
SUB_FILES+= pkg-message
.endif
.if !target(pre-everything)
@ -85,7 +113,7 @@ post-install:
.endif
@${ECHO_CMD} ""
.if exists(${FILESDIR}/pkg-message.in)
.if exists(${FILESDIR}/pkg-message.in) || exists(${FILESDIR}/plugin-pkg-message.in)
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD} ""
.endif

View File

@ -0,0 +1,7 @@
=============================================================
Before using the %%SQUIRREL_PLUGIN_NAME%% plugin, you must copy the file
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/%%SQUIRREL_PLUGIN_CONFIG%%.sample
to
%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/%%SQUIRREL_PLUGIN_CONFIG%%
and edit the configuration to meet your needs.
=============================================================