www/nghttp2: Change back to make

- Bump PORTREVISION for package change
This commit is contained in:
Po-Chuan Hsieh 2023-01-30 20:28:54 +08:00
parent 67d9091988
commit 6ab07aa32f
No known key found for this signature in database
GPG Key ID: 9A4BD10F002DD04B
8 changed files with 231 additions and 28 deletions

View File

@ -1,7 +1,7 @@
PORTNAME= nghttp2
DISTVERSION= 1.51.0
PORTVERSION= 1.51.0
CATEGORIES= www net
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= HTTP/2.0 C Library
@ -10,32 +10,44 @@ WWW= https://nghttp2.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= libnghttp2>=${DISTVERSION}:www/libnghttp2
BUILD_DEPENDS= libnghttp2>=${PORTVERSION}:www/libnghttp2
LIB_DEPENDS= libnghttp2.so:www/libnghttp2
USES= cmake compiler:c++14-lang cpe localbase:ldflags pathfix \
pkgconfig python:env shebangfix ssl tar:xz
USE_RC_SUBR= nghttpx
SHEBANG_FILES= script/fetch-ocsp-response
USES= compiler:c++14-lang cpe gmake libtool localbase pathfix pkgconfig ssl tar:xz
CMAKE_OFF= ENABLE_PYTHON_BINDINGS ENABLE_HTTP3
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR:PATH=man
CONFIGURE_ARGS= --disable-python-bindings --with-jemalloc
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_CXXSTD= c++14
USE_RC_SUBR= nghttpx
OPTIONS_DEFINE= APP DOCS EXAMPLES HPACK
OPTIONS_DEFAULT=APP HPACK
OPTIONS_SUB= yes
APP_DESC= Build h2load, nghttp, nghttpd and nghttpx
APP_BUILD_DEPENDS= c-ares>=1.7.5:dns/c-ares \
libev>=4.11:devel/libev
APP_CONFIGURE_ENABLE= app
APP_CONFIGURE_OFF= --without-libxml2
APP_LIB_DEPENDS= libcares.so:dns/c-ares \
libev.so:devel/libev
APP_USES= gnome
APP_USE= GNOME=libxml2
APP_CMAKE_BOOL= ENABLE_APP WITH_LIBXML2
HPACK_LIB_DEPENDS= libjansson.so:devel/jansson
HPACK_CMAKE_BOOL= ENABLE_HPACK_TOOLS
APP_USES= gnome
EXAMPLES_CONFIGURE_ENABLE= examples
EXAMPLES_BUILD_DEPENDS= libevent>=2.0.8:devel/libevent
EXAMPLES_LIB_DEPENDS= libevent_openssl.so:devel/libevent
EXAMPLES_CMAKE_BOOL= ENABLE_EXAMPLES
HPACK_BUILD_DEPENDS= jansson>=2.5:devel/jansson
HPACK_CONFIGURE_ENABLE= hpack-tools
HPACK_LIB_DEPENDS= libjansson.so:devel/jansson
# lib/libnghttp2.* are not available until configure phase
post-configure:
@${MKDIR} ${WRKSRC}/lib/.libs/
@${CP} ${LOCALBASE}/lib/libnghttp2.so* ${WRKSRC}/lib/.libs/
@cd ${WRKSRC}/lib/.libs/ && ${AR} x ${LOCALBASE}/lib/libnghttp2.a
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/nghttpx/
@ -43,7 +55,7 @@ post-install:
post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
cd ${WRKSRC}/examples/ && ${INSTALL_DATA} client.c deflate.c libevent-client.c libevent-server.c ${STAGEDIR}${EXAMPLESDIR}/
cd ${INSTALL_WRKSRC}/examples/ && ${INSTALL_PROGRAM} client deflate libevent-client libevent-server ${STAGEDIR}${EXAMPLESDIR}/
${INSTALL_DATA} ${WRKSRC}/examples/*.c* ${STAGEDIR}${EXAMPLESDIR}/
cd ${WRKSRC}/examples/ && ${INSTALL_PROGRAM} client deflate libevent-client libevent-server ${STAGEDIR}${EXAMPLESDIR}/
.include <bsd.port.mk>

View File

@ -1,11 +0,0 @@
--- CMakeLists.txt.orig 2022-12-24 08:52:48 UTC
+++ CMakeLists.txt
@@ -505,7 +505,7 @@ set(PKGLIBDIR "${CMAKE_INSTALL_FULL_LIBDIR}/${CMAKE_PR
install(FILES README.rst DESTINATION "${CMAKE_INSTALL_DOCDIR}")
-add_subdirectory(lib)
+#add_subdirectory(lib)
#add_subdirectory(lib/includes)
add_subdirectory(third-party)
add_subdirectory(src)

View File

@ -0,0 +1,11 @@
--- Makefile.in.orig 2022-11-13 06:53:28 UTC
+++ Makefile.in
@@ -465,7 +465,7 @@ top_srcdir = @top_srcdir@
# LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
# OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-SUBDIRS = lib third-party src bpf examples python tests integration-tests \
+SUBDIRS = third-party src bpf examples python tests integration-tests \
doc contrib script

View File

@ -0,0 +1,66 @@
% sed -i .orig 's|$[({]top_builddir[})]/lib/libnghttp2.la|-lnghttp2|' */Makefile.in
--- examples/Makefile.in.orig 2022-11-13 06:53:28 UTC
+++ examples/Makefile.in
@@ -146,7 +146,7 @@ am__asio_cl_SOURCES_DIST = asio-cl.cc
@ENABLE_ASIO_LIB_TRUE@@ENABLE_EXAMPLES_TRUE@am_asio_cl_OBJECTS = asio_cl-asio-cl.$(OBJEXT)
asio_cl_OBJECTS = $(am_asio_cl_OBJECTS)
am__DEPENDENCIES_1 =
-@ENABLE_ASIO_LIB_TRUE@@ENABLE_EXAMPLES_TRUE@am__DEPENDENCIES_2 = $(top_builddir)/lib/libnghttp2.la \
+@ENABLE_ASIO_LIB_TRUE@@ENABLE_EXAMPLES_TRUE@am__DEPENDENCIES_2 = -lnghttp2 \
@ENABLE_ASIO_LIB_TRUE@@ENABLE_EXAMPLES_TRUE@ $(top_builddir)/src/libnghttp2_asio.la \
@ENABLE_ASIO_LIB_TRUE@@ENABLE_EXAMPLES_TRUE@ $(top_builddir)/third-party/liburl-parser.la \
@ENABLE_ASIO_LIB_TRUE@@ENABLE_EXAMPLES_TRUE@ $(am__DEPENDENCIES_1) \
@@ -175,14 +175,14 @@ am__client_SOURCES_DIST = client.c
client_OBJECTS = $(am_client_OBJECTS)
client_LDADD = $(LDADD)
@ENABLE_EXAMPLES_TRUE@client_DEPENDENCIES = \
-@ENABLE_EXAMPLES_TRUE@ $(top_builddir)/lib/libnghttp2.la \
+@ENABLE_EXAMPLES_TRUE@ -lnghttp2 \
@ENABLE_EXAMPLES_TRUE@ $(top_builddir)/third-party/liburl-parser.la
am__deflate_SOURCES_DIST = deflate.c
@ENABLE_EXAMPLES_TRUE@am_deflate_OBJECTS = deflate.$(OBJEXT)
deflate_OBJECTS = $(am_deflate_OBJECTS)
deflate_LDADD = $(LDADD)
@ENABLE_EXAMPLES_TRUE@deflate_DEPENDENCIES = \
-@ENABLE_EXAMPLES_TRUE@ $(top_builddir)/lib/libnghttp2.la \
+@ENABLE_EXAMPLES_TRUE@ -lnghttp2 \
@ENABLE_EXAMPLES_TRUE@ $(top_builddir)/third-party/liburl-parser.la
am__libevent_client_SOURCES_DIST = libevent-client.c
@ENABLE_EXAMPLES_TRUE@am_libevent_client_OBJECTS = \
@@ -190,7 +190,7 @@ am__libevent_client_SOURCES_DIST = libevent-client.c
libevent_client_OBJECTS = $(am_libevent_client_OBJECTS)
libevent_client_LDADD = $(LDADD)
@ENABLE_EXAMPLES_TRUE@libevent_client_DEPENDENCIES = \
-@ENABLE_EXAMPLES_TRUE@ $(top_builddir)/lib/libnghttp2.la \
+@ENABLE_EXAMPLES_TRUE@ -lnghttp2 \
@ENABLE_EXAMPLES_TRUE@ $(top_builddir)/third-party/liburl-parser.la
am__libevent_server_SOURCES_DIST = libevent-server.c
@ENABLE_EXAMPLES_TRUE@am_libevent_server_OBJECTS = \
@@ -198,7 +198,7 @@ am__libevent_server_SOURCES_DIST = libevent-server.c
libevent_server_OBJECTS = $(am_libevent_server_OBJECTS)
libevent_server_LDADD = $(LDADD)
@ENABLE_EXAMPLES_TRUE@libevent_server_DEPENDENCIES = \
-@ENABLE_EXAMPLES_TRUE@ $(top_builddir)/lib/libnghttp2.la \
+@ENABLE_EXAMPLES_TRUE@ -lnghttp2 \
@ENABLE_EXAMPLES_TRUE@ $(top_builddir)/third-party/liburl-parser.la
AM_V_P = $(am__v_P_@AM_V@)
am__v_P_ = $(am__v_P_@AM_DEFAULT_V@)
@@ -504,7 +504,7 @@ EXTRA_DIST = CMakeLists.txt
@ENABLE_EXAMPLES_TRUE@ @DEFS@
@ENABLE_EXAMPLES_TRUE@AM_LDFLAGS = @LIBTOOL_LDFLAGS@
-@ENABLE_EXAMPLES_TRUE@LDADD = $(top_builddir)/lib/libnghttp2.la \
+@ENABLE_EXAMPLES_TRUE@LDADD = -lnghttp2 \
@ENABLE_EXAMPLES_TRUE@ $(top_builddir)/third-party/liburl-parser.la \
@ENABLE_EXAMPLES_TRUE@ @LIBEVENT_OPENSSL_LIBS@ \
@ENABLE_EXAMPLES_TRUE@ @OPENSSL_LIBS@ \
@@ -519,7 +519,7 @@ EXTRA_DIST = CMakeLists.txt
# nghttp2/nghttp2.h) in this package is used rather than installed
# one.
@ENABLE_ASIO_LIB_TRUE@@ENABLE_EXAMPLES_TRUE@ASIOCPPFLAGS = ${AM_CPPFLAGS} ${BOOST_CPPFLAGS}
-@ENABLE_ASIO_LIB_TRUE@@ENABLE_EXAMPLES_TRUE@ASIOLDADD = $(top_builddir)/lib/libnghttp2.la \
+@ENABLE_ASIO_LIB_TRUE@@ENABLE_EXAMPLES_TRUE@ASIOLDADD = -lnghttp2 \
@ENABLE_ASIO_LIB_TRUE@@ENABLE_EXAMPLES_TRUE@ $(top_builddir)/src/libnghttp2_asio.la @JEMALLOC_LIBS@ \
@ENABLE_ASIO_LIB_TRUE@@ENABLE_EXAMPLES_TRUE@ $(top_builddir)/third-party/liburl-parser.la \
@ENABLE_ASIO_LIB_TRUE@@ENABLE_EXAMPLES_TRUE@ @OPENSSL_LIBS@ \

View File

@ -0,0 +1,7 @@
--- script/fetch-ocsp-response.orig 2021-10-19 09:31:47 UTC
+++ script/fetch-ocsp-response
@@ -1,4 +1,3 @@
-#!/usr/bin/env python
# -*- coding: utf-8 -*-
# nghttp2 - HTTP/2 C Library

View File

@ -0,0 +1,83 @@
% sed -i .orig 's|$[({]top_builddir[})]/lib/libnghttp2.la|-lnghttp2|' */Makefile.in
--- src/Makefile.in.orig 2022-11-13 06:53:29 UTC
+++ src/Makefile.in
@@ -318,7 +318,7 @@ am__libnghttpx_a_SOURCES_DIST = util.cc util.h http2.c
libnghttpx_a_OBJECTS = $(am_libnghttpx_a_OBJECTS)
am__DEPENDENCIES_1 =
@ENABLE_ASIO_LIB_TRUE@libnghttp2_asio_la_DEPENDENCIES = \
-@ENABLE_ASIO_LIB_TRUE@ $(top_builddir)/lib/libnghttp2.la \
+@ENABLE_ASIO_LIB_TRUE@ -lnghttp2 \
@ENABLE_ASIO_LIB_TRUE@ $(top_builddir)/third-party/liburl-parser.la \
@ENABLE_ASIO_LIB_TRUE@ $(top_builddir)/third-party/libllhttp.la \
@ENABLE_ASIO_LIB_TRUE@ $(am__DEPENDENCIES_1) \
@@ -394,7 +394,7 @@ am__deflatehd_SOURCES_DIST = deflatehd.cc comp_helper.
@ENABLE_HPACK_TOOLS_TRUE@ $(am__objects_4)
deflatehd_OBJECTS = $(am_deflatehd_OBJECTS)
deflatehd_LDADD = $(LDADD)
-deflatehd_DEPENDENCIES = $(top_builddir)/lib/libnghttp2.la \
+deflatehd_DEPENDENCIES = -lnghttp2 \
$(top_builddir)/third-party/liburl-parser.la \
$(top_builddir)/third-party/libllhttp.la
am__h2load_SOURCES_DIST = util.cc util.h http2.cc http2.h h2load.cc \
@@ -413,7 +413,7 @@ am__h2load_SOURCES_DIST = util.cc util.h http2.cc http
@ENABLE_APP_TRUE@ $(am__objects_5)
h2load_OBJECTS = $(am_h2load_OBJECTS)
h2load_LDADD = $(LDADD)
-h2load_DEPENDENCIES = $(top_builddir)/lib/libnghttp2.la \
+h2load_DEPENDENCIES = -lnghttp2 \
$(top_builddir)/third-party/liburl-parser.la \
$(top_builddir)/third-party/libllhttp.la
am__inflatehd_SOURCES_DIST = inflatehd.cc comp_helper.c comp_helper.h \
@@ -422,7 +422,7 @@ am__inflatehd_SOURCES_DIST = inflatehd.cc comp_helper.
@ENABLE_HPACK_TOOLS_TRUE@ $(am__objects_4)
inflatehd_OBJECTS = $(am_inflatehd_OBJECTS)
inflatehd_LDADD = $(LDADD)
-inflatehd_DEPENDENCIES = $(top_builddir)/lib/libnghttp2.la \
+inflatehd_DEPENDENCIES = -lnghttp2 \
$(top_builddir)/third-party/liburl-parser.la \
$(top_builddir)/third-party/libllhttp.la
am__nghttp_SOURCES_DIST = util.cc http2.cc timegm.c app_helper.cc \
@@ -441,7 +441,7 @@ am__objects_7 =
@ENABLE_APP_TRUE@ $(am__objects_7) tls.$(OBJEXT)
nghttp_OBJECTS = $(am_nghttp_OBJECTS)
nghttp_LDADD = $(LDADD)
-nghttp_DEPENDENCIES = $(top_builddir)/lib/libnghttp2.la \
+nghttp_DEPENDENCIES = -lnghttp2 \
$(top_builddir)/third-party/liburl-parser.la \
$(top_builddir)/third-party/libllhttp.la
am__nghttpd_SOURCES_DIST = util.cc http2.cc timegm.c app_helper.cc \
@@ -453,13 +453,13 @@ am__nghttpd_SOURCES_DIST = util.cc http2.cc timegm.c a
@ENABLE_APP_TRUE@ tls.$(OBJEXT) HttpServer.$(OBJEXT)
nghttpd_OBJECTS = $(am_nghttpd_OBJECTS)
nghttpd_LDADD = $(LDADD)
-nghttpd_DEPENDENCIES = $(top_builddir)/lib/libnghttp2.la \
+nghttpd_DEPENDENCIES = -lnghttp2 \
$(top_builddir)/third-party/liburl-parser.la \
$(top_builddir)/third-party/libllhttp.la
am__nghttpx_SOURCES_DIST = shrpx.cc shrpx.h
@ENABLE_APP_TRUE@am_nghttpx_OBJECTS = nghttpx-shrpx.$(OBJEXT)
nghttpx_OBJECTS = $(am_nghttpx_OBJECTS)
-am__DEPENDENCIES_2 = $(top_builddir)/lib/libnghttp2.la \
+am__DEPENDENCIES_2 = -lnghttp2 \
$(top_builddir)/third-party/liburl-parser.la \
$(top_builddir)/third-party/libllhttp.la
@ENABLE_APP_TRUE@nghttpx_DEPENDENCIES = libnghttpx.a \
@@ -1150,7 +1150,7 @@ AM_CPPFLAGS = \
@DEFS@
AM_LDFLAGS = @LIBTOOL_LDFLAGS@
-LDADD = $(top_builddir)/lib/libnghttp2.la \
+LDADD = -lnghttp2 \
$(top_builddir)/third-party/liburl-parser.la \
$(top_builddir)/third-party/libllhttp.la \
@JEMALLOC_LIBS@ \
@@ -1330,7 +1330,7 @@ LDADD = $(top_builddir)/lib/libnghttp2.la \
@ENABLE_ASIO_LIB_TRUE@libnghttp2_asio_la_CPPFLAGS = ${AM_CPPFLAGS} ${BOOST_CPPFLAGS}
@ENABLE_ASIO_LIB_TRUE@libnghttp2_asio_la_LDFLAGS = $(AM_LDFLAGS) -no-undefined -version-info 1:0:0
@ENABLE_ASIO_LIB_TRUE@libnghttp2_asio_la_LIBADD = \
-@ENABLE_ASIO_LIB_TRUE@ $(top_builddir)/lib/libnghttp2.la \
+@ENABLE_ASIO_LIB_TRUE@ -lnghttp2 \
@ENABLE_ASIO_LIB_TRUE@ $(top_builddir)/third-party/liburl-parser.la \
@ENABLE_ASIO_LIB_TRUE@ $(top_builddir)/third-party/libllhttp.la \
@ENABLE_ASIO_LIB_TRUE@ @OPENSSL_LIBS@ \

View File

@ -0,0 +1,31 @@
% sed -i .orig 's|$[({]top_builddir[})]/lib/libnghttp2.la|-lnghttp2|' */Makefile.in
--- tests/Makefile.in.orig 2022-11-13 06:53:29 UTC
+++ tests/Makefile.in
@@ -141,7 +141,7 @@ failmalloc_OBJECTS = $(am_failmalloc_OBJECTS)
am__DEPENDENCIES_1 =
@ENABLE_STATIC_FALSE@@HAVE_CUNIT_TRUE@am__DEPENDENCIES_2 = ${top_builddir}/lib/.libs/*.o \
@ENABLE_STATIC_FALSE@@HAVE_CUNIT_TRUE@ $(am__DEPENDENCIES_1)
-@ENABLE_STATIC_TRUE@@HAVE_CUNIT_TRUE@am__DEPENDENCIES_2 = ${top_builddir}/lib/libnghttp2.la \
+@ENABLE_STATIC_TRUE@@HAVE_CUNIT_TRUE@am__DEPENDENCIES_2 = -lnghttp2 \
@ENABLE_STATIC_TRUE@@HAVE_CUNIT_TRUE@ $(am__DEPENDENCIES_1)
@ENABLE_FAILMALLOC_TRUE@@HAVE_CUNIT_TRUE@failmalloc_DEPENDENCIES = $(am__DEPENDENCIES_2)
AM_V_lt = $(am__v_lt_@AM_V@)
@@ -181,7 +181,7 @@ am__objects_1 =
main_OBJECTS = $(am_main_OBJECTS)
@ENABLE_STATIC_FALSE@@HAVE_CUNIT_TRUE@main_DEPENDENCIES = ${top_builddir}/lib/.libs/*.o \
@ENABLE_STATIC_FALSE@@HAVE_CUNIT_TRUE@ $(am__DEPENDENCIES_1)
-@ENABLE_STATIC_TRUE@@HAVE_CUNIT_TRUE@main_DEPENDENCIES = ${top_builddir}/lib/libnghttp2.la \
+@ENABLE_STATIC_TRUE@@HAVE_CUNIT_TRUE@main_DEPENDENCIES = -lnghttp2 \
@ENABLE_STATIC_TRUE@@HAVE_CUNIT_TRUE@ $(am__DEPENDENCIES_1)
main_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
@@ -743,7 +743,7 @@ EXTRA_DIST = CMakeLists.txt
# files directly because the tests use symbols not included in public API.
@ENABLE_STATIC_FALSE@@HAVE_CUNIT_TRUE@main_LDADD = ${top_builddir}/lib/.libs/*.o \
@ENABLE_STATIC_FALSE@@HAVE_CUNIT_TRUE@ $(am__append_2)
-@ENABLE_STATIC_TRUE@@HAVE_CUNIT_TRUE@main_LDADD = ${top_builddir}/lib/libnghttp2.la \
+@ENABLE_STATIC_TRUE@@HAVE_CUNIT_TRUE@main_LDADD = -lnghttp2 \
@ENABLE_STATIC_TRUE@@HAVE_CUNIT_TRUE@ $(am__append_2)
@HAVE_CUNIT_TRUE@main_LDFLAGS = -static
@ENABLE_FAILMALLOC_TRUE@@HAVE_CUNIT_TRUE@failmalloc_SOURCES = failmalloc.c failmalloc_test.c failmalloc_test.h \

View File

@ -10,6 +10,10 @@ man/man1/nghttp.1.gz
man/man1/nghttpd.1.gz
man/man1/nghttpx.1.gz
%%PORTDOCS%%%%DOCSDIR%%/README.rst
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/asio-cl.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/asio-cl2.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/asio-sv.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/asio-sv2.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/client
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/client.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/deflate