New port pengpong version 0.2: A cross-platform pong game written

in SDL

PR:		30060
Submitted by:	Patrick Li <pat@databits.net>
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2001-09-03 16:31:09 +00:00
parent fe3e441eb2
commit 6aa4f9ff21
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=47372
7 changed files with 64 additions and 0 deletions

View File

@ -177,6 +177,7 @@
SUBDIR += oneko
SUBDIR += oneko-sakura
SUBDIR += oonsoo
SUBDIR += pengpong
SUBDIR += penguin-command
SUBDIR += pentix
SUBDIR += phalanx

30
games/pengpong/Makefile Normal file
View File

@ -0,0 +1,30 @@
# New ports collection makefile for: pengpong
# Date created: Fri Aug 24 18:21:25 EDT 2001
# Whom: Patrick Li <pat@databits.net>
#
# $FreeBSD$
#
PORTNAME= pengpong
PORTVERSION= 0.2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= pat@databits.net
LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
NO_WRKSUBDIR= yes
MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
do-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
@${INSTALL_PROGRAM} ${WRKSRC}/pengpong ${PREFIX}/bin
.include <bsd.port.mk>

1
games/pengpong/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (pengpong-0.2.tar.gz) = 840fc7a4a6bb4abdc33cae629b951273

View File

@ -0,0 +1,25 @@
--- Makefile.orig Fri Aug 24 15:39:29 2001
+++ Makefile Mon Sep 3 13:25:31 2001
@@ -1,15 +1,8 @@
-all: SFont link2 sdlpong finish
+CXXFLAGS += `${SDL_CONFIG} --cflags`
+LIBS = `${SDL_CONFIG} --libs` -lSDL_image
-SFont:
- g++ -I/usr/include/SDL -D_REENTRANT -c -o SFont.o SFont.c
-link2:
- g++ -I/usr/include/SDL -D_REENTRANT -c -o link2.o link2.cpp
-sdlpong:
- g++ -pedantic -Wall -c -o sdlpong.o sdlpong.cpp -I/usr/include/SDL -D_REENTRANT
-finish: SFont link2 sdlpong
- g++ -o pengpong sdlpong.o link2.o SFont.o -D_REENTRANT -I/usr/include/SDL -lSDL_image
-install:
- cp pengpong /usr/local/bin
-
-clean:
- rm *.o
+all:
+ ${CXX} -c -o SFont.o SFont.c ${CXXFLAGS}
+ ${CXX} -c -o link2.o link2.cpp ${CXXFLAGS}
+ ${CXX} -c -o sdlpong.o sdlpong.cpp ${CXXFLAGS}
+ ${CXX} -o pengpong sdlpong.o link2.o SFont.o ${CXXFLAGS} ${LIBS}

View File

@ -0,0 +1 @@
A cross-platform pong game written in SDL

3
games/pengpong/pkg-descr Normal file
View File

@ -0,0 +1,3 @@
Peng-Pong is a cross-platform pong game written in SDL
WWW: http://pengpong.sourceforge.net/

3
games/pengpong/pkg-plist Normal file
View File

@ -0,0 +1,3 @@
bin/pengpong
%%PORTDOCS%%share/doc/pengpong/README
%%PORTDOCS%%@dirrm share/doc/pengpong