update comms/gammu to 1.00.0

PR:		ports/79189
Submitted by:	maintainer
This commit is contained in:
Oliver Lehmann 2005-04-14 09:05:03 +00:00
parent 7ab00c3b40
commit 6a554c8669
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=133307
12 changed files with 98 additions and 128 deletions

View File

@ -6,11 +6,10 @@
#
PORTNAME= gammu
PORTVERSION= 0.98.0
PORTVERSION= 1.00.0
PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= http://www.mwiacek.com/zips/gsm/gammu/older/ \
http://www.kirill.spb.ru/gammu/
MASTER_SITES= http://www.kirill.spb.ru/gammu/
MAINTAINER= kirill@solaris.ru
COMMENT= GNU All Mobile Management Utilities
@ -19,7 +18,7 @@ MAN1= gammu.1
USE_GMAKE= yes
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
WANT_AUTOCONF_VER=253
WANT_AUTOCONF_VER=259
CONFIGURE_ARGS= --disable-bluerfsearch
CONFIGURE_ENV= CFLAGS="${CFLAGS} -fPIC"

View File

@ -1,2 +1,2 @@
MD5 (gammu-0.98.0.tar.gz) = 6abfb95af979ce283fb22a179476dc6a
SIZE (gammu-0.98.0.tar.gz) = 813856
MD5 (gammu-1.00.0.tar.gz) = 9d921f9c5b6f3b8b76a69720e2d9f173
SIZE (gammu-1.00.0.tar.gz) = 850872

View File

@ -1,15 +1,15 @@
--- cfg/Makefile.glo.orig Mon Jul 26 04:01:32 2004
+++ cfg/Makefile.glo Wed Mar 2 10:42:01 2005
@@ -102,7 +102,7 @@
--- cfg/Makefile.glo.orig Sat Jan 15 17:01:28 2005
+++ cfg/Makefile.glo Thu Mar 24 13:13:31 2005
@@ -122,7 +122,7 @@
@echo Making $<
@$(CC) -c $(CFLAGS) -I$(TOPDIR)/common/ $(CPPFLAGS) $(<) -o $(@)
@$(CC) -c $(CFLAGS) -I$(TOPDIR)/common/ $(CPPFLAGS) $*.c -o $*.o
-all: gammu
+all: gammu shared
$(TOPDIR)/gammu/gammu: $(COMMON) $(GAMMU)
@echo Linking gammu
@@ -203,7 +203,7 @@
@@ -227,7 +227,7 @@
@$(INSTALL) -m 0644 $(TOPDIR)/docs/docs/english/gammu.1 $(DESTDIR)$(INSTALL_MAN_DIR)
@$(RM) $(DESTDIR)$(INSTALL_DOC_DIR)/docs/english/gammu.1
@ -18,7 +18,7 @@
installonly: all
@echo Installing binaries to $(DESTDIR)$(INSTALL_BIN_DIR)
@@ -220,8 +220,7 @@
@@ -244,8 +244,7 @@
@echo Installing shared library to $(DESTDIR)$(INSTALL_LIB_DIR)
@$(INSTALL) -m 0755 -d $(DESTDIR)$(INSTALL_LIB_DIR)
@ -28,7 +28,7 @@
@$(LN) -s libGammu.so.$(SONAME_MAJOR) $(DESTDIR)$(INSTALL_LIB_DIR)/libGammu.so
@echo Installing static library to $(DESTDIR)$(INSTALL_LIB_DIR)
@@ -240,8 +239,8 @@
@@ -264,8 +263,8 @@
@$(INSTALL) -m 0644 cfg/config.h $(DESTDIR)$(INSTALL_H_DIR)/config.h
@echo Installing pkgconfig file

View File

@ -1,18 +0,0 @@
--- common/device/serial/ser_unx.c.orig Fri Aug 13 12:10:45 2004
+++ common/device/serial/ser_unx.c Fri Nov 26 16:25:16 2004
@@ -230,6 +230,7 @@
case 57600: speed2 = B57600; break;
case 115200: speed2 = B115200; break;
case 230400: speed2 = B230400; break;
+#ifdef B460800
case 460800: speed2 = B460800; break;
#ifdef B500000
case 500000: speed2 = B500000; break;
@@ -243,6 +244,7 @@
case 3000000: speed2 = B3000000; break;
case 3500000: speed2 = B3500000; break;
case 4000000: speed2 = B4000000; break;
+#endif
#endif
#endif
}

View File

@ -1,25 +1,27 @@
--- cfg/autoconf/configure.in.orig Thu Nov 25 13:02:35 2004
+++ cfg/autoconf/configure.in Thu Nov 25 13:01:56 2004
@@ -163,14 +163,14 @@
dnl Bluetooth stacks
gsm_blue_stack=unknown
AC_CHECK_HEADERS(bluetooth/bluetooth.h,
- [gsm_blue_stack=Bluez
+ [gsm_blue_stack=FreeBSD
AC_DEFINE(GSM_ENABLE_BLUEZ)
- LDLIBS="$LDLIBS -lbluetooth -lsdp"])
+ LDLIBS="$LDLIBS -lbluetooth"])
-dnl Path for Bluez bluetooth library
+dnl Path for FreeBSD bluetooth library
gsm_bt_dir=""
AC_ARG_WITH(bluedir,
- [ --with-bluedir=DIR Specifies the base libbluetooth from Bluez],
+ [ --with-bluedir=DIR Specifies the base libbluetooth from FreeBSD],
[ if test x$withval = xyes; then
AC_MSG_WARN(Usage is: --with-bluedir=DIR)
else
@@ -261,7 +261,7 @@
--- cfg/autoconf/configure.in.orig Sat Jan 15 13:45:26 2005
+++ cfg/autoconf/configure.in Thu Apr 14 08:27:47 2005
@@ -185,17 +185,17 @@
fi
if test "$gsm_blue_stack" = unknown ; then
AC_CHECK_HEADERS(bluetooth/bluetooth.h,
- [gsm_blue_stack=Bluez
+ [gsm_blue_stack=FreeBSD
LDLIBS="$LDLIBS -lbluetooth"
AC_CHECK_LIB(sdp, sdp_list_append, LDLIBS="$LDLIBS -lsdp")
AC_DEFINE(GSM_ENABLE_BLUEZ)
])
fi
- dnl Path for Bluez bluetooth library
+ dnl Path for FreeBSD bluetooth library
gsm_bt_dir=""
AC_ARG_WITH(bluedir,
- [ --with-bluedir=DIR Specifies the base libbluetooth from Bluez],
+ [ --with-bluedir=DIR Specifies the base libbluetooth from FreeBSD],
[ if test x$withval = xyes; then
AC_MSG_WARN(Usage is: --with-bluedir=DIR)
else
@@ -287,7 +287,7 @@
[ --disable-bluefbus Disable Nokia FBUS2 over Bluetooth stack
(Nokia 6210)],
[gsm_enable_bluefbus2="no"],
@ -28,7 +30,7 @@
AC_DEFINE(GSM_ENABLE_BLUEFBUS2)
gsm_enable_bluefbus2="yes"
else
@@ -271,7 +271,7 @@
@@ -297,7 +297,7 @@
[ --disable-bluephonet Disable Nokia PHONET FBUS over Bluetooth
stack (all new Nokias)],
[gsm_enable_bluephonet="no"],
@ -37,7 +39,7 @@
AC_DEFINE(GSM_ENABLE_BLUEPHONET)
gsm_enable_bluephonet="yes"
else
@@ -280,7 +280,7 @@
@@ -306,7 +306,7 @@
AC_ARG_ENABLE(blueat,
[ --disable-blueat Disable AT commands over Bluetooth stack],
[gsm_enable_blueat="no"],
@ -46,7 +48,7 @@
AC_DEFINE(GSM_ENABLE_BLUEAT)
gsm_enable_blueat="yes"
else
@@ -289,7 +289,7 @@
@@ -315,7 +315,7 @@
AC_ARG_ENABLE(blueobex,
[ --disable-blueobex Disable OBEX over Bluetooth stack],
[gsm_enable_blueobex="no"],
@ -55,7 +57,7 @@
AC_DEFINE(GSM_ENABLE_BLUEOBEX)
gsm_enable_blueobex="yes"
else
@@ -408,7 +408,7 @@
@@ -438,7 +438,7 @@
Binaries - $bindir
RPM making directory - $RPM_DIR
Temporary directory - $TEMP_DIR

View File

@ -6,18 +6,18 @@ bin/gammu
%%DOCSDIR%%/docs/english/replace.txt
%%DOCSDIR%%/docs/italian/gammu.txt
%%DOCSDIR%%/docs/italian/readme.txt
%%DOCSDIR%%/examples/gammu.png
%%DOCSDIR%%/docs/gammu.png
%%DOCSDIR%%/examples/config/gammurc
%%DOCSDIR%%/examples/config/smsd_mysql.sql
%%DOCSDIR%%/examples/config/smsdrc
%%DOCSDIR%%/examples/config/mysql.sql
%%DOCSDIR%%/examples/fax/faxreceive
%%DOCSDIR%%/examples/fax/faxsend
%%DOCSDIR%%/examples/logo/greatings.nlm
%%DOCSDIR%%/examples/ppp/data
%%DOCSDIR%%/examples/ppp/gprs
%%DOCSDIR%%/examples/ppp/startppp
%%DOCSDIR%%/examples/ppp/statsppp
%%DOCSDIR%%/examples/ring/axelf.txt
%%DOCSDIR%%/examples/media/aliens.nlm
%%DOCSDIR%%/examples/media/axelf.txt
share/gammu/gammu_cs.txt
share/gammu/gammu_de.txt
share/gammu/gammu_it.txt
@ -57,6 +57,7 @@ include/gammu/phone/nokia/nfunc.h
include/gammu/phone/nokia/nfuncold.h
include/gammu/phone/nokia/dct3/dct3comm.h
include/gammu/phone/nokia/dct3/dct3func.h
include/gammu/phone/nokia/dct3/n0650.h
include/gammu/phone/nokia/dct3/n6110.h
include/gammu/phone/nokia/dct3/n7110.h
include/gammu/phone/nokia/dct3/n9210.h
@ -64,6 +65,8 @@ include/gammu/phone/nokia/dct4/dct4func.h
include/gammu/phone/nokia/dct4/n3320.h
include/gammu/phone/nokia/dct4/n3650.h
include/gammu/phone/nokia/dct4/n6510.h
include/gammu/phone/nokia/dct4/6510cal.h
include/gammu/phone/nokia/dct4/6510file.h
include/gammu/phone/obex/obexgen.h
include/gammu/phone/symbian/mroutgen.h
include/gammu/protocol/protocol.h
@ -123,9 +126,8 @@ include/gammu/service/sms/gsmsms.h
@dirrm %%DOCSDIR%%/docs/italian
@dirrm %%DOCSDIR%%/docs
@dirrm %%DOCSDIR%%/examples/config
@dirrm %%DOCSDIR%%/examples/media
@dirrm %%DOCSDIR%%/examples/ppp
@dirrm %%DOCSDIR%%/examples/ring
@dirrm %%DOCSDIR%%/examples/logo
@dirrm %%DOCSDIR%%/examples/fax
@dirrm %%DOCSDIR%%/examples
@dirrm %%DOCSDIR%%

View File

@ -6,11 +6,10 @@
#
PORTNAME= gammu
PORTVERSION= 0.98.0
PORTVERSION= 1.00.0
PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= http://www.mwiacek.com/zips/gsm/gammu/older/ \
http://www.kirill.spb.ru/gammu/
MASTER_SITES= http://www.kirill.spb.ru/gammu/
MAINTAINER= kirill@solaris.ru
COMMENT= GNU All Mobile Management Utilities
@ -19,7 +18,7 @@ MAN1= gammu.1
USE_GMAKE= yes
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
WANT_AUTOCONF_VER=253
WANT_AUTOCONF_VER=259
CONFIGURE_ARGS= --disable-bluerfsearch
CONFIGURE_ENV= CFLAGS="${CFLAGS} -fPIC"

View File

@ -1,2 +1,2 @@
MD5 (gammu-0.98.0.tar.gz) = 6abfb95af979ce283fb22a179476dc6a
SIZE (gammu-0.98.0.tar.gz) = 813856
MD5 (gammu-1.00.0.tar.gz) = 9d921f9c5b6f3b8b76a69720e2d9f173
SIZE (gammu-1.00.0.tar.gz) = 850872

View File

@ -1,15 +1,15 @@
--- cfg/Makefile.glo.orig Mon Jul 26 04:01:32 2004
+++ cfg/Makefile.glo Wed Mar 2 10:42:01 2005
@@ -102,7 +102,7 @@
--- cfg/Makefile.glo.orig Sat Jan 15 17:01:28 2005
+++ cfg/Makefile.glo Thu Mar 24 13:13:31 2005
@@ -122,7 +122,7 @@
@echo Making $<
@$(CC) -c $(CFLAGS) -I$(TOPDIR)/common/ $(CPPFLAGS) $(<) -o $(@)
@$(CC) -c $(CFLAGS) -I$(TOPDIR)/common/ $(CPPFLAGS) $*.c -o $*.o
-all: gammu
+all: gammu shared
$(TOPDIR)/gammu/gammu: $(COMMON) $(GAMMU)
@echo Linking gammu
@@ -203,7 +203,7 @@
@@ -227,7 +227,7 @@
@$(INSTALL) -m 0644 $(TOPDIR)/docs/docs/english/gammu.1 $(DESTDIR)$(INSTALL_MAN_DIR)
@$(RM) $(DESTDIR)$(INSTALL_DOC_DIR)/docs/english/gammu.1
@ -18,7 +18,7 @@
installonly: all
@echo Installing binaries to $(DESTDIR)$(INSTALL_BIN_DIR)
@@ -220,8 +220,7 @@
@@ -244,8 +244,7 @@
@echo Installing shared library to $(DESTDIR)$(INSTALL_LIB_DIR)
@$(INSTALL) -m 0755 -d $(DESTDIR)$(INSTALL_LIB_DIR)
@ -28,7 +28,7 @@
@$(LN) -s libGammu.so.$(SONAME_MAJOR) $(DESTDIR)$(INSTALL_LIB_DIR)/libGammu.so
@echo Installing static library to $(DESTDIR)$(INSTALL_LIB_DIR)
@@ -240,8 +239,8 @@
@@ -264,8 +263,8 @@
@$(INSTALL) -m 0644 cfg/config.h $(DESTDIR)$(INSTALL_H_DIR)/config.h
@echo Installing pkgconfig file

View File

@ -1,18 +0,0 @@
--- common/device/serial/ser_unx.c.orig Fri Aug 13 12:10:45 2004
+++ common/device/serial/ser_unx.c Fri Nov 26 16:25:16 2004
@@ -230,6 +230,7 @@
case 57600: speed2 = B57600; break;
case 115200: speed2 = B115200; break;
case 230400: speed2 = B230400; break;
+#ifdef B460800
case 460800: speed2 = B460800; break;
#ifdef B500000
case 500000: speed2 = B500000; break;
@@ -243,6 +244,7 @@
case 3000000: speed2 = B3000000; break;
case 3500000: speed2 = B3500000; break;
case 4000000: speed2 = B4000000; break;
+#endif
#endif
#endif
}

View File

@ -1,25 +1,27 @@
--- cfg/autoconf/configure.in.orig Thu Nov 25 13:02:35 2004
+++ cfg/autoconf/configure.in Thu Nov 25 13:01:56 2004
@@ -163,14 +163,14 @@
dnl Bluetooth stacks
gsm_blue_stack=unknown
AC_CHECK_HEADERS(bluetooth/bluetooth.h,
- [gsm_blue_stack=Bluez
+ [gsm_blue_stack=FreeBSD
AC_DEFINE(GSM_ENABLE_BLUEZ)
- LDLIBS="$LDLIBS -lbluetooth -lsdp"])
+ LDLIBS="$LDLIBS -lbluetooth"])
-dnl Path for Bluez bluetooth library
+dnl Path for FreeBSD bluetooth library
gsm_bt_dir=""
AC_ARG_WITH(bluedir,
- [ --with-bluedir=DIR Specifies the base libbluetooth from Bluez],
+ [ --with-bluedir=DIR Specifies the base libbluetooth from FreeBSD],
[ if test x$withval = xyes; then
AC_MSG_WARN(Usage is: --with-bluedir=DIR)
else
@@ -261,7 +261,7 @@
--- cfg/autoconf/configure.in.orig Sat Jan 15 13:45:26 2005
+++ cfg/autoconf/configure.in Thu Apr 14 08:27:47 2005
@@ -185,17 +185,17 @@
fi
if test "$gsm_blue_stack" = unknown ; then
AC_CHECK_HEADERS(bluetooth/bluetooth.h,
- [gsm_blue_stack=Bluez
+ [gsm_blue_stack=FreeBSD
LDLIBS="$LDLIBS -lbluetooth"
AC_CHECK_LIB(sdp, sdp_list_append, LDLIBS="$LDLIBS -lsdp")
AC_DEFINE(GSM_ENABLE_BLUEZ)
])
fi
- dnl Path for Bluez bluetooth library
+ dnl Path for FreeBSD bluetooth library
gsm_bt_dir=""
AC_ARG_WITH(bluedir,
- [ --with-bluedir=DIR Specifies the base libbluetooth from Bluez],
+ [ --with-bluedir=DIR Specifies the base libbluetooth from FreeBSD],
[ if test x$withval = xyes; then
AC_MSG_WARN(Usage is: --with-bluedir=DIR)
else
@@ -287,7 +287,7 @@
[ --disable-bluefbus Disable Nokia FBUS2 over Bluetooth stack
(Nokia 6210)],
[gsm_enable_bluefbus2="no"],
@ -28,7 +30,7 @@
AC_DEFINE(GSM_ENABLE_BLUEFBUS2)
gsm_enable_bluefbus2="yes"
else
@@ -271,7 +271,7 @@
@@ -297,7 +297,7 @@
[ --disable-bluephonet Disable Nokia PHONET FBUS over Bluetooth
stack (all new Nokias)],
[gsm_enable_bluephonet="no"],
@ -37,7 +39,7 @@
AC_DEFINE(GSM_ENABLE_BLUEPHONET)
gsm_enable_bluephonet="yes"
else
@@ -280,7 +280,7 @@
@@ -306,7 +306,7 @@
AC_ARG_ENABLE(blueat,
[ --disable-blueat Disable AT commands over Bluetooth stack],
[gsm_enable_blueat="no"],
@ -46,7 +48,7 @@
AC_DEFINE(GSM_ENABLE_BLUEAT)
gsm_enable_blueat="yes"
else
@@ -289,7 +289,7 @@
@@ -315,7 +315,7 @@
AC_ARG_ENABLE(blueobex,
[ --disable-blueobex Disable OBEX over Bluetooth stack],
[gsm_enable_blueobex="no"],
@ -55,7 +57,7 @@
AC_DEFINE(GSM_ENABLE_BLUEOBEX)
gsm_enable_blueobex="yes"
else
@@ -408,7 +408,7 @@
@@ -438,7 +438,7 @@
Binaries - $bindir
RPM making directory - $RPM_DIR
Temporary directory - $TEMP_DIR

View File

@ -6,18 +6,18 @@ bin/gammu
%%DOCSDIR%%/docs/english/replace.txt
%%DOCSDIR%%/docs/italian/gammu.txt
%%DOCSDIR%%/docs/italian/readme.txt
%%DOCSDIR%%/examples/gammu.png
%%DOCSDIR%%/docs/gammu.png
%%DOCSDIR%%/examples/config/gammurc
%%DOCSDIR%%/examples/config/smsd_mysql.sql
%%DOCSDIR%%/examples/config/smsdrc
%%DOCSDIR%%/examples/config/mysql.sql
%%DOCSDIR%%/examples/fax/faxreceive
%%DOCSDIR%%/examples/fax/faxsend
%%DOCSDIR%%/examples/logo/greatings.nlm
%%DOCSDIR%%/examples/ppp/data
%%DOCSDIR%%/examples/ppp/gprs
%%DOCSDIR%%/examples/ppp/startppp
%%DOCSDIR%%/examples/ppp/statsppp
%%DOCSDIR%%/examples/ring/axelf.txt
%%DOCSDIR%%/examples/media/aliens.nlm
%%DOCSDIR%%/examples/media/axelf.txt
share/gammu/gammu_cs.txt
share/gammu/gammu_de.txt
share/gammu/gammu_it.txt
@ -57,6 +57,7 @@ include/gammu/phone/nokia/nfunc.h
include/gammu/phone/nokia/nfuncold.h
include/gammu/phone/nokia/dct3/dct3comm.h
include/gammu/phone/nokia/dct3/dct3func.h
include/gammu/phone/nokia/dct3/n0650.h
include/gammu/phone/nokia/dct3/n6110.h
include/gammu/phone/nokia/dct3/n7110.h
include/gammu/phone/nokia/dct3/n9210.h
@ -64,6 +65,8 @@ include/gammu/phone/nokia/dct4/dct4func.h
include/gammu/phone/nokia/dct4/n3320.h
include/gammu/phone/nokia/dct4/n3650.h
include/gammu/phone/nokia/dct4/n6510.h
include/gammu/phone/nokia/dct4/6510cal.h
include/gammu/phone/nokia/dct4/6510file.h
include/gammu/phone/obex/obexgen.h
include/gammu/phone/symbian/mroutgen.h
include/gammu/protocol/protocol.h
@ -123,9 +126,8 @@ include/gammu/service/sms/gsmsms.h
@dirrm %%DOCSDIR%%/docs/italian
@dirrm %%DOCSDIR%%/docs
@dirrm %%DOCSDIR%%/examples/config
@dirrm %%DOCSDIR%%/examples/media
@dirrm %%DOCSDIR%%/examples/ppp
@dirrm %%DOCSDIR%%/examples/ring
@dirrm %%DOCSDIR%%/examples/logo
@dirrm %%DOCSDIR%%/examples/fax
@dirrm %%DOCSDIR%%/examples
@dirrm %%DOCSDIR%%