Import of pmars version 0.8

A portable corewar system with ICWS'94 extensions.

PR:		10104
Submitted by:	Gianmarco Giovannelli <gmarco@giovannelli.it>
This commit is contained in:
Steve Price 1999-04-02 04:10:14 +00:00
parent af02358e3d
commit 6a42820fe3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=17544
6 changed files with 94 additions and 0 deletions

41
games/pmars/Makefile Normal file
View File

@ -0,0 +1,41 @@
# New ports collection makefile for: games/pmars
# Version required: pmars v0.8
# Date created: 15 Feb 1999
# Whom: gmarco@scotty.masternet.it
#
# $Id$
#
DISTNAME= pmars08s
PKGNAME= pmars-0.8
CATEGORIES= games
MASTER_SITES= http://www.koth.org/pmars/ \
http://www.giovannelli.it/~gmarco/files/
EXTRACT_SUFX= .tar.Z
MAINTAINER= freebsd@scotty.masternet.it
USE_XLIB= yes
NO_WRKSUBDIR= yes
MAKEFILE= makefile
MAN6= pmars.6
do-install:
@${MKDIR} ${PREFIX}/share/games
@${MKDIR} ${PREFIX}/share/games/corewars
@${INSTALL_PROGRAM} ${WRKSRC}/pmars ${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/pmars.6 ${PREFIX}/man/man6
@${INSTALL_DATA} ${WRKSRC}/*.red ${PREFIX}/share/games/corewars
@${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/games/corewars
@${ECHO_MSG} ""
@${ECHO_MSG} "You can try something like :"
@${ECHO_MSG} "pmars -v 603 ${PREFIX}/share/games/corewars/rave.red ${PREFIX}/share/games/corewars/aeka.red"
@${ECHO_MSG} "to see how the simulator works (rave.red and aeka.red are two sample warriors)"
@${ECHO_MSG} ""
@${ECHO_MSG} "Some other warriors are installed in : ${PREFIX}/share/games/corewars"
@${ECHO_MSG} ""
@${ECHO_MSG} "Plase read also ${PREFIX}/share/games/corewars/README file for more infos"
@${ECHO_MSG} "on corewars and on the current version of pmars"
@${ECHO_MSG} ""
.include <bsd.port.mk>

1
games/pmars/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (pmars08s.tar.Z) = ad1869ea0a388f5c5070c4cd33b09d25

View File

@ -0,0 +1,25 @@
--- makefile.orig Mon Feb 15 17:07:29 1999
+++ makefile Mon Feb 15 17:07:39 1999
@@ -15,11 +15,11 @@
# (5) -DSMALLMEM 16-bit addresses, less memory
# (6) -DXWINGRAPHX 1 X-Windows graphics (UNIX)
-CFLAGS = -O -DEXT94
+CFLAGS = -O -I/usr/X11R6/include -DEXT94 -DGRAPHX -DXWINGRAPHX
LFLAGS = -x
LIB = -lcurses -ltermlib # enable this one for curses display
# LIB = -lvgagl -lvga # enable this one for Linux/SVGA
-# LIB = -lX11 # enable this one for X11
+LIB = -L/usr/X11R6/lib -lX11 # enable this one for X11
.SUFFIXES: .o .c .c~ .man .doc .6
MAINFILE = pmars
@@ -30,7 +30,7 @@
OBJ2 = clparse.o global.o token.o
OBJ3 = str_eng.o
-ALL: flags $(MAINFILE) man doc
+all: flags $(MAINFILE) man doc
flags:
@echo Making $(MAINFILE) with compiler flags $(CFLAGS)

1
games/pmars/pkg-comment Normal file
View File

@ -0,0 +1 @@
A portable corewar system with ICWS'94 extensions.

18
games/pmars/pkg-descr Normal file
View File

@ -0,0 +1,18 @@
pMARS (portable Memory Array Redcode Simulator) is a corewar
interpreter with multi-platform support.
pMARS implements the ICWS'94 draft standard, but can also be
used in ICWS'88 mode.
The base system includes a graphical core display for UNIX (curses,
X11 and Linux svgalib), PC/DOS, and the Mac.
A line-oriented debugger is included to help in writing warriors.
Contributors:
* Albert Ma (ama@mit.edu)
* Na'ndor Sieben (sieben@imap1.asu.edu)
* Stefan Strack (stst@vuse.vanderbilt.edu)
* Mintardjo Wangsawidjaja (wangsawm@kira.csos.orst.edu)
distfile: pmars08s.tar.Z (about 220kb)
home page: http://www.koth.org/pmars
- ported to FreeBSD by Gianmarco (gmarco@giovannelli.it)

8
games/pmars/pkg-plist Normal file
View File

@ -0,0 +1,8 @@
bin/pmars
share/games/corewars/aeka.red
share/games/corewars/pspace.red
share/games/corewars/validate.red
share/games/corewars/rave.red
share/games/corewars/flashpaper.red
share/games/corewars/README
@dirrm share/games/corewars