- Remove ports-mgmt/pver as it does not support pkgng

This commit is contained in:
Ryan Steinmetz 2014-05-11 18:53:23 +00:00
parent 859b330d29
commit 6a34a8319b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=353725
8 changed files with 1 additions and 111 deletions

1
MOVED
View File

@ -6097,3 +6097,4 @@ sysutils/lire||2014-05-11|Project is dead
net/ipfw-graph||2014-05-11|Project is dead
java/linux-sun-jre16||2014-05-11|Has expired: Unsupported and known for multiple security vulnerabilities
java/linux-sun-jdk16||2014-05-11|Has expired: Unsupported and known for multiple security vulnerabilities
ports-mgmt/pver||2014-05-11|Has expired: does not support pkgng

View File

@ -77,7 +77,6 @@
SUBDIR += poudriere-devel
SUBDIR += prhistory
SUBDIR += psearch
SUBDIR += pver
SUBDIR += symports
SUBDIR += tinderbox
SUBDIR += tinderbox-devel

View File

@ -1,56 +0,0 @@
# Created by: Wei-Yu Chen <weiyu@alpha3.cs.nthu.edu.tw>
# $FreeBSD$
PORTNAME= pver
PORTVERSION= 0.16
CATEGORIES= ports-mgmt
MASTER_SITES= http://www.csie.nctu.edu.tw/~weiyu/software/ \
${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= zi@FreeBSD.org
COMMENT= Show packages which are different version from ports using INDEX-*.db
OPTIONS_DEFINE= SORT DB185
SORT_DESC= Sort the result by the package names
DB185_DESC= Use BerkeleyDB 1.85/1.86
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ARGS+= PORTSDIR=${PORTSDIR}
MAKE_JOBS_UNSAFE=yes
DEPRECATED= Not compatible with pkgNG
EXPIRATION_DATE=2014-09-01
PLIST_FILES= bin/pver \
bin/pver_c \
bin/pver_dbgen \
bin/wpver \
%%DATADIR%%/LICENSE.txt
PLIST_DIRS= %%DATADIR%%
NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MSORT}
MAKE_ARGS+= -DSORT
.endif
.if ${PORT_OPTIONS:MDB185}
MAKE_ARGS+= -DBSD_DB
.else
USE_BDB= 41+
MAKE_ARGS+= BDB_VER=${BDB_VER} BDB_LIB_DIR=${BDB_LIB_DIR}
.endif
.if defined(INDEX_DB_FILE)
MAKE_ARGS+= INDEX_DB_FILE=${INDEX_DB_FILE}
.endif
post-install:
${MKDIR} ${DATADIR}
${INSTALL} ${WRKSRC}/LICENSE.txt ${DATADIR}
@${CAT} ${PKGMESSAGE} | ${SED} -e 's|PORTSDIR|${PORTSDIR}|g' \
-e 's|__FreeBSD__|${OSREL:C/.[0-9]//}|g' ${PKGDIR}/pkg-message
.include <bsd.port.post.mk>

View File

@ -1,2 +0,0 @@
SHA256 (pver-0.16.tar.gz) = 683528f8426a3489707a3c76321ccc6bd5a61c9902fb5eede003213b8dd2b60d
SIZE (pver-0.16.tar.gz) = 6598

View File

@ -1,18 +0,0 @@
--- ./pver.c.orig 2009-04-05 18:35:40.000000000 +0200
+++ ./pver.c 2011-05-26 12:00:10.000000000 +0200
@@ -78,12 +78,14 @@
char *data_sp;
char *show_p;
char *p1, *p2;
+ int w;
/**
* show_p: dp->d_name 's c-string version
* data_p: data.data 's c-string version
*/
asprintf(&show_p, "%.*s", dp->d_namlen, dp->d_name);
- asprintf(&data_p, "%.*s", data.DU_LEN, (const char *)data.DU_DATA);
+ w = data.DU_LEN > INT_MAX ? INT_MAX : data.DU_LEN;
+ asprintf(&data_p, "%.*s", w, (const char *)data.DU_DATA);
/**
* If string data_p contains |, data_p is terminated at |

View File

@ -1,13 +0,0 @@
--- ./pver_c.c.orig 2009-02-21 09:05:36.000000000 +0100
+++ ./pver_c.c 2011-05-26 12:00:10.000000000 +0200
@@ -7,7 +7,9 @@
#include "config.h"
int show_key(DBI_UNIT *key) {
- printf("%d %.*s\n", key->DU_LEN, key->DU_LEN, (const char *)key->DU_DATA);
+ int w;
+ w = key->DU_LEN > INT_MAX ? INT_MAX : key->DU_LEN;
+ printf("%lu %.*s\n", (unsigned long)key->DU_LEN, w, (const char *)key->DU_DATA);
return 0;
}

View File

@ -1,7 +0,0 @@
A simple utility to show the package name and version
whose port version is different from it.
The utility uses /usr/ports/INDEX-{__FreeBSD__}.db
The file can be generated by using bundled pver_dbgen
WWW: http://www.csie.nctu.edu.tw/~weiyu/#msgbox=page/program.html

View File

@ -1,14 +0,0 @@
===================================================================================
PORTSDIR/INDEX-__FreeBSD__.db is usually generated by ports-mgmt/portupgrade
However, you can use the tool 'pver_dbgen' to generate/update it
> sudo pver_dbgen
The tool use PORTSDIR/INDEX-__FreeBSD__ to generate db file
Then you can show the packages whose port version and package version is different
by typing 'pver'
> pver
===================================================================================