add bibtool 2.48

Command line manipulation of BibTeX files

PR:		88455
Submitted by:	rafan@infor.org
This commit is contained in:
Ying-Chieh Liao 2005-11-04 05:40:12 +00:00
parent 8441d0fd82
commit 69ddbe18a4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=147184
8 changed files with 146 additions and 0 deletions

View File

@ -26,6 +26,7 @@
SUBDIR += bg-aspell
SUBDIR += bib2html
SUBDIR += bibtex2html
SUBDIR += bibtool
SUBDIR += bidiv
SUBDIR += bn-aspell
SUBDIR += br-aspell

45
textproc/bibtool/Makefile Normal file
View File

@ -0,0 +1,45 @@
# New ports collection makefile for: bibtool
# Date created: Oct 10, 2005
# Whom: Rong-En Fan <rafan@infor.org>
#
# $FreeBSD$
#
PORTNAME= bibtool
PORTVERSION= 2.48
CATEGORIES= textproc print
MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= biblio/bibtex/utils/${PORTNAME}
DISTNAME= BibTool-${PORTVERSION}
MAINTAINER= rafan@infor.org
COMMENT= Command line manipulation of BibTeX files
BUILD_DEPENDS= ${LOCALBASE}/include/kpathsea/tex-file.h:${PORTSDIR}/print/teTeX-base
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-kpathsea
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
MAKEFILE= makefile
INSTALL_TARGET= install install.man
MAN1= bibtool.1
TXT_DOCS= Doc/bibtool.dvi Doc/ref_card.dvi Doc/c_lib.dvi
.if !defined(NOPORTDOCS)
PORTDOCS= ${TXT_DOCS:S/^Doc\///}
.endif
.include <bsd.port.pre.mk>
post-install:
.if !defined(NOPORTDOCS)
cd ${WRKSRC} && ${MAKE} doc && ${MAKE} doc
${MKDIR} ${DOCSDIR}
for f in ${TXT_DOCS}; do \
${INSTALL_MAN} ${WRKSRC}/$$f ${DOCSDIR}; \
done
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,2 @@
MD5 (BibTool-2.48.tar.gz) = 20ebb18ea55e5f64b67f5b8edaa0d6fa
SIZE (BibTool-2.48.tar.gz) = 634267

View File

@ -0,0 +1,20 @@
--- configure.orig Sun Feb 8 17:35:23 2004
+++ configure Wed Nov 2 16:45:08 2005
@@ -4566,12 +4566,12 @@
kpathsea_dir=
kpathsea_lib=
kpathsea_def=
- for cand in .. ../kpse3-2 kpse3-2 .
+ for cand in ${LOCALBASE}
do
- if test -f $cand/kpathsea/tex-file.h ; then
- kpathsea_dir=$cand
- kpathsea_lib=$cand/kpathsea/STATIC/libkpathsea.a
- kpathsea_def="-DHAVE_LIBKPATHSEA -I$cand"
+ if test -f $cand/include/kpathsea/tex-file.h ; then
+ kpathsea_dir=$cand/include
+ kpathsea_lib=$cand/lib/libkpathsea.a
+ kpathsea_def="-DHAVE_LIBKPATHSEA -I$cand/include"
fi
done
if test -z "$kpathsea_dir"; then

View File

@ -0,0 +1,20 @@
--- main.c.orig Wed Nov 2 16:45:23 2005
+++ main.c Wed Nov 2 16:47:22 2005
@@ -331,17 +331,6 @@
/*-----------------------------------------------------------------------------
-** Function: true()
-** Type: static int
-** Purpose:
-**
-** Arguments:
-**
-** Returns:
-**___________________________________________________ */
-static int true() { return TRUE; }
-
-/*-----------------------------------------------------------------------------
** Function: keep_selected()
** Type: static int
** Purpose:

View File

@ -0,0 +1,29 @@
--- AutoConf/makefile.in.orig Sun Feb 8 17:46:11 2004
+++ AutoConf/makefile.in Wed Nov 2 17:05:33 2005
@@ -67,7 +67,7 @@
# Name the C compiler
#
-CC = @CC@
+CC ?= @CC@
# -------------------------------------------------------
# CFLAGS are the flags for the C compiler.
@@ -78,7 +78,7 @@
# optimizer is turned on.
#
-CFLAGS =
+CFLAGS += -DHAVE_PROTOTYPES
# CFLAGS = -O
# GNU C
# CFLAGS = -g -Wall
@@ -461,7 +461,7 @@
# Targets from the GNU Regular Expression Library.
regex$(OBJ): $(REGEX_DIR)$(DIR_SEP)regex.c $(MAKEFILE)
- $(CC) $(C_FLAGS) -I$(REGEX_DIR) -I.. $(NON_ANSI_DEFS) $(REGEX_DIR)$(DIR_SEP)regex.c $(DONT_LINK) -o $@
+ $(CC) $(C_FLAGS) -DSTDC_HEADERS -I$(REGEX_DIR) -I.. $(NON_ANSI_DEFS) $(REGEX_DIR)$(DIR_SEP)regex.c $(DONT_LINK) -o $@
bibtcl:

View File

@ -0,0 +1,17 @@
Command line manipulation of BibTeX files:
* Pretty-printing data bases
* Syntactic checks with error recovery
* Semantic checks
* Sorting and merging of data bases
* Generation of uniform reference keys according to predefined rules or
according to user specification
* Selecting references used in one publication which are found by
analyzing an aux file
* Controlled rewriting of fields utilising regular expressions to specify
the rewriting rules
* Macro (String) expansion to eliminate the need of extra string
definitions
* Collecting statistics about one or more data bases
WWW: http://www.ctan.org/tex-archive/biblio/bibtex/utils/bibtool/

View File

@ -0,0 +1,12 @@
bin/bibtool
lib/BibTool/braces.rsc
lib/BibTool/check_y.rsc
lib/BibTool/default.rsc
lib/BibTool/field.rsc
lib/BibTool/improve.rsc
lib/BibTool/iso2tex.rsc
lib/BibTool/month.rsc
lib/BibTool/opt.rsc
lib/BibTool/sort_fld.rsc
lib/BibTool/tex_def.rsc
@dirrm lib/BibTool