OpenCVS is a FREE implementation of the Concurrent Versions System, the most

popular open source revision control software. It can be used as both client
and server for repositories and provides granular access control over data
stored in the repository. It aims to be as compatible as possible with other
CVS implementations, except when particular features reduce the overall
security of the system.

WWW: http://www.opencvs.org/

This port was requested by rdivacky@, who created the dist patches for
OpenCVS.
This commit is contained in:
Gabor Kovesdan 2008-11-01 18:43:36 +00:00
parent b17d51b0d4
commit 69d5c43463
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=222279
30 changed files with 352 additions and 0 deletions

View File

@ -888,6 +888,7 @@
SUBDIR += oniguruma
SUBDIR += oniguruma4
SUBDIR += open-beagle
SUBDIR += opencvs
SUBDIR += openwince-include
SUBDIR += openzz
SUBDIR += orbitcpp

27
devel/opencvs/Makefile Normal file
View File

@ -0,0 +1,27 @@
# New ports collection makefile for: opencvs
# Date created: 1 November 2008
# Whom: Gabor Kovesdan <gabor@FreeBSD.org>
#
# $FreeBSD$
PORTNAME= opencvs
PORTVERSION= 20081101
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= gabor
MAINTAINER= gabor@FreeBSD.org
COMMENT= BSD-licensed CVS implementation
WRKSRC= ${WRKDIR}/cvs
MANCOMPRESSED= maybe
MAN7= cvsintro.7
MAKE_ENV+= BINDIR="${PREFIX}/bin" \
MANDIR="${MANPREFIX}/man/man" \
CATDIR="${MANPREFIX}/man/man"
PLIST_FILES= bin/opencvs
.include <bsd.port.mk>

3
devel/opencvs/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (opencvs-20081101.tar.gz) = c62341da9e79a5fe30063003df9c68ae
SHA256 (opencvs-20081101.tar.gz) = c6397493fc480dddbd70b47e99f31f6147a0f35f7b2be85773e78460122d5929
SIZE (opencvs-20081101.tar.gz) = 160631

View File

@ -0,0 +1,19 @@
--- Makefile 2008-06-21 17:39:15.000000000 +0200
+++ Makefile 2008-11-01 14:42:14.000000000 +0100
@@ -12,14 +12,7 @@
server.c status.c tag.c trigger.c worklist.c util.c update.c version.c \
watch.c xmalloc.c
-CFLAGS+=-Wall
-CFLAGS+=-Wstrict-prototypes -Wmissing-prototypes
-CFLAGS+=-Wmissing-declarations
-CFLAGS+=-Wshadow -Wpointer-arith -Wcast-qual
-CFLAGS+=-Wsign-compare
-DEBUG= -g -ggdb
-YFLAGS=
-
-INSTALL_STRIP=
+DPADD+= ${LIBZ}
+LDADD+= -lz -lmd
.include <bsd.prog.mk>

View File

@ -0,0 +1,10 @@
--- admin.c 12 Sep 2008 13:20:36 -0000 1.64
+++ admin.c 17 Oct 2008 08:51:45 -0000
@@ -24,6 +24,7 @@
#include <fcntl.h>
#include <libgen.h>
#include <string.h>
+#include <time.h>
#include <unistd.h>
#include "cvs.h"

View File

@ -0,0 +1,20 @@
--- atomicio.h 17 Sep 2007 10:07:21 -0000 1.1
+++ atomicio.h 17 Oct 2008 08:51:45 -0000
@@ -1,4 +1,4 @@
-/* $OpenBSD: atomicio.h,v 1.1 2007/09/17 10:07:21 tobias Exp $ */
+/* $OpenBSD: atomicio.h,v 1.10 2006/08/03 03:34:41 deraadt Exp $ */
/*
* Copyright (c) 2006 Damien Miller. All rights reserved.
@@ -35,5 +35,11 @@
size_t atomicio(ssize_t (*)(int, void *, size_t), int, void *, size_t);
#define vwrite (ssize_t (*)(int, void *, size_t))write
+
+/*
+ * ensure all of data on socket comes through. f==readv || f==writev
+ */
+size_t atomiciov(ssize_t (*)(int, const struct iovec *, int),
+ int, const struct iovec *, int);
#endif /* _ATOMICIO_H */

View File

@ -0,0 +1,11 @@
--- checkout.c 8 Jul 2008 12:29:58 -0000 1.156
+++ checkout.c 17 Oct 2008 08:51:45 -0000
@@ -352,6 +352,7 @@
xfree(module_repo_root);
}
+#define TAILQ_END(head) NULL
if (mc->mc_canfree == 1) {
for (fl = TAILQ_FIRST(&(mc->mc_modules));
fl != TAILQ_END(&(mc->mc_modules)); fl = nxt) {

View File

@ -0,0 +1,11 @@
--- cmd.c 3 Feb 2008 18:18:44 -0000 1.68
+++ cmd.c 17 Oct 2008 08:51:45 -0000
@@ -27,6 +27,7 @@
#include <sys/dirent.h>
#include <string.h>
+#include <time.h>
#include "cvs.h"

View File

@ -0,0 +1,11 @@
--- config.c 2 Mar 2008 11:58:45 -0000 1.15
+++ config.c 17 Oct 2008 08:51:45 -0000
@@ -23,6 +23,7 @@
#include <limits.h>
#include <stdlib.h>
#include <string.h>
+#include <time.h>
#include "cvs.h"
#include "config.h"

View File

@ -0,0 +1,21 @@
--- cvs.c 21 Jun 2008 15:39:15 -0000 1.150
+++ cvs.c 17 Oct 2008 08:51:45 -0000
@@ -70,7 +70,7 @@
struct cvs_cmd *cmdp; /* struct of command we are running */
int cvs_getopt(int, char **);
-__dead void usage(void);
+void usage(void);
static void cvs_read_rcfile(void);
struct cvs_wklhead temp_files;
@@ -122,7 +122,7 @@
cvs_ent_close(current_list, ENT_SYNC);
}
-__dead void
+void
usage(void)
{
(void)fprintf(stderr,

View File

@ -0,0 +1,10 @@
--- cvs.h 27 Jun 2008 21:14:15 -0000 1.172
+++ cvs.h 17 Oct 2008 08:51:45 -0000
@@ -433,5 +433,6 @@
int cvs_watch(int, char **);
int cvs_watchers(int, char **);
+#define SIZE_MAX ULONG_MAX
#endif

View File

@ -0,0 +1,11 @@
--- date.y 16 Feb 2008 01:00:00 -0000 1.18
+++ date.y 17 Oct 2008 08:51:45 -0000
@@ -14,6 +14,7 @@
/* SUPPRESS 287 on yaccpar_sccsid *//* Unused static variable */
/* SUPPRESS 288 on yyerrlab *//* Label unused */
+#include <time.h>
#include <sys/timeb.h>
#include <ctype.h>

View File

@ -0,0 +1,11 @@
--- diff3.c 9 Mar 2008 01:52:55 -0000 1.48
+++ diff3.c 17 Oct 2008 08:51:45 -0000
@@ -81,6 +81,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
+#include <time.h>
#include <unistd.h>
#include "atomicio.h"

View File

@ -0,0 +1,11 @@
--- getlog.c 12 Sep 2008 13:38:35 -0000 1.90
+++ getlog.c 17 Oct 2008 08:51:45 -0000
@@ -19,6 +19,7 @@
#include <unistd.h>
#include <string.h>
#include <errno.h>
+#include <time.h>
#include "cvs.h"
#include "remote.h"

View File

@ -0,0 +1,11 @@
--- hash.c 21 Jun 2008 15:39:15 -0000 1.1
+++ hash.c 17 Oct 2008 08:51:45 -0000
@@ -21,6 +21,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
+#include <time.h>
#include "cvs.h"
#include "hash.h"

View File

@ -0,0 +1,11 @@
--- log.c 12 Jun 2008 16:53:12 -0000 1.45
+++ log.c 17 Oct 2008 08:51:45 -0000
@@ -27,6 +27,7 @@
#include <errno.h>
#include <string.h>
+#include <time.h>
#include "cvs.h"

View File

@ -0,0 +1,11 @@
--- log.h 10 Jun 2008 01:00:34 -0000 1.23
+++ log.h 17 Oct 2008 08:51:46 -0000
@@ -47,6 +47,6 @@
void cvs_vlog(u_int, const char *, va_list);
int cvs_printf(const char *, ...) __attribute__((format(printf, 1, 2)));
int cvs_vprintf(const char *, va_list);
-void fatal(const char *, ...) __dead __attribute__((format(printf, 1,2)));
+void fatal(const char *, ...) __attribute__((format(printf, 1,2)));
#endif /* LOG_H */

View File

@ -0,0 +1,10 @@
--- modules.c 8 Mar 2008 21:58:34 -0000 1.13
+++ modules.c 17 Oct 2008 08:51:46 -0000
@@ -22,6 +22,7 @@
#include <ctype.h>
#include <stdlib.h>
#include <string.h>
+#include <time.h>
#include "cvs.h"
#include "config.h"

View File

@ -0,0 +1,11 @@
--- rcsnum.c 22 May 2008 07:03:02 -0000 1.53
+++ rcsnum.c 17 Oct 2008 08:51:46 -0000
@@ -26,6 +26,7 @@
#include <ctype.h>
#include <string.h>
+#include <time.h>
#include "cvs.h"

View File

@ -0,0 +1,11 @@
--- remove.c 23 Jun 2008 20:51:08 -0000 1.79
+++ remove.c 17 Oct 2008 08:51:46 -0000
@@ -17,6 +17,7 @@
#include <errno.h>
#include <string.h>
+#include <time.h>
#include <unistd.h>
#include "cvs.h"

View File

@ -0,0 +1,11 @@
--- root.c 20 Jun 2008 23:00:13 -0000 1.45
+++ root.c 17 Oct 2008 08:51:46 -0000
@@ -27,6 +27,7 @@
#include <errno.h>
#include <stdlib.h>
#include <string.h>
+#include <time.h>
#include "cvs.h"

View File

@ -0,0 +1,11 @@
--- tag.c 20 Jun 2008 14:04:29 -0000 1.76
+++ tag.c 17 Oct 2008 08:51:46 -0000
@@ -17,6 +17,7 @@
#include <errno.h>
#include <string.h>
+#include <time.h>
#include <unistd.h>
#include "cvs.h"

View File

@ -0,0 +1,11 @@
--- trigger.c 29 Aug 2008 09:51:21 -0000 1.16
+++ trigger.c 17 Oct 2008 08:51:46 -0000
@@ -27,6 +27,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
+#include <time.h>
#include <unistd.h>
#include "config.h"

View File

@ -0,0 +1,12 @@
--- util.c 21 Jun 2008 15:39:15 -0000 1.147
+++ util.c 17 Oct 2008 08:51:46 -0000
@@ -30,7 +30,7 @@
#include <sys/types.h>
#include <sys/wait.h>
-#include <atomicio.h>
+#include "atomicio.h"
#include <errno.h>
#include <fcntl.h>
#include <md5.h>

View File

@ -0,0 +1,12 @@
--- version.c 2 May 2007 16:26:50 -0000 1.25
+++ version.c 17 Oct 2008 08:51:46 -0000
@@ -16,6 +16,8 @@
* OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
*/
+#include <time.h>
+
#include "cvs.h"
#include "remote.h"

View File

@ -0,0 +1,11 @@
--- watch.c 23 Jun 2008 20:51:08 -0000 1.21
+++ watch.c 17 Oct 2008 08:51:46 -0000
@@ -16,6 +16,7 @@
*/
#include <string.h>
+#include <time.h>
#include <unistd.h>
#include "cvs.h"

View File

@ -0,0 +1,11 @@
--- worklist.c 22 Feb 2007 06:42:10 -0000 1.6
+++ worklist.c 17 Oct 2008 08:51:46 -0000
@@ -25,6 +25,7 @@
*/
#include <string.h>
+#include <time.h>
#include <unistd.h>
#include "cvs.h"

View File

@ -0,0 +1,12 @@
--- xmalloc.c 22 Feb 2007 06:42:10 -0000 1.8
+++ xmalloc.c 17 Oct 2008 08:51:46 -0000
@@ -13,6 +13,8 @@
* called by a name other than "ssh" or "Secure Shell".
*/
+#include <sys/types.h>
+
#include <limits.h>
#include <stdio.h>
#include <stdlib.h>

View File

@ -0,0 +1,11 @@
--- xmalloc.h 29 Jan 2007 16:22:29 -0000 1.3
+++ xmalloc.h 17 Oct 2008 08:51:46 -0000
@@ -29,7 +29,6 @@
__attribute__((__nonnull__ (2)));
int xsnprintf(char *, size_t, const char *, ...)
__attribute__((__format__ (printf, 3, 4)))
- __attribute__((__nonnull__ (3)))
- __attribute__((__bounded__ (__string__,1,2)));
+ __attribute__((__nonnull__ (3)));
#endif /* XMALLOC_H */

8
devel/opencvs/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
OpenCVS is a FREE implementation of the Concurrent Versions System, the most
popular open source revision control software. It can be used as both client
and server for repositories and provides granular access control over data
stored in the repository. It aims to be as compatible as possible with other
CVS implementations, except when particular features reduce the overall
security of the system.
WWW: http://www.opencvs.org/