comms/qsstv: fix build with graphics/openjpeg 2.5 by removing unnecessary patches
While here, have ourselves a working DEBUG build
Encoding/saving JPEG2000 crashes due to graphics/jasper interaction.
Not sure if it has ever worked.
Approved by: arrowd (mentor)
Differential Revision: https://reviews.freebsd.org/D35308
(cherry picked from commit 543d8888c9
)
This commit is contained in:
parent
7f2bedd3a2
commit
698607cd81
@ -24,6 +24,18 @@ USE_GL= gl
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
PLIST_FILES= bin/qsstv \
|
||||
share/applications/qsstv.desktop \
|
||||
share/pixmaps/qsstv.png
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if defined(WITH_DEBUG)
|
||||
BUILD_DEPENDS+= doxygen:devel/doxygen
|
||||
LIB_DEPENDS+= libqwt6.so:x11-toolkits/qwt6
|
||||
PLIST_FILES+= bin/qsstv.debug
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
|
||||
-e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
|
||||
|
@ -1,6 +1,13 @@
|
||||
--- qsstv.pro.orig 2021-07-31 20:57:03 UTC
|
||||
+++ qsstv.pro
|
||||
@@ -523,7 +523,7 @@ QMAKE_EXTRA_TARGETS += dox
|
||||
@@ -517,13 +517,13 @@ contains(QMAKE_HOST.arch, arm.*):{
|
||||
|
||||
|
||||
|
||||
-dox.path=/usr/share/doc/$$TARGET
|
||||
+dox.path=%%PREFIX%%/share/doc/$$TARGET
|
||||
dox.files= $$PWD/manual/*
|
||||
QMAKE_EXTRA_TARGETS += dox
|
||||
|
||||
|
||||
isEmpty(PREFIX) {
|
||||
@ -9,3 +16,12 @@
|
||||
}
|
||||
target.path = $$PREFIX/bin
|
||||
|
||||
@@ -605,6 +605,6 @@ FORMS += scope/scopeoffset.ui \
|
||||
|
||||
FORMS += scope/scopeoffset.ui \
|
||||
scope/plotform.ui
|
||||
-INCLUDEPATH += /usr/include/qwt /usr/include/qt5/qwt
|
||||
-LIBS += -lqwt-qt5
|
||||
+INCLUDEPATH += %%PREFIX%%/include/qt5/qwt6
|
||||
+LIBS += -L%%PREFIX%%/lib/qt5 -lqwt6
|
||||
}
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- utils/color.cpp.orig 2017-11-16 17:14:48 UTC
|
||||
+++ utils/color.cpp
|
||||
@@ -41,7 +41,7 @@
|
||||
#include <math.h>
|
||||
#include <assert.h>
|
||||
|
||||
-#include "openjpeg.h"
|
||||
+#include "openjpeg-2.4/openjpeg.h"
|
||||
#include "color.h"
|
||||
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- utils/jp2io.h.orig 2016-08-23 19:39:12 UTC
|
||||
+++ utils/jp2io.h
|
||||
@@ -1,6 +1,6 @@
|
||||
#ifndef JP2READER_H
|
||||
#define JP2READER_H
|
||||
-#include "openjpeg.h"
|
||||
+#include "openjpeg-2.4/openjpeg.h"
|
||||
|
||||
#include <QString>
|
||||
#include <QImage>
|
@ -1,3 +0,0 @@
|
||||
bin/qsstv
|
||||
share/applications/qsstv.desktop
|
||||
share/pixmaps/qsstv.png
|
Loading…
Reference in New Issue
Block a user