www/mitmproxy: Unbreak at runtime
* After r511877 (initial cause, already fixed in r518596) and r516400 [1] the port was broken at runtime. Unbreak it by relaxing the version range for net/py-ldap3. Also relax the version range for devel/py-urwid which was recently updated in r519201. * Adjust the RUN_DEPENDS by making them more specific (as given in setup.py) to reduce the likelihood of runtime errors in the future. * Bump PORTREVISION due changed code. A MFH is not required as www/mitmproxy in the 2019Q4 branch isn't affected and was already fixed with r518597. PR: 242025 Reported by: ale [1] Approved by: maintainer timeout (2 weeks)
This commit is contained in:
parent
37e587487a
commit
697bc871ba
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=520286
@ -4,7 +4,7 @@
|
||||
PORTNAME= mitmproxy
|
||||
PORTVERSION= 4.0.4
|
||||
DISTVERSIONPREFIX= v
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= www python
|
||||
|
||||
MAINTAINER= gaod@hychen.org
|
||||
@ -15,22 +15,23 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=6.2:devel/py-click@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}blinker>=1.4:devel/py-blinker@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wsproto>=0.13.0:net/py-wsproto@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}certifi>=2015.11.20.1:security/py-certifi@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wsproto>=0.11.0:net/py-wsproto@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}ldap3>=2.5:net/py-ldap3@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}passlib>=1.6.5:security/py-passlib@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pyasn1>=0.3.1:devel/py-pyasn1@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pyasn1>=0.3.1<0.5:devel/py-pyasn1@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}openssl>=17.5:security/py-openssl@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pyparsing>=2.1.3:devel/py-pyparsing@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}ruamel.yaml>=0.13.2:devel/py-ruamel.yaml@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}tornado>=4.3:www/py-tornado@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}tornado>=4.3<5.2:www/py-tornado@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}urwid>=2.0.1:devel/py-urwid@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}brotli>=0.7.0:archivers/py-brotli@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}sortedcontainers>=1.5.4:devel/py-sortedcontainers@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pyperclip>=1.6.0:devel/py-pyperclip@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}hyperframe>=5.1.0:www/py-hyperframe@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}kaitaistruct>=0.7:devel/py-kaitaistruct@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}h2>=3.1.0:www/py-h2@${PY_FLAVOR}
|
||||
${PYTHON_PKGNAMEPREFIX}hyperframe>=5.1.0<6:www/py-hyperframe@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}kaitaistruct>=0.7<0.9:devel/py-kaitaistruct@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}h2>=3.0.1<4:www/py-h2@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}cryptography>=2.1.4:security/py-cryptography@${PY_FLAVOR}
|
||||
|
||||
USES= python:3.5+
|
||||
USE_PYTHON= distutils autoplist noflavors
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- setup.py.orig 2019-07-30 16:02:34 UTC
|
||||
--- setup.py.orig 2019-12-09 13:30:10 UTC
|
||||
+++ setup.py
|
||||
@@ -61,24 +61,24 @@ setup(
|
||||
# It is not considered best practice to use install_requires to pin dependencies to specific versions.
|
||||
@ -13,7 +13,8 @@
|
||||
"h2>=3.0.1,<4",
|
||||
"hyperframe>=5.1.0,<6",
|
||||
"kaitaistruct>=0.7,<0.9",
|
||||
"ldap3>=2.5,<2.6",
|
||||
- "ldap3>=2.5,<2.6",
|
||||
+ "ldap3>=2.5",
|
||||
"passlib>=1.6.5",
|
||||
"pyasn1>=0.3.1,<0.5",
|
||||
- "pyOpenSSL>=17.5,<18.1",
|
||||
@ -24,8 +25,9 @@
|
||||
- "sortedcontainers>=1.5.4,<2.1",
|
||||
+ "sortedcontainers>=1.5.4",
|
||||
"tornado>=4.3,<5.2",
|
||||
"urwid>=2.0.1,<2.1",
|
||||
- "urwid>=2.0.1,<2.1",
|
||||
- "wsproto>=0.11.0,<0.12.0",
|
||||
+ "urwid>=2.0.1",
|
||||
+ "wsproto>=0.13.0",
|
||||
],
|
||||
extras_require={
|
||||
|
Loading…
Reference in New Issue
Block a user