- Bump PORTREVISION for all previous changes

- Allow access to /home if mod_userdir is loaded
- We don't need apache2libs.sh if apr is installed from ports.
- Add recent changes to UPGRADING
This commit is contained in:
Clement Laforet 2004-08-17 12:41:26 +00:00
parent 3190699a5e
commit 696614c16d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=116513
7 changed files with 97 additions and 28 deletions

View File

@ -6,6 +6,17 @@ You should get into the habit of checking this file for changes each
time you update your ports collection, before attempting any port
upgrades.
20040817:
AFFECTS: users of www/apache2
AUTHOR: clement@FreeBSD.org
Summary of recent changes:
- Access to filesystem is denied by default.
- mod_proxy* are no longer built by default
- Now ${PREFIX}/etc/apache2/Includes/*.conf can be used to store
local configuration or sample configurations.
- Makefile.modules.3rd contains modules selection for apache 2.x and 1.3.x
20040815:
AFFECTS: users of net/openldap22{,-sasl}-server
AUTHOR: eik@FreeBSD.org

View File

@ -9,7 +9,8 @@
PORTNAME= apache
PORTVERSION= 2.0.50
CATEGORIES= www ipv6
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
http://sheepkiller.nerim.net/ports/${PORTNAME}/:powerlogo
DISTNAME= httpd-${PORTVERSION}
@ -77,10 +78,13 @@ WITH_HTTP_PORT?= 80
.if defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --disable-ipv6
.elif defined(WITH_IPV6_V6ONLY) && defined(WITHOUT_V4MAPPED)
CONFIGURE_ARGS+= --disable-v4-mapped
.else
CATEGORIES+= ipv6
. if defined(WITH_IPV6_V6ONLY) && defined(WITHOUT_V4MAPPED)
CONFIGURE_ARGS+= --disable-v4-mapped
. else
CONFIGURE_ARGS+= --enable-v4-mapped
. endif
.endif
.if !defined(WITHOUT_SSL)
@ -185,8 +189,10 @@ post-patch:
@${RM} -f ${WRKSRC}/docs/docroot/*.bak
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache.sh > ${WRKDIR}/apache2.sh
.if !defined(WITH_APR_FROM_PORTS)
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache2libs.sh > ${WRKDIR}/apache2libs.sh
.endif
@${RM} -f ${WRKSRC}/docs/manual/index.html.ko.euc-kr
@${REINPLACE_CMD} -e 's," PLATFORM ",FreeBSD,' \
${WRKSRC}/server/core.c
@ -205,10 +211,12 @@ pre-install:
post-install:
@${MKDIR} ${PREFIX}/etc/apache2/Includes
@${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/apache2.sh startup file."
@${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2.sh ${PREFIX}/etc/rc.d/apache2.sh
.if !defined(WITH_APR_FROM_PORTS)
@${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/000.apache2libs.sh startup file."
@${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2libs.sh ${PREFIX}/etc/rc.d/000.apache2libs.sh
.endif
@${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/apache2.sh startup file."
@${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2.sh ${PREFIX}/etc/rc.d/apache2.sh
@@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -1,5 +1,5 @@
--- docs/conf/httpd-std.conf.in.orig Sat Apr 24 20:13:43 2004
+++ docs/conf/httpd-std.conf.in Sun Jul 25 11:37:58 2004
+++ docs/conf/httpd-std.conf.in Tue Aug 17 12:11:17 2004
@@ -68,7 +68,7 @@
#
<IfModule !mpm_netware.c>
@ -34,7 +34,7 @@
</Directory>
#
@@ -365,8 +366,11 @@
@@ -365,24 +366,29 @@
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
#
@ -46,15 +46,36 @@
#
# Control access to UserDir directories. The following is an example
# for a site where these directories are restricted to read-only.
@@ -384,6 +388,8 @@
# </LimitExcept>
#</Directory>
+</IfModule>
#
-#<Directory /home/*/public_html>
-# AllowOverride FileInfo AuthConfig Limit Indexes
-# Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
-# <Limit GET POST OPTIONS PROPFIND>
-# Order allow,deny
-# Allow from all
-# </Limit>
-# <LimitExcept GET POST OPTIONS PROPFIND>
-# Order deny,allow
-# Deny from all
-# </LimitExcept>
-#</Directory>
+<Directory /home/*/public_html>
+ AllowOverride FileInfo AuthConfig Limit Indexes
+ Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
+ <Limit GET POST OPTIONS PROPFIND>
+ Order allow,deny
+ Allow from all
+ </Limit>
+ <LimitExcept GET POST OPTIONS PROPFIND>
+ Order deny,allow
+ Deny from all
+ </LimitExcept>
+</Directory>
+
+</IfModule>
#
# DirectoryIndex: sets the file that Apache will serve if a directory
# is requested.
@@ -472,7 +478,7 @@
# logged here. If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.

View File

@ -14,7 +14,7 @@ etc/apache2/mime.types-dist
@unexec if cmp -s %D/etc/apache2/ssl.conf %D/etc/apache2/ssl-std.conf; then rm -f %D/etc/apache2/ssl.conf; fi
etc/apache2/ssl-std.conf
@exec [ -f %B/ssl.conf ] || cp %B/%f %B/ssl.conf
etc/rc.d/000.apache2libs.sh
%%PORTS_APR%%etc/rc.d/000.apache2libs.sh
etc/rc.d/apache2.sh
include/apache2/ap_compat.h
include/apache2/ap_config.h

View File

@ -9,7 +9,8 @@
PORTNAME= apache
PORTVERSION= 2.0.50
CATEGORIES= www ipv6
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
http://sheepkiller.nerim.net/ports/${PORTNAME}/:powerlogo
DISTNAME= httpd-${PORTVERSION}
@ -77,10 +78,13 @@ WITH_HTTP_PORT?= 80
.if defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --disable-ipv6
.elif defined(WITH_IPV6_V6ONLY) && defined(WITHOUT_V4MAPPED)
CONFIGURE_ARGS+= --disable-v4-mapped
.else
CATEGORIES+= ipv6
. if defined(WITH_IPV6_V6ONLY) && defined(WITHOUT_V4MAPPED)
CONFIGURE_ARGS+= --disable-v4-mapped
. else
CONFIGURE_ARGS+= --enable-v4-mapped
. endif
.endif
.if !defined(WITHOUT_SSL)
@ -185,8 +189,10 @@ post-patch:
@${RM} -f ${WRKSRC}/docs/docroot/*.bak
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache.sh > ${WRKDIR}/apache2.sh
.if !defined(WITH_APR_FROM_PORTS)
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache2libs.sh > ${WRKDIR}/apache2libs.sh
.endif
@${RM} -f ${WRKSRC}/docs/manual/index.html.ko.euc-kr
@${REINPLACE_CMD} -e 's," PLATFORM ",FreeBSD,' \
${WRKSRC}/server/core.c
@ -205,10 +211,12 @@ pre-install:
post-install:
@${MKDIR} ${PREFIX}/etc/apache2/Includes
@${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/apache2.sh startup file."
@${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2.sh ${PREFIX}/etc/rc.d/apache2.sh
.if !defined(WITH_APR_FROM_PORTS)
@${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/000.apache2libs.sh startup file."
@${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2libs.sh ${PREFIX}/etc/rc.d/000.apache2libs.sh
.endif
@${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/apache2.sh startup file."
@${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2.sh ${PREFIX}/etc/rc.d/apache2.sh
@@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -1,5 +1,5 @@
--- docs/conf/httpd-std.conf.in.orig Sat Apr 24 20:13:43 2004
+++ docs/conf/httpd-std.conf.in Sun Jul 25 11:37:58 2004
+++ docs/conf/httpd-std.conf.in Tue Aug 17 12:11:17 2004
@@ -68,7 +68,7 @@
#
<IfModule !mpm_netware.c>
@ -34,7 +34,7 @@
</Directory>
#
@@ -365,8 +366,11 @@
@@ -365,24 +366,29 @@
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
#
@ -46,15 +46,36 @@
#
# Control access to UserDir directories. The following is an example
# for a site where these directories are restricted to read-only.
@@ -384,6 +388,8 @@
# </LimitExcept>
#</Directory>
+</IfModule>
#
-#<Directory /home/*/public_html>
-# AllowOverride FileInfo AuthConfig Limit Indexes
-# Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
-# <Limit GET POST OPTIONS PROPFIND>
-# Order allow,deny
-# Allow from all
-# </Limit>
-# <LimitExcept GET POST OPTIONS PROPFIND>
-# Order deny,allow
-# Deny from all
-# </LimitExcept>
-#</Directory>
+<Directory /home/*/public_html>
+ AllowOverride FileInfo AuthConfig Limit Indexes
+ Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
+ <Limit GET POST OPTIONS PROPFIND>
+ Order allow,deny
+ Allow from all
+ </Limit>
+ <LimitExcept GET POST OPTIONS PROPFIND>
+ Order deny,allow
+ Deny from all
+ </LimitExcept>
+</Directory>
+
+</IfModule>
#
# DirectoryIndex: sets the file that Apache will serve if a directory
# is requested.
@@ -472,7 +478,7 @@
# logged here. If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.

View File

@ -14,7 +14,7 @@ etc/apache2/mime.types-dist
@unexec if cmp -s %D/etc/apache2/ssl.conf %D/etc/apache2/ssl-std.conf; then rm -f %D/etc/apache2/ssl.conf; fi
etc/apache2/ssl-std.conf
@exec [ -f %B/ssl.conf ] || cp %B/%f %B/ssl.conf
etc/rc.d/000.apache2libs.sh
%%PORTS_APR%%etc/rc.d/000.apache2libs.sh
etc/rc.d/apache2.sh
include/apache2/ap_compat.h
include/apache2/ap_config.h