New port: misc/gkrellweather2

GKrellM plugin which shows weather info from the US National
    Weather

PR:		ports/45666,ports/45663
Submitted by:	Jean-Yves Lefort <jylefort@brutele.be>
This commit is contained in:
Edwin Groothuis 2002-11-24 04:14:55 +00:00
parent eb2e894826
commit 69606f2f5e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=70945
8 changed files with 104 additions and 0 deletions

View File

@ -92,6 +92,7 @@
SUBDIR += gkrellscore
SUBDIR += gkrellshoot
SUBDIR += gkrellweather
SUBDIR += gkrellweather2
SUBDIR += gkx86info
SUBDIR += gman
SUBDIR += gnome-icon-theme

View File

@ -0,0 +1,28 @@
# New ports collection makefile for: gkrellweather2
# Date Created: 24 Nov 2002
# Whom: Jean-Yves Lefort <jylefort@brutele.be>
#
# $FreeBSD$
# $Id: Makefile,v 1.1.1.1 2002/11/24 03:13:54 jylefort Exp $
#
PORTNAME= gkrellweather
PORTVERSION= 2.0.4
CATEGORIES= misc
MASTER_SITES= http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/
EXTRACT_SUFX= .tgz
MAINTAINER= jylefort@brutele.be
BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2 \
${X11BASE}/bin/GrabWeather:${PORTSDIR}/misc/wmweather
USE_X_PREFIX= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
INSTALL_DATA="${INSTALL_DATA}"
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (gkrellweather-2.0.4.tgz) = 70aeabcee21c3dc3a35ac523312b024c

View File

@ -0,0 +1,33 @@
--- Makefile.orig Sun Nov 24 04:00:54 2002
+++ Makefile Sun Nov 24 04:07:15 2002
@@ -8,24 +8,20 @@
OBJS = gkrellweather.o
+all: gkrellweather.so
+
gkrellweather.so: $(OBJS)
- $(CC) $(OBJS) -DVERSION=\"$(VERSION)\" -o gkrellweather.so $(LFLAGS) $(LIBS) -lpthread
+ ${CC} ${OBJS} ${PTHREAD_LIBS} -DVERSION=\"${VERSION}\" -o gkrellweather.so ${LFLAGS} ${LIBS}
clean:
rm -f *.o core *.so* *.bak *~
gkrellweather.o: gkrellweather.c
- $(CC) $(CFLAGS) -DVERSION=\"$(VERSION)\" -c gkrellweather.c
+ ${CC} ${CFLAGS} ${PTHREAD_CFLAGS} -DVERSION=\"$(VERSION)\" -c gkrellweather.c
install:
- if [ -d /usr/lib/gkrellm2/plugins/ ] ; then \
- install -c -s -m 644 gkrellweather.so /usr/lib/gkrellm2/plugins/ ; \
- elif [ -d /usr/local/lib/gkrellm2/plugins/ ] ; then \
- install -c -s -m 644 gkrellweather.so /usr/local/lib/gkrellm2/plugins/ ; \
- else \
- install -D -c -s -m 644 gkrellweather.so /usr/local/lib/gkrellm2/plugins/gkrellweather.so ; \
- fi
- install -c -m 755 GrabWeather /usr/local/bin
+ ${MKDIR} ${PREFIX}/libexec/gkrellm2/plugins
+ ${INSTALL_DATA} gkrellweather.so ${PREFIX}/libexec/gkrellm2/plugins
uninstall:
rm -f /usr/lib/gkrellm2/plugins/gkrellweather.so

View File

@ -0,0 +1,20 @@
--- gkrellweather.c.orig Sun Nov 24 04:49:42 2002
+++ gkrellweather.c Sun Nov 24 04:50:58 2002
@@ -720,7 +720,7 @@
options.station[1] = c[1];
options.station[2] = c[2];
options.station[3] = c[3];
- sprintf(options.command, "/usr/local/bin/GrabWeather %s", options.station);
+ sprintf(options.command, "GrabWeather %s", options.station);
sprintf(options.filename, "%s/.wmWeatherReports/%s.dat",
getenv("HOME"), options.station);
net_update = FALSE;
@@ -981,7 +981,7 @@
options.windspeed_unit = 1;
options.pressure_unit = 1;
strcpy(options.station, DEFAULT_STATION_ID);
- sprintf(options.command, "/usr/share/gkrellm/GrabWeather %s", options.station);
+ sprintf(options.command, "GrabWeather %s", options.station);
sprintf(options.filename, "%s/.wmWeatherReports/%s.dat",
getenv("HOME"), options.station);
}

View File

@ -0,0 +1 @@
GKrellWeather is a weather plugin for GKrellM

View File

@ -0,0 +1,19 @@
GKrellM plugin which shows weather info from the US National Weather
Service
Features
- Choose the location nearest to you by 4-letter METAR station
identifier code. (http://www.nws.noaa.gov/oso/siteloc.shtml)
- Monitor temperature, dew point, pressure, relative humidity, sky
condition, wind direction and speed
- Display using imperial units (degrees Fareheight, inches of
Mercury, miles per hour)
- Display using metric units (degrees Celsius, millimeters of
Mercury, kilometers per hour)
- Display pressure in kPa, hPa and mmHg
- Display wind speeds in kmph, mps and beaufort scale
WWW: http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm
- Jean-Yves Lefort
jylefort@brutele.be

View File

@ -0,0 +1 @@
libexec/gkrellm2/plugins/gkrellweather.so