Update to 1.11
This commit is contained in:
parent
d7fe9aeefb
commit
6938310ec8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=520719
@ -1,8 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= certstream
|
||||
PORTVERSION= 1.10
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.11
|
||||
CATEGORIES= security www python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
@ -22,7 +21,4 @@ USE_PYTHON= distutils autoplist concurrent
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} 's,==.*,,' ${WRKSRC}/requirements.txt
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1537604749
|
||||
SHA256 (certstream-1.10.tar.gz) = 566d59ceda3371ce5093fa985d6b6b5f11413cb3e4afa25311a890b524695548
|
||||
SIZE (certstream-1.10.tar.gz) = 9514
|
||||
TIMESTAMP = 1577106276
|
||||
SHA256 (certstream-1.11.tar.gz) = 660fdcb76c12a66a1600a0ef63701a78462f48660b6e8584002989b7d64e3a6f
|
||||
SIZE (certstream-1.11.tar.gz) = 9544
|
||||
|
@ -1,32 +0,0 @@
|
||||
--- certstream/core.py.orig 2018-03-02 11:20:56 UTC
|
||||
+++ certstream/core.py
|
||||
@@ -27,12 +27,12 @@ class CertStreamClient(WebSocketApp):
|
||||
on_error=self._on_error,
|
||||
)
|
||||
|
||||
- def _on_open(self, instance):
|
||||
+ def _on_open(self):
|
||||
logging.info("Connection established to CertStream! Listening for events...")
|
||||
if self.on_open_handler:
|
||||
- self.on_open_handler(instance)
|
||||
+ self.on_open_handler()
|
||||
|
||||
- def _on_message(self, _, message):
|
||||
+ def _on_message(self, message):
|
||||
frame = json.loads(message)
|
||||
|
||||
if frame.get('message_type', None) == "heartbeat" and self.skip_heartbeats:
|
||||
@@ -40,11 +40,11 @@ class CertStreamClient(WebSocketApp):
|
||||
|
||||
self.message_callback(frame, self._context)
|
||||
|
||||
- def _on_error(self, instance, ex):
|
||||
+ def _on_error(self, ex):
|
||||
if type(ex) == KeyboardInterrupt:
|
||||
raise
|
||||
if self.on_error_handler:
|
||||
- self.on_error_handler(instance, ex)
|
||||
+ self.on_error_handler(ex)
|
||||
logging.error("Error connecting to CertStream - {} - Sleeping for a few seconds and trying again...".format(ex))
|
||||
|
||||
def listen_for_events(message_callback, url, skip_heartbeats=True, setup_logger=True, on_open=None, on_error=None, **kwargs):
|
Loading…
Reference in New Issue
Block a user