fcitx-sunpinyin provides SunPinyin, a statistical language model based
input method engine, as a back-end to the Fcitx IM server. WWW: http://code.google.com/p/fcitx/ PR: ports/162466 Submitted by: maintainer (Zhihao Yuan) Feature safe: yes
This commit is contained in:
parent
46d27fe6b7
commit
691d0e4f4c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=285569
@ -37,6 +37,7 @@
|
||||
SUBDIR += eterm
|
||||
SUBDIR += fcitx
|
||||
SUBDIR += fcitx-configtool
|
||||
SUBDIR += fcitx-sunpinyin
|
||||
SUBDIR += fireflyttf
|
||||
SUBDIR += font-std
|
||||
SUBDIR += fortune
|
||||
|
30
chinese/fcitx-sunpinyin/Makefile
Normal file
30
chinese/fcitx-sunpinyin/Makefile
Normal file
@ -0,0 +1,30 @@
|
||||
# New ports collection makefile for: fcitx-sunpinyin
|
||||
# Date created: 10 Nov 2011
|
||||
# Whom: Zhihao Yuan <lichray@gmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= fcitx-sunpinyin
|
||||
PORTVERSION= 0.3.2
|
||||
CATEGORIES= chinese x11
|
||||
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
|
||||
|
||||
MAINTAINER= lichray@gmail.com
|
||||
COMMENT= SunPinyin support for Fcitx
|
||||
|
||||
LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx \
|
||||
sunpinyin.3:${PORTSDIR}/chinese/sunpinyin
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GETTEXT= yes
|
||||
USE_CMAKE= yes
|
||||
USE_GNOME= intltool
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
PROJECTHOST= fcitx
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
2
chinese/fcitx-sunpinyin/distinfo
Normal file
2
chinese/fcitx-sunpinyin/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (fcitx-sunpinyin-0.3.2.tar.bz2) = e22c6b64224ac7d50d62574980eaa180c9857f35c87b7450a185cd8e906a3577
|
||||
SIZE (fcitx-sunpinyin-0.3.2.tar.bz2) = 43008
|
11
chinese/fcitx-sunpinyin/files/patch-CMakeLists.txt
Normal file
11
chinese/fcitx-sunpinyin/files/patch-CMakeLists.txt
Normal file
@ -0,0 +1,11 @@
|
||||
--- CMakeLists.txt~ 2011-09-29 01:58:59.000000000 -0500
|
||||
+++ CMakeLists.txt 2011-11-10 23:22:41.804644040 -0600
|
||||
@@ -10,7 +10,7 @@ FIND_PACKAGE(Libintl REQUIRED)
|
||||
FIND_PACKAGE(Gettext REQUIRED)
|
||||
FIND_PACKAGE(Fcitx 4.1.2 REQUIRED)
|
||||
|
||||
-PKG_CHECK_MODULES(SUNPINYIN REQUIRED "sunpinyin-2.0 >= 2.0.4" )
|
||||
+PKG_CHECK_MODULES(SUNPINYIN REQUIRED "sunpinyin-2.0 >= 2.0.3" )
|
||||
|
||||
# uninstall target
|
||||
configure_file(
|
11
chinese/fcitx-sunpinyin/files/patch-src_eim.cpp
Normal file
11
chinese/fcitx-sunpinyin/files/patch-src_eim.cpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/eim.cpp.orig 2011-09-29 01:58:59.000000000 -0500
|
||||
+++ src/eim.cpp 2011-11-11 02:25:11.839864988 -0600
|
||||
@@ -229,8 +229,6 @@ INPUT_RETURN_VALUE FcitxSunpinyinGetCand
|
||||
(ppd.size() - ppd.caret() + 1) * sizeof(TWCHAR));
|
||||
memcpy(sunpinyin->input_src, src, hzlen * sizeof(TWCHAR));
|
||||
|
||||
- FcitxLog(INFO, "%d", ppd.candi_start());
|
||||
-
|
||||
sunpinyin->front_src[ppd.caret()] = 0;
|
||||
sunpinyin->end_src[ppd.size() - ppd.caret() + 1] = 0;
|
||||
sunpinyin->input_src[hzlen] = 0;
|
4
chinese/fcitx-sunpinyin/pkg-descr
Normal file
4
chinese/fcitx-sunpinyin/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
fcitx-sunpinyin provides SunPinyin, a statistical language model based
|
||||
input method engine, as a back-end to the Fcitx IM server.
|
||||
|
||||
WWW: http://code.google.com/p/fcitx/
|
7
chinese/fcitx-sunpinyin/pkg-message
Normal file
7
chinese/fcitx-sunpinyin/pkg-message
Normal file
@ -0,0 +1,7 @@
|
||||
************************************************************************
|
||||
|
||||
You probably need to remove the old configurations, i.e,
|
||||
rm -fr $HOME/.config/fcitx
|
||||
before switching to the fcitx-sunpinyin back-end!
|
||||
|
||||
************************************************************************
|
13
chinese/fcitx-sunpinyin/pkg-plist
Normal file
13
chinese/fcitx-sunpinyin/pkg-plist
Normal file
@ -0,0 +1,13 @@
|
||||
lib/fcitx/fcitx-sunpinyin.so
|
||||
share/fcitx/addon/fcitx-sunpinyin.conf
|
||||
share/fcitx/configdesc/fcitx-sunpinyin.desc
|
||||
share/fcitx/skin/classic/sunpinyin.png
|
||||
share/fcitx/skin/dark/sunpinyin.png
|
||||
share/fcitx/skin/default/sunpinyin.png
|
||||
share/icons/hicolor/128x128/apps/fcitx-sunpinyin.png
|
||||
share/icons/hicolor/16x16/apps/fcitx-sunpinyin.png
|
||||
share/icons/hicolor/22x22/apps/fcitx-sunpinyin.png
|
||||
share/icons/hicolor/24x24/apps/fcitx-sunpinyin.png
|
||||
share/icons/hicolor/32x32/apps/fcitx-sunpinyin.png
|
||||
share/icons/hicolor/48x48/apps/fcitx-sunpinyin.png
|
||||
share/locale/zh_CN/LC_MESSAGES/fcitx-sunpinyin.mo
|
Loading…
Reference in New Issue
Block a user