Fix Make fails with a 32bit architecture.

Also, add strip.

PR:		200042
Submitted by:	takefu@airport.fm
This commit is contained in:
Stephen Hurd 2016-04-08 07:31:44 +00:00
parent 8bc477a5e1
commit 69195e1f58
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=412721
2 changed files with 4 additions and 2 deletions

View File

@ -39,6 +39,8 @@ do-build:
(cd ${WRKSRC};${GMAKE})
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/wspr/WsprMod/w.so
.if defined(BOOTSTRAP)
#portlint freaks over this but it's only for dev ignore.
SVN_REV!= svn info svn://svn.code.sf.net/p/wsjt/wsjt/branches/wspr | ${GREP} Revision | cut -d' ' -f2

View File

@ -1,4 +1,4 @@
--- configure.ac.orig 2015-07-27 16:22:02 UTC
--- configure.ac.orig 2016-04-08 05:56:23 UTC
+++ configure.ac
@@ -10,18 +10,33 @@ dnl ------------------------------------
dnl path vars
@ -193,7 +193,7 @@
;;
+ *freebsd* )
+ CFLAGS="${CFLAGS} -fpic"
+ FFLAGS="-O2 -m64 -Wall -fbounds-check -fno-second-underscore \
+ FFLAGS="-O2 -m"$(/usr/bin/getconf LONG_BIT)" -Wall -fbounds-check -fno-second-underscore \
+-Wno-conversion -Wno-character-truncation -fPIC" ;;
*)
AC_MSG_ERROR([Unsupported System: ${host_os}.])