Upgrade from 4.1 to 4.2. Our patch, which tried to hardlink before

doing a full copy, is no longer needed.

Approved by:	maintainer (maho)
This commit is contained in:
Mikhail Teterin 2011-06-13 16:16:56 +00:00
parent ca998e4232
commit 68d09cd805
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=275494
3 changed files with 3 additions and 35 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= epm
PORTVERSION= 4.1
PORTREVISION= 1
PORTVERSION= 4.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_EASYSW}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
@ -21,6 +20,5 @@ GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf
MAN1= epm.1 epminstall.1 mkepmlist.1 setup.1
MAN5= epm.list.5 setup.types.5
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.mk>

View File

@ -1,3 +1,2 @@
MD5 (epm-4.1-source.tar.bz2) = 658385d63e81bfd0989f8f9b8a956c2c
SHA256 (epm-4.1-source.tar.bz2) = 960ce17836040dc64f5058186c71032c2c9c9b5f8a31b790e820900e130cb8a3
SIZE (epm-4.1-source.tar.bz2) = 452818
SHA256 (epm-4.2-source.tar.bz2) = 66c689fae292d4e390d5c52a4bcbd4b231d20dd51d309a7cb9a73d172a7d358e
SIZE (epm-4.2-source.tar.bz2) = 458362

View File

@ -1,29 +0,0 @@
Change copy_file() function to try to create a hard link instead
of copying...
Submitted to author:
http://www.epmhome.org/str.php?L21+P0+S-2+C0+I0+E0+M10+Q
-mi
--- file.c 2006-08-29 12:43:09.000000000 -0400
+++ file.c 2009-11-16 19:49:06.242283000 -0500
@@ -67,4 +67,17 @@
unlink(dst);
+ if (link(src, dst) == 0)
+ {
+ if (Verbosity > 1)
+ printf("Successfully linked %s to %s instead of copying\n",
+ src, dst);
+ return 0;
+ }
+ else
+ {
+ if (Verbosity > 1)
+ printf("Linking %s to %s failed: %s.\n\tFalling back to copying\n",
+ src, dst, strerror(errno));
+ }
if ((dstfile = fopen(dst, "wb")) == NULL)