- Update to 0.7.1_002
This commit is contained in:
parent
973d30dc90
commit
684b1c683c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=264174
@ -6,32 +6,31 @@
|
||||
#
|
||||
|
||||
PORTNAME= qpxtool
|
||||
PORTVERSION= 0.6.1
|
||||
PORTREVISION= 5
|
||||
DISTVERSION= 0.7.1_002
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= SF
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION:C/\.[^.]*$/.x/}/${DISTVERSION}
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= A GUI for testing CD/DVD quality and transfer rate
|
||||
|
||||
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_QT_VER= 3
|
||||
|
||||
MAKE_ARGS= CC="${CC}" CXX="${CXX}"
|
||||
MAKE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
|
||||
QTDIR="${QT_PREFIX}"
|
||||
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= qmake_build moc_build rcc_build linguist_build corelib gui network
|
||||
QT_NONSTANDARD= yes
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ENV= PREFIX=${PREFIX}
|
||||
USE_LDCONFIG= yes
|
||||
MANCOMPRESSED= no
|
||||
MAN8= pxcontrol.8 pxfw.8
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-Wall -g -O2||; s|/usr/local|${PREFIX}|' \
|
||||
${WRKSRC}/Makefile
|
||||
@${REINPLACE_CMD} -e '/^LDLIBS.*+=/ s|$$| -lcam|' \
|
||||
${WRKSRC}/lib/qpxtransport/Makefile
|
||||
MAN1= f1tattoo.1 cdvdcontrol.1 qscan.1 readdvd.1 qpxtool.1 qscand.1
|
||||
MAN8= pxfw.8
|
||||
MANCOMPRESSED= yes
|
||||
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} -e 's|$$(QMAKE4)|& ${QMAKEFLAGS}|' \
|
||||
${WRKSRC}/gui/Makefile
|
||||
@${REINPLACE_CMD} -e 's|S_ISBLK|S_ISCHR|' \
|
||||
${WRKSRC}/lib/qpxtransport/qpx_mmc.cpp
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,2 @@
|
||||
MD5 (qpxtool-0.6.1.tar.bz2) = 4fa7ce8aa9c13aa2db0a8b5224acb906
|
||||
SHA256 (qpxtool-0.6.1.tar.bz2) = ee0c1d0be57a4efd6e458867863fcf460ae7e155e3b674bd525ad4dcd13dcb59
|
||||
SIZE (qpxtool-0.6.1.tar.bz2) = 156636
|
||||
SHA256 (qpxtool-0.7.1_002.tar.bz2) = f77e41c494fbd046d609aec30f21dc8752f00853f8607d3825289ca332d0a2e0
|
||||
SIZE (qpxtool-0.7.1_002.tar.bz2) = 494438
|
||||
|
46
sysutils/qpxtool/files/patch-configure
Normal file
46
sysutils/qpxtool/files/patch-configure
Normal file
@ -0,0 +1,46 @@
|
||||
--- configure.orig 2010-03-27 19:25:38.000000000 +0300
|
||||
+++ configure 2010-04-25 07:56:54.000000000 +0400
|
||||
@@ -13,10 +13,10 @@
|
||||
OSLIBS_DL=""
|
||||
OSLIBS_THREAD=""
|
||||
|
||||
-__cc=cc
|
||||
-__cxx=c++
|
||||
-__defprefix=""
|
||||
-__prefix=""
|
||||
+__cc=${CC}
|
||||
+__cxx=${CXX}
|
||||
+__defprefix="${PREFIX}"
|
||||
+__prefix="${PREFIX}"
|
||||
__enable_debug=no
|
||||
__enable_png=yes
|
||||
__enable_gui=yes
|
||||
@@ -261,8 +261,8 @@
|
||||
|
||||
" >> Makefile
|
||||
|
||||
- echo "CXXFLAGS += -Wall -O2 $OSDEFS $LPNG_DEFS $PLUGIN_DEFS $DEFS" >> Makefile
|
||||
- echo "CFLAGS += -Wall -O2 $OSDEFS $LPNG_DEFS $PLUGIN_DEFS $DEFS" >> Makefile
|
||||
+ echo "CXXFLAGS += -Wall $OSDEFS $LPNG_DEFS $PLUGIN_DEFS $DEFS" >> Makefile
|
||||
+ echo "CFLAGS += -Wall $OSDEFS $LPNG_DEFS $PLUGIN_DEFS $DEFS" >> Makefile
|
||||
|
||||
if test "$__enable_debug" = "yes" ; then
|
||||
echo "# additional debug options" >> Makefile
|
||||
@@ -407,7 +407,7 @@
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
- echo " lrelease -verbose qpxtool.pro" >> $mf
|
||||
+ echo " lrelease-qt4 -verbose qpxtool.pro" >> $mf
|
||||
|
||||
echo "
|
||||
clean: Makefile.qmake
|
||||
@@ -765,7 +765,7 @@
|
||||
__libdir=$__prefix/lib
|
||||
__plugindir=$__libdir/qpxtool
|
||||
__incdir=$__prefix/include
|
||||
- __mandir=$__prefix/share/man
|
||||
+ __mandir=$__prefix/man
|
||||
;;
|
||||
mingw32*)
|
||||
__bindir=$__prefix
|
@ -1,11 +0,0 @@
|
||||
--- qpxtool-gui/Makefile.orig 2007-08-19 18:04:14.000000000 +0400
|
||||
+++ qpxtool-gui/Makefile 2008-04-10 22:06:05.000000000 +0400
|
||||
@@ -15,7 +15,7 @@
|
||||
CONFIG+="thread" \
|
||||
INCLUDEPATH+="../lib/include" \
|
||||
LIBS+="-lqpxtransport -lqpxplextor -lqpxpioneer -lqpxscan" \
|
||||
- LIBPATH+="../lib/lib"
|
||||
+ LIBPATH="../lib/lib \$${LIBPATH}"
|
||||
|
||||
install: Makefile.qmake
|
||||
install -m 4755 qpxtool $(DESTDIR)$(BINDIR)
|
@ -1,31 +1,51 @@
|
||||
bin/deadreader
|
||||
bin/pioquiet
|
||||
bin/pxcontrol
|
||||
bin/pxfw
|
||||
bin/cdvdcontrol
|
||||
bin/f1tattoo
|
||||
bin/qpxtool
|
||||
include/common_functions.h
|
||||
include/media_check_benq.h
|
||||
include/media_check_benq_rom.h
|
||||
include/media_check_generic.h
|
||||
include/media_check_liteon.h
|
||||
include/media_check_nec.h
|
||||
include/media_check_pioneer.h
|
||||
include/pioneer_spdctl.h
|
||||
include/plextor_features.h
|
||||
include/plextor_qcheck.h
|
||||
include/qpx_mmc.h
|
||||
include/qpx_opcodes.h
|
||||
include/qpx_transport.h
|
||||
include/scan_pointers.h
|
||||
bin/qscan
|
||||
bin/qscand
|
||||
bin/readdvd
|
||||
include/qpxtool/common_functions.h
|
||||
include/qpxtool/pioneer_spdctl.h
|
||||
include/qpxtool/plextor_features.h
|
||||
include/qpxtool/qpx_mmc.h
|
||||
include/qpxtool/qpx_scan.h
|
||||
include/qpxtool/qpx_scan_plugin_api.h
|
||||
include/qpxtool/qpx_transport.h
|
||||
include/qpxtool/qpx_writer.h
|
||||
include/qpxtool/sense.h
|
||||
include/qpxtool/threads.h
|
||||
include/qpxtool/yamaha_features.h
|
||||
lib/libqpxpioneer.so
|
||||
lib/libqpxpioneer.so.0
|
||||
lib/libqpxpioneer.so.0.6.0
|
||||
lib/libqpxpioneer.so.0.7.0
|
||||
lib/libqpxplextor.so
|
||||
lib/libqpxplextor.so.0
|
||||
lib/libqpxplextor.so.0.6.1
|
||||
lib/libqpxplextor.so.0.7.0
|
||||
lib/libqpxscan.so
|
||||
lib/libqpxscan.so.0
|
||||
lib/libqpxscan.so.0.6.1
|
||||
lib/libqpxscan.so.0.7.0
|
||||
lib/libqpxtransport.so
|
||||
lib/libqpxtransport.so.0
|
||||
lib/libqpxtransport.so.0.6.3
|
||||
lib/libqpxtransport.so.0.7.0
|
||||
lib/libqpxyamaha.so
|
||||
lib/libqpxyamaha.so.0
|
||||
lib/libqpxyamaha.so.0.7.0
|
||||
lib/qpxtool/libqscan_asus.so
|
||||
lib/qpxtool/libqscan_benq.so
|
||||
lib/qpxtool/libqscan_benq_dvdrom.so
|
||||
lib/qpxtool/libqscan_generic.so
|
||||
lib/qpxtool/libqscan_liteon.so
|
||||
lib/qpxtool/libqscan_nec.so
|
||||
lib/qpxtool/libqscan_pioneer.so
|
||||
lib/qpxtool/libqscan_plextor.so
|
||||
lib/qpxtool/libqscan_tsst.so
|
||||
sbin/pxfw
|
||||
share/applications/qpxtool.desktop
|
||||
share/pixmaps/qpxtool.png
|
||||
%%DATADIR%%/locale/qpxtool.ru_RU.qm
|
||||
%%DATADIR%%/locale/qpxtool.de_DE.qm
|
||||
@dirrm %%DATADIR%%/locale
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrmtry share/applications
|
||||
@dirrm lib/qpxtool
|
||||
@dirrm include/qpxtool
|
||||
|
Loading…
Reference in New Issue
Block a user