Changed to use REINPLACE

Fixed build under 5.0

PR:		46528
Submitted by:	Hendrik Scholz <hendrik@scholz.net>
This commit is contained in:
Mark Pulford 2003-02-01 01:29:32 +00:00
parent fa25120540
commit 682e45d4ad
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=74398
2 changed files with 17 additions and 4 deletions

View File

@ -13,6 +13,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/0$//}
MAINTAINER= markp@FreeBSD.org
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOMENG= yes
@ -21,10 +22,12 @@ MAKE_ARGS+= PREFIX="${PREFIX}"
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
post-patch:
${PERL} -pi -e "s@CC = gcc@CC = ${CC}@g; s@-O3 -ansi -Wall@${CFLAGS} -Wall@g; \
s@PREFIX = /usr/local@PREFIX = ${PREFIX}@g; \
s@gtk-config@${GTK_CONFIG}@g; s@-lgtk@-lgtk12@g; \
s@-c -g kmem -m 2755 -o root@-s -c -g kmem -m 2755 -o root@g" ${WRKSRC}/Makefile
${REINPLACE_CMD} -e "s@CC = gcc@CC = ${CC}@g; \
s@-O3 -ansi -Wall@${CFLAGS} -Wall@g; \
s@PREFIX = /usr/local@PREFIX = ${PREFIX}@g; \
s@gtk-config@${GTK_CONFIG}@g; s@-lgtk@-lgtk12@g; \
s@-c -g kmem -m 2755 -o root@-s -c -g kmem -m 2755 -o root@g" \
${WRKSRC}/Makefile
post-install:
${MKDIR} ${EXAMPLESDIR}

View File

@ -0,0 +1,10 @@
--- sys_freebsd.c.orig Mon Apr 16 14:14:53 2001
+++ sys_freebsd.c Sat Feb 1 11:39:45 2003
@@ -19,6 +19,7 @@
#include <kvm.h>
#include <fcntl.h>
+#include <sys/types.h>
#include <sys/dkstat.h>
#include <sys/vmmeter.h>
#include <stdlib.h>