Update to 0.7.43.

Tidy up for portlint.

PR:		ports/93921
Submitted by:	Rainer Alves <rainer.alves@gmail.com>
Approved by:	holger <holger@e-gitt.net> (maintainer)
This commit is contained in:
Sam Lawrance 2006-05-02 23:14:18 +00:00
parent 70ecc7953d
commit 681e14389b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=161222
6 changed files with 61 additions and 70 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= avifile
PORTVERSION= 0.7.41
PORTREVISION= 1
PORTVERSION= 0.7.43
PORTEPOCH= 2
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@ -20,10 +19,11 @@ COMMENT= AVI player/converter with numerous codecs, including MPEG-4(DivX ;-))
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USE_SUBMAKE= yes
USE_REINPLACE= yes
USE_BZIP2= yes
USE_XLIB= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
USE_ICONV= yes
INSTALLS_SHLIB= yes
LIBTOOLFILES= acinclude.m4
@ -46,8 +46,6 @@ CODEC_DETECTION_FILE!= ${MAKE} -f ${CODEC_PORT}/Makefile -V CODEC_DETECTION_FILE
LIB_VERSION= 3
VERSION= 0.7
DIFF?= /usr/bin/diff
FMT?= /usr/bin/fmt
# qt -- USE_QT_VER has to happen befor bsd.port.pre.mk
.if !defined(WITHOUT_QT)
@ -71,7 +69,7 @@ WITH_OPTIMIZED_CFLAGS= yes
.if (${ARCH} != "i386") && (${ARCH} != "amd64")
WITHOUT_A52=yes
BROKEN= "Does not compile on !i386"
BROKEN= Does not compile on !i386
.endif
# compilation optimizations

View File

@ -1,3 +1,3 @@
MD5 (avifile-0.7-0.7.41.tar.gz) = a08911965d81a02ded95ddb95f63e1cf
SHA256 (avifile-0.7-0.7.41.tar.gz) = 9abb8d50564ab5cb84215c22aaa23521ba1ed2f4bef7c3b647eff4d0c72a7285
SIZE (avifile-0.7-0.7.41.tar.gz) = 3498203
MD5 (avifile-0.7-0.7.43.tar.bz2) = 821adfba2606773764aa29fcf14eb51f
SHA256 (avifile-0.7-0.7.43.tar.bz2) = bd1e802b994f682176a635a041c66129af2651a812355004c63952f66189c6f7
SIZE (avifile-0.7-0.7.43.tar.bz2) = 2980827

View File

@ -1,5 +1,5 @@
--- configure.orig Tue Oct 5 14:25:48 2004
+++ configure Tue Oct 5 14:26:14 2004
+++ configure Mon Feb 27 20:58:48 2006
@@ -3768,7 +3768,7 @@
case "$target" in
@ -9,3 +9,15 @@
cat >>confdefs.h <<\_ACEOF
#define ARCH_X86 1
@@ -32127,7 +32127,10 @@
AMM_USE_ARTSC_FALSE=
fi
-last_cvs_update=`find . -name Entries -printf '%Ty%Tm%Td-%TH:%TM\n' | sort | tail -1`
+#
+# find(1) doesn't support the `printf` argument on FreeBSD
+#
+# last_cvs_update=`find . -name Entries -printf '%Ty%Tm%Td-%TH:%TM\n' | sort | tail -1`
if test $? -ne 0 -o -z "$last_cvs_update" ; then
# probably no gnu date installed(?), use current date
# or this is release

View File

@ -1,9 +1,9 @@
--- ffmpeg/libavformat/allformats.c.orig Wed Jan 22 17:38:35 2003
+++ ffmpeg/libavformat/allformats.c Wed Jan 22 17:37:03 2003
@@ -55,6 +55,7 @@
#ifndef CONFIG_WIN32
ffm_init();
+++ ffmpeg/libavformat/allformats.c Mon Feb 27 20:12:55 2006
@@ -87,6 +87,7 @@
#endif
ffm_init();
+#undef CONFIG_VIDEO4LINUX
#ifdef CONFIG_VIDEO4LINUX
video_grab_init();

View File

@ -1,19 +0,0 @@
--- lib/subtitle/subread.c.orig Tue Oct 5 15:47:53 2004
+++ lib/subtitle/subread.c Tue Oct 5 15:49:02 2004
@@ -100,12 +100,14 @@
if (sl->lines < SUBTITLE_MAX_LINES && txt)
{
int n = 0;
- char* b = trim_spaces(txt);
+ char* b;
+ char* t;
+ b = trim_spaces(txt);
trim_http(b);
// skip color and font-style change - not supported right now
// {c:$00ffff} {y:i}
- char* t = strchr(b, '{');
+ t = strchr(b, '{');
if (t)
{
char u = toupper(t[1]);

View File

@ -117,43 +117,43 @@ lib/libaviplayavformat.so.0
%%QT%%lib/libqavm.so.0
libdata/pkgconfig/avifile.pc
share/aclocal/avifile.m4
share/avifile/action.cfg
share/doc/avifile/avicap/avicap.html
share/doc/avifile/avicap/configuration.html
share/doc/avifile/avicap/epg.html
share/doc/avifile/avicap/shutdown_resume.html
share/doc/avifile/avicap/timertable.html
share/doc/avifile/COPYING
share/doc/avifile/CREDITS
share/doc/avifile/EXCEPTIONS
share/doc/avifile/FreeBSD
share/doc/avifile/ChangeLog
share/doc/avifile/KNOWN_BUGS
share/doc/avifile/LICENSING
share/doc/avifile/README
share/doc/avifile/README.ac3pass
share/doc/avifile/README-DEVEL
share/doc/avifile/TODO
share/doc/avifile/VIDEO-PERFORMANCE
share/doc/avifile/WARNINGS
share/avifile/pixmaps/about.ppm
share/avifile/pixmaps/bottom.ppm
share/avifile/pixmaps/down.ppm
share/avifile/pixmaps/mute.ppm
share/avifile/pixmaps/open.ppm
share/avifile/pixmaps/opena.ppm
share/avifile/pixmaps/opens.ppm
share/avifile/pixmaps/pause.ppm
share/avifile/pixmaps/play.ppm
share/avifile/pixmaps/stop.ppm
share/avifile/pixmaps/test.png
share/avifile/pixmaps/test.xpm
share/avifile/pixmaps/top.ppm
share/avifile/pixmaps/up.ppm
@dirrm share/doc/avifile/avicap
@dirrm share/doc/avifile
@dirrm share/avifile/pixmaps
@dirrm share/avifile
%%DATADIR%%/action.cfg
%%DOCSDIR%%/avicap/avicap.html
%%DOCSDIR%%/avicap/configuration.html
%%DOCSDIR%%/avicap/epg.html
%%DOCSDIR%%/avicap/shutdown_resume.html
%%DOCSDIR%%/avicap/timertable.html
%%DOCSDIR%%/COPYING
%%DOCSDIR%%/CREDITS
%%DOCSDIR%%/EXCEPTIONS
%%DOCSDIR%%/FreeBSD
%%DOCSDIR%%/ChangeLog
%%DOCSDIR%%/KNOWN_BUGS
%%DOCSDIR%%/LICENSING
%%DOCSDIR%%/README
%%DOCSDIR%%/README.ac3pass
%%DOCSDIR%%/README-DEVEL
%%DOCSDIR%%/TODO
%%DOCSDIR%%/VIDEO-PERFORMANCE
%%DOCSDIR%%/WARNINGS
%%DATADIR%%/pixmaps/about.ppm
%%DATADIR%%/pixmaps/bottom.ppm
%%DATADIR%%/pixmaps/down.ppm
%%DATADIR%%/pixmaps/mute.ppm
%%DATADIR%%/pixmaps/open.ppm
%%DATADIR%%/pixmaps/opena.ppm
%%DATADIR%%/pixmaps/opens.ppm
%%DATADIR%%/pixmaps/pause.ppm
%%DATADIR%%/pixmaps/play.ppm
%%DATADIR%%/pixmaps/stop.ppm
%%DATADIR%%/pixmaps/test.png
%%DATADIR%%/pixmaps/test.xpm
%%DATADIR%%/pixmaps/top.ppm
%%DATADIR%%/pixmaps/up.ppm
@dirrm %%DOCSDIR%%/avicap
@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%
@dirrmtry lib/avifile/vidix
@dirrm lib/avifile
@dirrm include/avifile