Add webkit2-gtk3 2.6.4.

This port only supplies the WebKit2 library for gtk3, and has some API changes.
The webkitgtk project switch to cmake. Due to issues I don't understand
  yet we can't use USES=cmake yet.
Use USES=compiler:c++11-lib to replace custom dancing around with clang
  and OSVERSION.
Make 8.x as IGNORE, because of c++ and other issues.
This commit is contained in:
Koop Mast 2014-12-25 21:10:27 +00:00
parent 15e41c0813
commit 67ec4d9e63
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=375603
11 changed files with 546 additions and 0 deletions

View File

@ -2139,6 +2139,7 @@
SUBDIR += webkit-qt4
SUBDIR += webkit-qt5
SUBDIR += webkit-sharp
SUBDIR += webkit2-gtk3
SUBDIR += weblint
SUBDIR += weblint++
SUBDIR += webmachine

104
www/webkit2-gtk3/Makefile Normal file
View File

@ -0,0 +1,104 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
PORTNAME= webkit
PORTVERSION= 2.6.4
CATEGORIES= www
MASTER_SITES= http://webkitgtk.org/releases/
PKGNAMESUFFIX= 2-gtk3
DISTNAME= ${PORTNAME}gtk-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Opensource browser engine using the GTK+ 3 toolkit
BUILD_DEPENDS= geoclue>=0:${PORTSDIR}/net/geoclue
LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libwebp.so:${PORTSDIR}/graphics/webp \
libpng15.so:${PORTSDIR}/graphics/png \
libsecret-1.so:${PORTSDIR}/security/libsecret \
libharfbuzz.so:${PORTSDIR}/print/harfbuzz \
libsoup-2.4.so:${PORTSDIR}/devel/libsoup
#add libicu
RUN_DEPENDS= geoclue>=0:${PORTSDIR}/net/geoclue
USE_GSTREAMER1= yes
USE_XORG= x11 xext ice
# when it USES=cmake safe
USES= bison compiler:c++11-lib gettext gmake gperf perl5 \
pkgconfig python:2 tar:xz
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS=yes
USE_GNOME= cairo gtk20 gtk30 introspection:build \
libxml2 libxslt:build
USE_GL= gl egl
USE_SQLITE= 3
USE_PERL5= build
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
BUILD_DEPENDS+= cmake:${PORTSDIR}/devel/cmake
#USES=cmake is not used because it triggers:
#Linking CXX executable ../../../bin/jsc
#../../../lib/libjavascriptcoregtk-4.0.so.18.0.8: undefined reference to `JSC::JSCell::inherits(JSC::ClassInfo const*) const'
#../../../lib/libjavascriptcoregtk-4.0.so.18.0.8: undefined reference to `JSC::JSCell::structure() const'
#c++: error: linker command failed with exit code 1 (use -v to see invocation)
#Source/JavaScriptCore/shell/CMakeFiles/jsc.dir/build.make:94: recipe for target 'bin/jsc' failed
# there is something in CMAKE_ENV that cause this ... but what.
CMAKE_ARGS+= -DPORT=GTK
CMAKE_ENV+= XDG_CACHE_HOME=${WRKDIR} \
CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
CC="${CC}" CXX="${CXX}" CPP="${CPP}"
#CMAKE_ARGS+= -DCMAKE_VERBOSE_MAKEFILE=1
#MAKE_ARGS+= V=1 VERBOSE=1
BROWSER_PLUGINS_DIR?= ${LOCALBASE}/lib/browser_plugins/symlinks/webkit-gtk3
#_BROWSER_PLUGINS_DIR= ${BROWSER_PLUGINS_DIR:S|^/|"|:S|/|", "|g}",
OPTIONS_DEFINE= DEBUG FULLDEBUG
DEBUG_DESC= Just enable debug symbols
FULLDEBUG_DESC= Enable asserts and other debug support
FULLDEBUG_CONFIGURE_ENABLE= debug
DEBUG_CONFIGURE_ON= --enable-debug-symbols=yes
DEBUG_CONFIGURE_OFF= --disable-debug-symbols
.include <bsd.port.options.mk>
.if ${OSVERSION} < 900000
IGNORE= Not supported on 8.x due to c++ madness
.endif
.if ${ARCH} == powerpc64
CFLAGS+= -mminimal-toc
.endif
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= flex>=0:${PORTSDIR}/textproc/flex
CONFIGURE_ENV+= FLEX_PATH="${LOCALBASE}/bin/flex"
.endif
post-patch:
@${REINPLACE_CMD} -e 's|%%BROWSER_PLUGINS_DIR%%|${BROWSER_PLUGINS_DIR}|' \
${WRKSRC}/Source/WebCore/plugins/PluginDatabase.cpp
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} CFLAGS="${CFLAGS}" \
${CMAKE_ENV} cmake -DPORT=GTK ${CMAKE_ARGS}
post-install:
${MV} ${STAGEDIR}${PREFIX}/bin/jsc \
${STAGEDIR}/${PREFIX}/bin/jsc-4
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so.*
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/webkit2gtk-4.0/injected-bundle/*.so
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/jsc-4
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/webkit2gtk-4.0/WebKit*
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
SHA256 (webkitgtk-2.6.4.tar.xz) = beef5e24edd9b9cade22d80bf373c74d236f996fe30f49f8697a70f267772e9b
SIZE (webkitgtk-2.6.4.tar.xz) = 9996524

View File

@ -0,0 +1,11 @@
--- Source/JavaScriptCore/PlatformGTK.cmake.orig 2014-12-25 20:19:12.049673483 +0100
+++ Source/JavaScriptCore/PlatformGTK.cmake 2014-12-25 20:20:42.328667491 +0100
@@ -10,7 +10,7 @@
ADD_TYPELIB(${CMAKE_BINARY_DIR}/JavaScriptCore-${WEBKITGTK_API_VERSION}.typelib)
install(FILES "${CMAKE_BINARY_DIR}/Source/JavaScriptCore/javascriptcoregtk-${WEBKITGTK_API_VERSION}.pc"
- DESTINATION "${LIB_INSTALL_DIR}/pkgconfig"
+ DESTINATION "${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig"
)
install(FILES API/JavaScript.h

View File

@ -0,0 +1,16 @@
$OpenBSD: patch-Source_JavaScriptCore_jit_ExecutableAllocator_h,v 1.1 2013/04/13 09:11:02 landry Exp $
https://bugs.webkit.org/show_bug.cgi?id=61137
--- Source/JavaScriptCore/jit/ExecutableAllocator.h.orig 2013-06-11 09:39:47.000000000 +0200
+++ Source/JavaScriptCore/jit/ExecutableAllocator.h 2013-08-07 09:25:56.000000000 +0200
@@ -105,7 +105,8 @@
#if ENABLE(EXECUTABLE_ALLOCATOR_FIXED)
#if CPU(ARM)
static const size_t fixedExecutableMemoryPoolSize = 16 * 1024 * 1024;
-#elif CPU(X86_64)
+// We don't want an initial allocation of 1GB, it's above the default ulimit
+#elif CPU(X86_64) && !defined(__OpenBSD__) && !defined(__FreeBSD__)
static const size_t fixedExecutableMemoryPoolSize = 1024 * 1024 * 1024;
#else
static const size_t fixedExecutableMemoryPoolSize = 32 * 1024 * 1024;

View File

@ -0,0 +1,10 @@
--- Source/WebCore/plugins/PluginDatabase.cpp.orig 2011-01-11 16:24:29.000000000 +0000
+++ Source/WebCore/plugins/PluginDatabase.cpp 2011-01-11 16:24:54.000000000 +0000
@@ -375,6 +375,7 @@ Vector<String> PluginDatabase::defaultPl
userPluginPath.append(String("/.netscape/plugins"));
paths.append(userPluginPath);
+ paths.append("%%BROWSER_PLUGINS_DIR%%");
paths.append("/usr/lib/browser/plugins");
paths.append("/usr/local/lib/mozilla/plugins");
paths.append("/usr/lib/firefox/plugins");

View File

@ -0,0 +1,11 @@
--- Source/WebKit2/PlatformGTK.cmake.orig 2014-12-25 20:23:07.749658406 +0100
+++ Source/WebKit2/PlatformGTK.cmake 2014-12-25 20:23:43.409739634 +0100
@@ -837,7 +837,7 @@
)
install(FILES "${CMAKE_BINARY_DIR}/Source/WebKit2/webkit2gtk-${WEBKITGTK_API_VERSION}.pc"
"${CMAKE_BINARY_DIR}/Source/WebKit2/webkit2gtk-web-extension-${WEBKITGTK_API_VERSION}.pc"
- DESTINATION "${LIB_INSTALL_DIR}/pkgconfig"
+ DESTINATION "${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig"
)
install(FILES ${WebKit2GTK_INSTALLED_HEADERS}
${WebKit2WebExtension_INSTALLED_HEADERS}

View File

@ -0,0 +1,11 @@
--- Source/JavaScriptCore/assembler/ARMAssembler.h.orig 2014-12-15 04:13:43.336068961 +0000
+++ Source/JavaScriptCore/assembler/ARMAssembler.h 2014-12-15 04:13:49.213068201 +0000
@@ -1121,6 +1121,8 @@
linuxPageFlush(current, end);
#elif OS(WINCE)
CacheRangeFlush(code, size, CACHE_SYNC_ALL);
+#elif CPU(ARM_TRADITIONAL) && OS(FREEBSD) && COMPILER(CLANG)
+ __clear_cache(code, reinterpret_cast<char*>(code) + size);
#else
#error "The cacheFlush support is missing on this platform."
#endif

View File

@ -0,0 +1,54 @@
2014-10-15 Ting-Wei Lan <lantw44@gmail.com>
+ [GTK] Use LD_LIBRARY_PATH to make g-ir-scanner use the newly-built
+ version of libraries when running the temporary executable
+ https://bugs.webkit.org/show_bug.cgi?id=136018
+
+ Reviewed by NOBODY (OOPS!).
+
+ This patch modifies LD_LIBRARY_PATH to make sure the dynamic linker
+ find the correct version of libraries when running the temporary
+ executable to generate the .gir file.
+
+ * PlatformGTK.cmake:
+
+2014-10-15 Ting-Wei Lan <lantw44@gmail.com>
+
[GTK] LDFLAGS is ignored when running g-ir-scanner
https://bugs.webkit.org/show_bug.cgi?id=136018
--- Source/WebKit2/PlatformGTK.cmake
+++ Source/WebKit2/PlatformGTK.cmake
@@ -731,11 +731,24 @@ foreach (linker_flag ${INTROSPECTION_ADDITIONAL_LINKER_FLAGS})
endif ()
endforeach (linker_flag)
+# Add ${CMAKE_LIBRARY_OUTPUT_DIRECTORY} to LD_LIBRARY_PATH
+string(COMPARE EQUAL "$ENV{LD_LIBRARY_PATH}" "" ld_library_path_not_exist)
+if (ld_library_path_does_not_exist)
+ set(INTROSPECTION_ADDITIONAL_LIBRARY_PATH
+ "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}"
+ )
+else ()
+ set(INTROSPECTION_ADDITIONAL_LIBRARY_PATH
+ "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}:$ENV{LD_LIBRARY_PATH}"
+ )
+endif ()
+
add_custom_command(
OUTPUT ${CMAKE_BINARY_DIR}/WebKit2-${WEBKITGTK_API_VERSION}.gir
DEPENDS WebKit2
DEPENDS ${CMAKE_BINARY_DIR}/JavaScriptCore-${WEBKITGTK_API_VERSION}.gir
COMMAND CC=${CMAKE_C_COMPILER} CFLAGS=-Wno-deprecated-declarations LDFLAGS=
+ LD_LIBRARY_PATH="${INTROSPECTION_ADDITIONAL_LIBRARY_PATH}"
${INTROSPECTION_SCANNER}
--quiet
--warn-all
@@ -775,6 +788,7 @@ add_custom_command(
DEPENDS ${CMAKE_BINARY_DIR}/JavaScriptCore-${WEBKITGTK_API_VERSION}.gir
DEPENDS ${CMAKE_BINARY_DIR}/WebKit2-${WEBKITGTK_API_VERSION}.gir
COMMAND CC=${CMAKE_C_COMPILER} CFLAGS=-Wno-deprecated-declarations LDFLAGS=
+ LD_LIBRARY_PATH="${INTROSPECTION_ADDITIONAL_LIBRARY_PATH}"
${INTROSPECTION_SCANNER}
--quiet
--warn-all

View File

@ -0,0 +1,5 @@
WebKit is an open source web browser engine. It is able to display content
such as HTML, SVG, XML, and others. It also supports DOM, XMLHttpRequest,
XSLT, CSS, Javascript/ECMAscript and more.
WWW: http://webkit.org/

321
www/webkit2-gtk3/pkg-plist Normal file
View File

@ -0,0 +1,321 @@
bin/jsc-4
include/webkitgtk-4.0/JavaScriptCore/JSBase.h
include/webkitgtk-4.0/JavaScriptCore/JSContextRef.h
include/webkitgtk-4.0/JavaScriptCore/JSObjectRef.h
include/webkitgtk-4.0/JavaScriptCore/JSStringRef.h
include/webkitgtk-4.0/JavaScriptCore/JSValueRef.h
include/webkitgtk-4.0/JavaScriptCore/JavaScript.h
include/webkitgtk-4.0/JavaScriptCore/WebKitAvailability.h
include/webkitgtk-4.0/webkit2/WebKitAuthenticationRequest.h
include/webkitgtk-4.0/webkit2/WebKitBackForwardList.h
include/webkitgtk-4.0/webkit2/WebKitBackForwardListItem.h
include/webkitgtk-4.0/webkit2/WebKitContextMenu.h
include/webkitgtk-4.0/webkit2/WebKitContextMenuActions.h
include/webkitgtk-4.0/webkit2/WebKitContextMenuItem.h
include/webkitgtk-4.0/webkit2/WebKitCookieManager.h
include/webkitgtk-4.0/webkit2/WebKitCredential.h
include/webkitgtk-4.0/webkit2/WebKitDefines.h
include/webkitgtk-4.0/webkit2/WebKitDownload.h
include/webkitgtk-4.0/webkit2/WebKitEditingCommands.h
include/webkitgtk-4.0/webkit2/WebKitEnumTypes.h
include/webkitgtk-4.0/webkit2/WebKitError.h
include/webkitgtk-4.0/webkit2/WebKitFaviconDatabase.h
include/webkitgtk-4.0/webkit2/WebKitFileChooserRequest.h
include/webkitgtk-4.0/webkit2/WebKitFindController.h
include/webkitgtk-4.0/webkit2/WebKitFormSubmissionRequest.h
include/webkitgtk-4.0/webkit2/WebKitForwardDeclarations.h
include/webkitgtk-4.0/webkit2/WebKitFrame.h
include/webkitgtk-4.0/webkit2/WebKitGeolocationPermissionRequest.h
include/webkitgtk-4.0/webkit2/WebKitHitTestResult.h
include/webkitgtk-4.0/webkit2/WebKitJavascriptResult.h
include/webkitgtk-4.0/webkit2/WebKitMimeInfo.h
include/webkitgtk-4.0/webkit2/WebKitNavigationAction.h
include/webkitgtk-4.0/webkit2/WebKitNavigationPolicyDecision.h
include/webkitgtk-4.0/webkit2/WebKitPermissionRequest.h
include/webkitgtk-4.0/webkit2/WebKitPlugin.h
include/webkitgtk-4.0/webkit2/WebKitPolicyDecision.h
include/webkitgtk-4.0/webkit2/WebKitPrintOperation.h
include/webkitgtk-4.0/webkit2/WebKitResponsePolicyDecision.h
include/webkitgtk-4.0/webkit2/WebKitScriptDialog.h
include/webkitgtk-4.0/webkit2/WebKitScriptWorld.h
include/webkitgtk-4.0/webkit2/WebKitSecurityManager.h
include/webkitgtk-4.0/webkit2/WebKitSettings.h
include/webkitgtk-4.0/webkit2/WebKitURIRequest.h
include/webkitgtk-4.0/webkit2/WebKitURIResponse.h
include/webkitgtk-4.0/webkit2/WebKitURISchemeRequest.h
include/webkitgtk-4.0/webkit2/WebKitUserContent.h
include/webkitgtk-4.0/webkit2/WebKitUserContentManager.h
include/webkitgtk-4.0/webkit2/WebKitVersion.h
include/webkitgtk-4.0/webkit2/WebKitWebContext.h
include/webkitgtk-4.0/webkit2/WebKitWebExtension.h
include/webkitgtk-4.0/webkit2/WebKitWebInspector.h
include/webkitgtk-4.0/webkit2/WebKitWebPage.h
include/webkitgtk-4.0/webkit2/WebKitWebResource.h
include/webkitgtk-4.0/webkit2/WebKitWebView.h
include/webkitgtk-4.0/webkit2/WebKitWebViewBase.h
include/webkitgtk-4.0/webkit2/WebKitWindowProperties.h
include/webkitgtk-4.0/webkit2/webkit-web-extension.h
include/webkitgtk-4.0/webkit2/webkit2.h
include/webkitgtk-4.0/webkitdom/WebKitDOMAttr.h
include/webkitgtk-4.0/webkitdom/WebKitDOMAttrUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMAudioTrack.h
include/webkitgtk-4.0/webkitdom/WebKitDOMAudioTrackList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMBarProp.h
include/webkitgtk-4.0/webkitdom/WebKitDOMBatteryManager.h
include/webkitgtk-4.0/webkitdom/WebKitDOMBlob.h
include/webkitgtk-4.0/webkitdom/WebKitDOMBlobUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMCDATASection.h
include/webkitgtk-4.0/webkitdom/WebKitDOMCSSRule.h
include/webkitgtk-4.0/webkitdom/WebKitDOMCSSRuleList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMCSSRuleUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMCSSStyleDeclaration.h
include/webkitgtk-4.0/webkitdom/WebKitDOMCSSStyleSheet.h
include/webkitgtk-4.0/webkitdom/WebKitDOMCSSValue.h
include/webkitgtk-4.0/webkitdom/WebKitDOMCharacterData.h
include/webkitgtk-4.0/webkitdom/WebKitDOMCharacterDataUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMComment.h
include/webkitgtk-4.0/webkitdom/WebKitDOMCustom.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMApplicationCache.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMImplementation.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMMimeType.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMMimeTypeArray.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMNamedFlowCollection.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMPlugin.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMPluginArray.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMSecurityPolicy.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMSelection.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMSettableTokenList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMStringList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMStringMap.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMTokenList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMWindow.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMWindowCSS.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMWindowSpeechSynthesis.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDOMWindowUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDataCue.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDatabase.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDocument.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDocumentFragment.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDocumentFragmentUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDocumentType.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDocumentTypeUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMDocumentUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMEntityReference.h
include/webkitgtk-4.0/webkitdom/WebKitDOMEvent.h
include/webkitgtk-4.0/webkitdom/WebKitDOMEventTarget.h
include/webkitgtk-4.0/webkitdom/WebKitDOMEventUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMFile.h
include/webkitgtk-4.0/webkitdom/WebKitDOMFileList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMGamepad.h
include/webkitgtk-4.0/webkitdom/WebKitDOMGamepadList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMGeolocation.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLAnchorElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLAnchorElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLAppletElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLAreaElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLAreaElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLAudioElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLBRElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLBaseElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLBaseFontElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLBodyElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLButtonElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLButtonElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLCanvasElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLCollection.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLDListElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLDetailsElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLDirectoryElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLDivElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLDocument.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLEmbedElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLFieldSetElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLFieldSetElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLFontElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLFormElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLFormElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLFrameElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLFrameSetElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLHRElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLHeadElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLHeadingElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLHtmlElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLHtmlElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLIFrameElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLIFrameElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLImageElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLImageElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLInputElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLInputElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLKeygenElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLLIElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLLabelElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLLabelElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLLegendElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLLinkElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLMapElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLMarqueeElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLMarqueeElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLMediaElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLMenuElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLMetaElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLModElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLOListElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLOListElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLObjectElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLObjectElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLOptGroupElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLOptionElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLOptionsCollection.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLParagraphElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLParamElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLPreElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLQuoteElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLScriptElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLScriptElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLSelectElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLSelectElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLStyleElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTableCaptionElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTableCellElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTableColElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTableElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTableElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTableRowElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTableSectionElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTextAreaElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTextAreaElementUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTitleElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLUListElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLVideoElement.h
include/webkitgtk-4.0/webkitdom/WebKitDOMHistory.h
include/webkitgtk-4.0/webkitdom/WebKitDOMKeyboardEvent.h
include/webkitgtk-4.0/webkitdom/WebKitDOMLocation.h
include/webkitgtk-4.0/webkitdom/WebKitDOMMediaController.h
include/webkitgtk-4.0/webkitdom/WebKitDOMMediaError.h
include/webkitgtk-4.0/webkitdom/WebKitDOMMediaList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMMediaQueryList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMMessagePort.h
include/webkitgtk-4.0/webkitdom/WebKitDOMMouseEvent.h
include/webkitgtk-4.0/webkitdom/WebKitDOMMouseEventUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMNamedNodeMap.h
include/webkitgtk-4.0/webkitdom/WebKitDOMNavigator.h
include/webkitgtk-4.0/webkitdom/WebKitDOMNode.h
include/webkitgtk-4.0/webkitdom/WebKitDOMNodeFilter.h
include/webkitgtk-4.0/webkitdom/WebKitDOMNodeIterator.h
include/webkitgtk-4.0/webkitdom/WebKitDOMNodeList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMObject.h
include/webkitgtk-4.0/webkitdom/WebKitDOMPerformance.h
include/webkitgtk-4.0/webkitdom/WebKitDOMPerformanceEntry.h
include/webkitgtk-4.0/webkitdom/WebKitDOMPerformanceEntryList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMPerformanceNavigation.h
include/webkitgtk-4.0/webkitdom/WebKitDOMPerformanceTiming.h
include/webkitgtk-4.0/webkitdom/WebKitDOMProcessingInstruction.h
include/webkitgtk-4.0/webkitdom/WebKitDOMRange.h
include/webkitgtk-4.0/webkitdom/WebKitDOMRangeUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMScreen.h
include/webkitgtk-4.0/webkitdom/WebKitDOMSpeechSynthesis.h
include/webkitgtk-4.0/webkitdom/WebKitDOMSpeechSynthesisEvent.h
include/webkitgtk-4.0/webkitdom/WebKitDOMSpeechSynthesisUtterance.h
include/webkitgtk-4.0/webkitdom/WebKitDOMSpeechSynthesisVoice.h
include/webkitgtk-4.0/webkitdom/WebKitDOMStorage.h
include/webkitgtk-4.0/webkitdom/WebKitDOMStorageInfo.h
include/webkitgtk-4.0/webkitdom/WebKitDOMStorageQuota.h
include/webkitgtk-4.0/webkitdom/WebKitDOMStyleMedia.h
include/webkitgtk-4.0/webkitdom/WebKitDOMStyleSheet.h
include/webkitgtk-4.0/webkitdom/WebKitDOMStyleSheetList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMText.h
include/webkitgtk-4.0/webkitdom/WebKitDOMTextTrack.h
include/webkitgtk-4.0/webkitdom/WebKitDOMTextTrackCue.h
include/webkitgtk-4.0/webkitdom/WebKitDOMTextTrackCueList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMTextTrackList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMTimeRanges.h
include/webkitgtk-4.0/webkitdom/WebKitDOMTouch.h
include/webkitgtk-4.0/webkitdom/WebKitDOMTrackEvent.h
include/webkitgtk-4.0/webkitdom/WebKitDOMTreeWalker.h
include/webkitgtk-4.0/webkitdom/WebKitDOMUIEvent.h
include/webkitgtk-4.0/webkitdom/WebKitDOMUIEventUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMVTTCue.h
include/webkitgtk-4.0/webkitdom/WebKitDOMValidityState.h
include/webkitgtk-4.0/webkitdom/WebKitDOMVideoPlaybackQuality.h
include/webkitgtk-4.0/webkitdom/WebKitDOMVideoTrack.h
include/webkitgtk-4.0/webkitdom/WebKitDOMVideoTrackList.h
include/webkitgtk-4.0/webkitdom/WebKitDOMWebKitNamedFlow.h
include/webkitgtk-4.0/webkitdom/WebKitDOMWebKitPoint.h
include/webkitgtk-4.0/webkitdom/WebKitDOMWheelEvent.h
include/webkitgtk-4.0/webkitdom/WebKitDOMWheelEventUnstable.h
include/webkitgtk-4.0/webkitdom/WebKitDOMXPathExpression.h
include/webkitgtk-4.0/webkitdom/WebKitDOMXPathNSResolver.h
include/webkitgtk-4.0/webkitdom/WebKitDOMXPathResult.h
include/webkitgtk-4.0/webkitdom/webkitdom.h
include/webkitgtk-4.0/webkitdom/webkitdomdefines-unstable.h
include/webkitgtk-4.0/webkitdom/webkitdomdefines.h
lib/girepository-1.0/JavaScriptCore-4.0.typelib
lib/girepository-1.0/WebKit2-4.0.typelib
lib/girepository-1.0/WebKit2WebExtension-4.0.typelib
lib/libjavascriptcoregtk-4.0.so
lib/libjavascriptcoregtk-4.0.so.18
lib/libjavascriptcoregtk-4.0.so.18.0.8
lib/libwebkit2gtk-4.0.so
lib/libwebkit2gtk-4.0.so.37
lib/libwebkit2gtk-4.0.so.37.2.5
libdata/pkgconfig/javascriptcoregtk-4.0.pc
libdata/pkgconfig/webkit2gtk-4.0.pc
libdata/pkgconfig/webkit2gtk-web-extension-4.0.pc
lib/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
libexec/webkit2gtk-4.0/WebKitNetworkProcess
libexec/webkit2gtk-4.0/WebKitPluginProcess
libexec/webkit2gtk-4.0/WebKitPluginProcess2
libexec/webkit2gtk-4.0/WebKitWebProcess
share/gir-1.0/JavaScriptCore-4.0.gir
share/gir-1.0/WebKit2-4.0.gir
share/gir-1.0/WebKit2WebExtension-4.0.gir
share/locale/ar/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/as/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/bg/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/cs/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/de/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/el/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/en_CA/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/en_GB/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/eo/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/es/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/et/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/eu/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/fr/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/gl/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/gu/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/he/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/hi/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/hu/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/id/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/it/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/ja/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/kn/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/ko/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/lt/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/lv/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/ml/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/mr/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/nb/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/nl/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/or/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/pa/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/pl/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/pt/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/pt_BR/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/ro/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/ru/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/sl/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/sr/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/sr@latin/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/sv/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/ta/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/te/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/uk/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/vi/LC_MESSAGES/WebKit2GTK-4.0.mo
share/locale/zh_CN/LC_MESSAGES/WebKit2GTK-4.0.mo