- Crashfix patch.
- Bump portrevision. PR: 236443 Submitted by: rsmith@xs4all.nl
This commit is contained in:
parent
68079c60d0
commit
67c079774e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=495313
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= netgen
|
||||
PORTVERSION= 5.3.1
|
||||
PORTREVISION= 8
|
||||
PORTREVISION= 9
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= SF/netgen-mesher/netgen-mesher/${PORTVERSION:C|\.[[:digit:]]+$||}/
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- configure.orig 2014-10-06 11:04:36 UTC
|
||||
+++ configure
|
||||
@@ -9219,7 +9219,7 @@ $as_echo_n "checking whether the $compil
|
||||
@@ -9219,7 +9219,7 @@ $as_echo_n "checking whether the $compiler linker ($LD
|
||||
hardcode_minus_L=no
|
||||
hardcode_shlibpath_var=unsupported
|
||||
inherit_rpath=no
|
||||
@ -45,7 +45,7 @@
|
||||
else
|
||||
ld_shlibs=no
|
||||
fi
|
||||
@@ -10142,7 +10142,7 @@ $as_echo "$lt_cv_irix_exported_symbol" >
|
||||
@@ -10142,7 +10142,7 @@ $as_echo "$lt_cv_irix_exported_symbol" >&6; }
|
||||
hardcode_direct_absolute=yes
|
||||
if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`" || test "$host_os-$host_cpu" = "openbsd2.8-powerpc"; then
|
||||
archive_cmds='$CC -shared $pic_flag -o $lib $libobjs $deplibs $compiler_flags'
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- libsrc/csg/Makefile.am.orig 2014-08-29 09:54:06 UTC
|
||||
+++ libsrc/csg/Makefile.am
|
||||
@@ -5,7 +5,7 @@ polyhedra.hpp specpoin.hpp csg.hpp expli
|
||||
@@ -5,7 +5,7 @@ polyhedra.hpp specpoin.hpp csg.hpp explicitcurve2d.hpp
|
||||
revolution.hpp spline3d.hpp vscsg.hpp
|
||||
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- libsrc/csg/Makefile.in.orig 2014-10-06 11:04:37 UTC
|
||||
+++ libsrc/csg/Makefile.in
|
||||
@@ -285,7 +285,7 @@ meshsurf.hpp solid.hpp triapprox.hpp csg
|
||||
@@ -285,7 +285,7 @@ meshsurf.hpp solid.hpp triapprox.hpp csgeom.hpp edgefl
|
||||
polyhedra.hpp specpoin.hpp csg.hpp explicitcurve2d.hpp identify.hpp \
|
||||
revolution.hpp spline3d.hpp vscsg.hpp
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- libsrc/visualization/Makefile.in.orig 2016-04-21 11:00:04 UTC
|
||||
--- libsrc/visualization/Makefile.in.orig 2014-10-06 11:04:37 UTC
|
||||
+++ libsrc/visualization/Makefile.in
|
||||
@@ -275,7 +275,7 @@ noinst_HEADERS = meshdoc.hpp mvdraw.hpp
|
||||
@@ -275,7 +275,7 @@ noinst_HEADERS = meshdoc.hpp mvdraw.hpp vispar.hpp \
|
||||
visual.hpp vssolution.hpp
|
||||
|
||||
include_HEADERS = soldata.hpp
|
||||
|
@ -8,7 +8,7 @@
|
||||
|
||||
|
||||
if NGGUI
|
||||
@@ -22,7 +22,7 @@ netgen_LDADD = $(top_builddir)/libsrc/vi
|
||||
@@ -22,7 +22,7 @@ netgen_LDADD = $(top_builddir)/libsrc/visualization/li
|
||||
$(top_builddir)/libsrc/csg/libcsg.la \
|
||||
$(top_builddir)/libsrc/interface/libinterface.la \
|
||||
$(top_builddir)/libsrc/meshing/libmesh.la \
|
||||
|
@ -9,7 +9,7 @@
|
||||
netgen_SOURCES = demoview.cpp ngappinit.cpp onetcl.cpp parallelfunc.cpp ngpkg.cpp demoview.hpp parallelfunc.hpp togl_1_7.h
|
||||
@NGMKL_TRUE@MKL_LIBS = -L$(MKLROOT)/lib/intel64 -lmkl_intel_lp64 -lmkl_gnu_thread -lmkl_core -lmkl_def
|
||||
# -lpardiso500-GNU472-X86-64 -lgfortran
|
||||
@@ -312,7 +312,7 @@ netgen_LDADD = $(top_builddir)/libsrc/vi
|
||||
@@ -312,7 +312,7 @@ netgen_LDADD = $(top_builddir)/libsrc/visualization/li
|
||||
$(top_builddir)/libsrc/csg/libcsg.la \
|
||||
$(top_builddir)/libsrc/interface/libinterface.la \
|
||||
$(top_builddir)/libsrc/meshing/libmesh.la \
|
||||
|
11
cad/netgen/files/patch-ng_drawing.tcl
Normal file
11
cad/netgen/files/patch-ng_drawing.tcl
Normal file
@ -0,0 +1,11 @@
|
||||
--- ng/drawing.tcl.orig 2019-03-10 18:49:31 UTC
|
||||
+++ ng/drawing.tcl
|
||||
@@ -11,7 +11,7 @@ set oldmousey 0
|
||||
# use this one for Togl 2.0
|
||||
# if {[catch {togl .ndraw -width 400 -height 300 -rgba true -double true -depth true -privatecmap false -stereo false -indirect true -create init -display draw -reshape reshape }] } {
|
||||
|
||||
-if {[catch {togl .ndraw -width 400 -height 300 -rgba true -double true -depth true -privatecmap false -stereo false -indirect true }] } { puts "no OpenGL"
|
||||
+if {[catch {togl .ndraw -width 400 -height 300 -rgba true -double true -depth true -privatecmap false -stereo false -indirect false }] } { puts "no OpenGL"
|
||||
} {
|
||||
#
|
||||
pack .ndraw -expand true -fill both -padx 10 -pady 10
|
@ -1,6 +1,6 @@
|
||||
--- nglib/Makefile.in.orig 2014-10-06 11:04:37 UTC
|
||||
+++ nglib/Makefile.in
|
||||
@@ -129,7 +129,7 @@ LTCXXCOMPILE = $(LIBTOOL) --tag=CXX $(AM
|
||||
@@ -129,7 +129,7 @@ LTCXXCOMPILE = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS)
|
||||
CXXLD = $(CXX)
|
||||
CXXLINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
|
||||
--mode=link $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) \
|
||||
|
Loading…
Reference in New Issue
Block a user