- Fix a segmentation fault

- Bump PORTREVISION
- Respect CC and CFLAGS

PR:		129042
Submitted by:	zlopi.ru <zlopi.ru@gmail.com>
This commit is contained in:
Emanuel Haupt 2008-11-27 22:36:52 +00:00
parent 5b7e27c17d
commit 67bd9e3586
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=223471
3 changed files with 21 additions and 5 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= poptop
PORTVERSION= 1.3.4
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -18,9 +18,9 @@ COMMENT= Windows 9x compatible PPTP (VPN) server
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
MAKE_ENV+= CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}"
USE_RC_SUBR= pptpd.sh

View File

@ -0,0 +1,16 @@
--- plugins/Makefile.orig 2006-08-03 04:02:01.000000000 +0200
+++ plugins/Makefile 2008-11-27 22:19:48.000000000 +0100
@@ -1,10 +1,10 @@
-CC = gcc
-COPTS = -O2 -g
+CC ?= gcc
+CPP ?= $(CXX)
CFLAGS = $(COPTS) -I.. -I../../include -fPIC
LDFLAGS = -shared
LDADD = -lutil
INSTALL = install -o root
-prefix = /usr/local
+prefix = $(PREFIX)
PLUGINS = pptpd-logwtmp.so

View File

@ -1,5 +1,5 @@
--- pptpd.c.orig Tue Sep 5 01:17:25 2006
+++ pptpd.c Tue Jul 31 08:19:38 2007
--- pptpd.c.orig 2006-09-05 01:17:25.000000000 +0200
+++ pptpd.c 2008-11-27 22:09:53.000000000 +0100
@@ -98,18 +98,21 @@
printf(" [-i] [--noipparam] Suppress the passing of the client's IP address\n");
printf(" to PPP, which is done by default otherwise.\n");
@ -22,7 +22,7 @@
#endif
printf(" [-t] [--stimeout seconds] Specifies the timeout for the first packet. This is a DOS protection\n");
- printf(" (default is 10).\n");
+ printf(" (default is %s).\n",STIMEOUT_DEFAULT);
+ printf(" (default is %d).\n",STIMEOUT_DEFAULT);
printf(" [-v] [--version] Displays the pptpd version number.\n");
printf(" [-w] [--logwtmp] Update wtmp as users login.\n");
printf(" [-C] [--connections n] Limit on number of connections.\n");