Fix build with clang 3.8.0 (and gcc >= 4.9.0).

This changes the XMM intrinsincs detection logic.

Submitted by:	dim
PR:		206620
This commit is contained in:
Alexander Leidinger 2016-01-29 22:16:08 +00:00
parent b4ae92eed5
commit 67bd1fee85
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=407500
2 changed files with 66 additions and 1 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= lame
PORTVERSION= 3.99.5
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME:tl}/3.99

View File

@ -0,0 +1,65 @@
--- configure.in.orig 2012-02-28 19:50:27.000000000 +0100
+++ configure.in 2016-01-25 20:15:46.034842000 +0100
@@ -96,9 +96,19 @@
sys/soundcard.h \
sys/time.h \
unistd.h \
- xmmintrin.h \
linux/soundcard.h)
+dnl Checks for actually working SSE intrinsics
+AC_MSG_CHECKING(working SSE intrinsics)
+AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [[#include <xmmintrin.h>]],
+ [[_mm_sfence();]])],
+ [AC_DEFINE([HAVE_XMMINTRIN_H], [1], [Define if SSE intrinsics work.])
+ ac_cv_header_xmmintrin_h=yes],
+ [ac_cv_header_xmmintrin_h=no])
+AC_MSG_RESULT(${ac_cv_header_xmmintrin_h})
+
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_C_INLINE
--- configure.orig 2012-02-28 19:54:37.000000000 +0100
+++ configure 2016-01-25 20:16:07.429512000 +0100
@@ -11922,7 +11918,6 @@
sys/soundcard.h \
sys/time.h \
unistd.h \
- xmmintrin.h \
linux/soundcard.h
do :
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
@@ -11937,6 +11932,31 @@
done
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking working SSE intrinsics" >&5
+$as_echo_n "checking working SSE intrinsics... " >&6; }
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+#include <xmmintrin.h>
+int
+main ()
+{
+_mm_sfence();
+ ;
+ return 0;
+}
+_ACEOF
+if ac_fn_c_try_compile "$LINENO"; then :
+
+$as_echo "#define HAVE_XMMINTRIN_H 1" >>confdefs.h
+
+ ac_cv_header_xmmintrin_h=yes
+else
+ ac_cv_header_xmmintrin_h=no
+fi
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ${ac_cv_header_xmmintrin_h}" >&5
+$as_echo "${ac_cv_header_xmmintrin_h}" >&6; }
+
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for an ANSI C-conforming const" >&5
$as_echo_n "checking for an ANSI C-conforming const... " >&6; }
if ${ac_cv_c_const+:} false; then :